source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 6328

Revision 6328, 18.6 KB checked in by munepi, 12 years ago (diff)

updated to 1.1; built with ffmpeg-0.11.1; added some skins

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5#% global with_ffmpeg 1
6%global ffmpegver 0.11.1
7
8#% global svndate  20120525
9#% global dvbappver 0.98
10
11%define codecdir   %{_libdir}/codecs
12
13%global ttfontdir   %{_datadir}/fonts
14%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
15                    TrueType-sazanami-gothic/sazanami-gothic
16
17Summary:        The Movie Player
18Summary(ja):    動画プレイヤー
19Name:           mplayer
20Version:        1.1
21Release:        1%{?svndate:.%svndate}%{?_dist_release}
22Source0:        http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
23#Source0:       mplayer-export-%{svndate}.tar.xz
24Source1:        http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
25
26Source10:       mplayer-snapshot-vine.sh
27
28Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
29Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
30Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
31Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
32
33# ## DVB app.
34# ## 0.9.8
35# Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0799.zip
36
37# set defaults for Vine Linux
38#Patch2:         %{name}-config.patch
39#Patch2:         %{name}-config-20120525-vine.patch
40Patch2:         %{name}-1.1-config-vine.patch
41# use roff include statements instead of symlinks
42Patch8:         %{name}-1.1-manlinks.patch
43# erase any trace of libdvdcss
44Patch14:        %{name}-1.1-nodvdcss.patch
45# use system FFmpeg libraries
46Patch18:        %{name}-1.1-ffmpeg.patch
47
48## Vine
49
50
51%if 0%{!?_without_amr:1}
52License:        GPLv3+
53%else
54License:        GPLv2+
55%endif
56Group:          Applications/Multimedia
57URL:            http://www.mplayerhq.hu/
58
59BuildRequires:  SDL-devel
60BuildRequires:  aalib-devel
61BuildRequires:  alsa-lib-devel
62BuildRequires:  cdparanoia-devel
63BuildRequires:  desktop-file-utils
64##!!BuildRequires:  em8300-devel
65BuildRequires:  libdvdnav-devel
66BuildRequires:  enca-devel
67BuildRequires:  fontconfig-devel
68BuildRequires:  freetype2-devel >= 2.0.9
69BuildRequires:  fribidi-devel
70BuildRequires:  giflib-devel
71BuildRequires:  gtk2-devel
72BuildRequires:  mesa-libGL-devel
73BuildRequires:  libXinerama-devel
74BuildRequires:  libXScrnSaver-devel
75BuildRequires:  libXv-devel
76BuildRequires:  libXvMC-devel
77BuildRequires:  libXxf86dga-devel
78BuildRequires:  libXxf86vm-devel
79BuildRequires:  libass-devel
80BuildRequires:  libpng-devel
81BuildRequires:  libjpeg-devel
82BuildRequires:  libdvdread
83BuildRequires:  libmpcdec-devel >= 1.2.1
84BuildRequires:  librtmp-devel >= 2.3
85BuildRequires:  speex-devel >= 1.1
86%{?with_vaapi:BuildRequires:libva-devel}
87BuildRequires:  libvdpau-devel
88BuildRequires:  libvorbis-devel
89%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
90BuildRequires:  lzo-devel >= 2
91BuildRequires:  pulseaudio-lib-devel
92BuildRequires:  speex-devel >= 1.1
93BuildRequires:  twolame-devel
94BuildRequires:  xorg-x11-devel
95BuildRequires:  yasm
96BuildRequires:  zlib-devel
97
98# *-devel packages provided by other self-build-* should only be listed
99# in self-build-%{name}.spec as PreReq.
100##Requires:     self-build-mplayer-codecs
101##BuildRequires:        self-build-libdvdcss
102##BuildRequires:  self-build-lame
103##BuildRequires:  self-build-libdca
104##BuildRequires:  self-build-x264 >= 0.0.0-15.20110322
105##BuildRequires:  self-build-xvidcore >= 0.9.2
106##BuildRequires:  self-build-faad2 >= 2.6.1
107##BuildRequires:  self-build-libmpeg2
108
109Requires:       TrueType-vlgothic
110Requires:       mesa-libGL
111
112BuildRoot:      %{_tmppath}/%{name}-%{version}-root
113
114Obsoletes:      mplayer < %{version}-%{release}
115
116%description
117MPlayer can play most standard video formats out of the box and almost
118all others with the help of external codecs.
119MPlayer currently works best from the command line, but visual feedback
120for many functions is available from its onscreen status display (OSD),
121which is also used for displaying subtitles.
122MPlayer also has a GUI with skin support and several unofficial alternative
123graphical frontends are available.
124
125MEncoder is a command line video encoder for advanced users that can
126be built from the MPlayer source tree. Unofficial graphical frontends
127exist but arenot included.
128
129MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
130support for some newer codecs are not yet inpmlemented.
131You should install mplayer-codecs package if you want to play videos
132using those new codecs.
133
134%description -l ja
135MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
136またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
137で再生できます。
138現在の MPlayer はコマンドラインから使うのが一番便利ですが、
139多くの操作は字幕と同様に、
140オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
141MPlayer には スキンを変更できる GUI も用意されていますし、
142また複数の非公式なフロントエンドも利用できます。
143
144MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
145非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
146
147MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
148を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
149いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
150をインストールする必要があります。
151
152
153%prep
154#% setup -q -n mplayer-export-%{svndate}
155%setup -q -n MPlayer-%{version}
156%__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
157
158%patch2 -p1 -b .vine
159%patch8 -p1 -b .manlinks
160%patch14 -p1 -b .nodvdcss
161%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
162
163# ## apply the DVB app. patches
164# unzip %{SOURCE100}
165# patch -p1 < mplayer-patches-%{dvbappver}/0014-check-the-decoded-result-of-PCE.patch || exit 1
166
167
168%build
169./configure \
170    --prefix=%{_prefix} \
171    --bindir=%{_bindir} \
172    --datadir=%{_datadir}/mplayer \
173    --mandir=%{_mandir} \
174    --confdir=%{_sysconfdir}/mplayer \
175    --libdir=%{_libdir} \
176    --codecsdir=%{codecdir} \
177    \
178    --extra-cflags="$RPM_OPT_FLAGS" \
179    --language=ja,en \
180    --enable-joystick \
181    --enable-gui --enable-menu \
182    --enable-radio --enable-radio-capture \
183    --enable-runtime-cpudetection \
184    --enable-unrarexec \
185    \
186    --disable-dvdread-internal \
187    --disable-libdvdcss-internal \
188    --disable-nemesi \
189    \
190    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
191    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
192    %{!?with_faac:--disable-faac} \
193    --disable-libmpeg2-internal \
194    --disable-libopenjpeg \
195    \
196    --disable-bitmap-font \
197    --disable-dga1 --disable-dga2 \
198    --disable-directfb \
199    --disable-svga \
200    --disable-termcap \
201    --enable-xvmc \
202    --with-xvmclib=XvMCW \
203    \
204    --disable-arts --disable-esd --disable-jack --disable-openal \
205    --disable-live \
206    ;
207
208%{__make} V=1 %{?_smp_mflags}
209
210%install
211%{__rm} -rf ${RPM_BUILD_ROOT}
212%{__make} install INSTALLSTRIP= \
213    prefix=${RPM_BUILD_ROOT}%{_prefix} \
214    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
215    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
216    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
217    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
218    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
219    ;
220
221## install some default config files
222%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
223%{__install} -pm 644 etc/example.conf \
224    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
225%{__install} -pm 644 etc/{input,menu,codecs}.conf \
226    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
227
228# # Icons
229# for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
230#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
231#     install -pm 644 etc/mplayer$iconsize.png \
232#         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
233# done
234
235# install skins and set the default skin
236%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
237pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
238  for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
239    %__tar xf ${x} || exit 1
240  done
241  %__ln_s Blue default || exit 1
242popd
243
244# make sybolic link to ttf font for subtitle
245for i in %{ttfontlist}; do
246    if [ -e %{ttfontdir}/$i.ttf ];then
247        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
248        break;
249    fi;
250done
251
252## install TOOLS
253for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
254%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
255done
256
257for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
258%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
259done
260
261for file in vobshift.py ; do
262%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
263done
264
265%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
266%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
267
268
269%clean
270%{__rm} -rf ${RPM_BUILD_ROOT}
271
272%post
273touch --no-create %{_datadir}/icons/hicolor
274if [ -x %{_bindir}/gtk-update-icon-cache ]; then
275  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
276fi
277%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
278
279%postun
280%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
281touch --no-create %{_datadir}/icons/hicolor
282if [ -x %{_bindir}/gtk-update-icon-cache ]; then
283  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
284fi || :
285
286
287%files
288%defattr(-,root,root)
289#%doc AUTHORS Changelog Copyright LICENSE README
290%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
291%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
292%config(noreplace) %{_sysconfdir}/mplayer/input.conf
293%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
294%{_bindir}/mplayer
295%{_bindir}/gmplayer
296%{_bindir}/mencoder
297%{_datadir}/mplayer/skins/default
298%{_datadir}/mplayer/skins/Blue
299%{_datadir}/mplayer/skins/Blue-small
300%{_datadir}/mplayer/skins/OSX-Mod
301%{_datadir}/mplayer/skins/standard
302%{_datadir}/mplayer/subfont.ttf
303%{_datadir}/applications/mplayer.desktop
304%{_datadir}/icons/hicolor/*/apps/mplayer.png
305%{_mandir}/man1/mplayer.1*
306%{_mandir}/man1/mencoder.1*
307## TOOLS
308%{_bindir}/aconvert
309%{_bindir}/calcbpp
310%{_bindir}/countquant
311%{_bindir}/divx2svcd
312%{_bindir}/dvd2divxscript
313%{_bindir}/mencvcd
314%{_bindir}/midentify
315%{_bindir}/mpconsole
316%{_bindir}/qepdvcd
317%{_bindir}/subsearch
318%{_bindir}/vobshift
319%{_datadir}/mplayer/*.fp
320
321
322%changelog
323* Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
324- updated to 1.1
325  - built with ffmpeg-0.11.1
326- added some skins
327
328* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
329- updated snapshot 20120525 with ffmpeg 0.11
330
331* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
332- updated snapshot 20120102
333
334* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
335- updated snapshot 20111217 (with ffmpeg 0.9)
336
337* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
338- s/self-build-libdvdnav/libdvdnav/
339
340* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
341- updated %%SOURCE1
342  - update to 1.8
343
344* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
345- dropped BuildRequires: esound-devel
346
347* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
348- new upstream release
349  - ready for Vine Linux 6
350  - revived support for Vine Linux 5
351- added BuildRequires:
352  - libass-devel
353  - librtmp-devel >= 2.3
354  - speex-devel >= 1.1
355
356* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
357- added BuildRequires:
358  - aalib-devel
359  - enca-devel
360  - lzo-devel
361  - speex-devel
362
363* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
364- updated fixed %{name}-config.patch
365  - applied %{name}-config-20100709-vine.patch
366
367* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
368- change release to sync with self-build-mplayer
369
370* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
371- updated source snapshot 20100709
372- renamed %%Source10 to mplayer-snapshot-vine.sh
373- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
374- added BuildRequires: libvpx-devel >= 0.9.1
375
376* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
377- updated source snapshot 20100621
378
379* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
380- updated source snapshot 20100615
381- added BuildRequires: libXinerama-devel
382- dropped vl4 support
383
384* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
385- updated source snapshot 20100410
386
387* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
388- updated source snapshot 20100401
389
390* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
391- updated source snapshot 20100326
392
393* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
394- updated source snapshot 20100317
395
396* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
397- updated source snapshot 20100216
398- moved scripts from TOOLS
399- added --disable-libopenjpeg in configure options
400
401* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
402- updated source snapshot 20100201
403- dropped obsolete patches
404- added BuildRequires:
405  - libvdpau-devel
406  - libXScrnSaver-devel
407
408* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
409- update mplayer-config-20091215-vine.patch
410- update mplayer-20091215-x86_32-compile.patch
411- added --enable-runtime-cpudetection in configure options
412
413* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
414- source snapshot 20091031
415  - updated mplayer-20091031-x86_32-compile.patch
416
417* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
418- source snapshot 20091003
419
420* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
421- change release to sync with self-build-mplayer
422
423* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
424- source snapshot 20090905
425- added settings for vl6
426
427* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
428- source snapshot 20090821
429- replaced BR: libungif-devel with BR: giflib-devel
430
431* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
432- source snapshot 20090722
433
434* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
435- source snapshot 20090702
436
437* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
438- source snapshot 20090611
439
440* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
441- added Requires: TrueType-vlgothic
442
443* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
444- source snapshot 20090522
445  - build with x264 >= 0.0.0-9.20090522
446  - updated mplayer-20090522-nodvdcss.patch
447
448* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
449- change release to sync with self-build-mplayer
450
451* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
452- source snapshot 20090502
453- updated mplayer-20090503-x86_32-compile.patch
454- updated mplayer-20090502-nodvdcss.patch
455
456* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
457- applied mplayer-config-vine.patch
458
459* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
460- source snapshot 20090327
461- updated mplayer-20090327-x86_32-compile.patch
462- updated mplayer-20090325-nodvdcss.patch
463- dropped gmplayer-about-vine.patch
464- install some default config files
465- added configure options:
466  - --disable-termcap
467  - --enable-xvmc
468  - --with-xvmclib=XvMCW
469- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
470- fixed %%files for *.conf
471
472* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
473- source snapshot 20090305
474
475* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
476- source snapshot 20090227
477
478* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
479- source snapshot 20090216
480
481* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
482- source snapshot 20090206
483- dropped mplayer-man-zh_CN.patch
484- updated mplayer-20090206-nodvdcss.patch
485- changed to PreReq:  self-build-faad2 from faad2-devel
486- added PreReq:  self-build-libmad
487
488* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
489- source snapshot 20090131
490
491* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
492- change release to sync with self-build-mplayer
493
494* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
495- source snapshot
496- update mplayer-20090122-nodvdcss.patch
497- added BuildRequires:
498  - faad2-devel
499  - libmpcdec-devel
500  - twolame-devel
501  - yasm
502  - faac-devel (as PreReq in self-build-%{name})
503  - lame-devel (as PreReq in self-build-%{name})
504  - libdca-devel (as PreReq in self-build-%{name})
505  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
506  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
507
508* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
509- source snapshot
510- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
511  --disable-faad-internal in configure options
512- dropped gmplayer-add-flv-extension.patch
513
514* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
515- source snapshot
516- fixed License
517- added some patches from RPM Fusion
518- updated gmplayer-about-vine.patch for 20081001 snapshot
519- added BuildRequires:  libdvdread
520- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
521- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
522  in configure options
523#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
524
525* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
526- fixed License
527- added some devel packages to support OpenGL
528
529* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
530- spec in utf8
531- fix sybolic link of subfont for vl5
532
533* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
534- add "Patch105: CVE-2008-1558.patch".
535
536* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
537- build with new versioning policy.
538- fix Source[01] URLs.
539- add "Patch200: gmplayer-about-vine.patch".
540- add "Patch201: gmplayer-add-flv-extension.patch".
541
542* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
543- add four official security patches (CVE-2008-0485, CVE-2008-0486,
544  CVE-2008-0629, CVE-2008-0630)
545- add mplayer-1.0rc2-20080211-stream_cddb.patch
546
547* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
548- change source download URL. <BTS:VineLinux:603>
549
550* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
551- fix CONFDIR for make install. <BTS:wishes:33>
552
553* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
554- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.