source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 5297

Revision 5297, 18.9 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5# define with_ffmpeg 1
6
7%global name    mplayer
8%global version 1.0
9# define extver rc4
10%global svndate  20111210
11%global release 45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
12
13# define dvbappver 0.95
14
15%global ttfontdir   /usr/share/fonts
16%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
17                    TrueType-sazanami-gothic/sazanami-gothic
18
19Summary:        The Movie Player
20Summary(ja):    動画プレイヤー
21Name:           %{name}
22Version:        %{version}
23Release:        %{release}
24#Source0:       http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
25Source0:        mplayer-export-%{svndate}.tar.xz
26Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
27Source10:       mplayer-snapshot-vine.sh
28
29## DVB app.
30## 0.9.5
31# Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0624.zip
32## 0.9.5 -> 0.9.6
33# Source101: http://2sen.dip.jp/cgi-bin/dtvup/source/up0658.zip
34
35#Patch2:         %{name}-config.patch
36Patch2:         %{name}-config-20111217-vine.patch
37Patch8:         %{name}-manlinks.patch
38Patch14:        %{name}-nodvdcss.patch
39Patch18:        %{name}-ffmpeg.patch
40
41## Vine
42# Patch50:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
43# Patch101:      mplayer-1.0rc4-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
44# Patch102:      mplayer-1.0rc4-0002-add-support-for-audio-channel-reconfiguration.patch
45# Patch103:      mplayer-1.0rc4-0003-add-support-for-dual-mono-auto-selection-and-switchi.patch
46# Patch106:      mplayer-1.0rc4-0006-add-support-for-S2API-tuning-with-a-new-channels.con.patch
47# Patch107:      mplayer-1.0rc4-0007-add-BCAS-descrambling-feature.patch
48# Patch111:      mplayer-1.0rc4-ffmpeg-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
49# Patch113:      mplayer-1.0rc4-ffmpeg-0003-add-dual-mono-support-to-ffdec_aac.patch
50
51License:        GPLv2+
52Group:          Applications/Multimedia
53URL:            http://www.mplayerhq.hu/
54
55BuildRequires:  SDL-devel
56BuildRequires:  aalib-devel
57BuildRequires:  alsa-lib-devel
58BuildRequires:  cdparanoia-devel
59BuildRequires:  desktop-file-utils
60BuildRequires:  libdvdnav-devel
61BuildRequires:  enca-devel
62BuildRequires:  freetype2-devel >= 2.0.9
63BuildRequires:  fribidi-devel
64BuildRequires:  fontconfig-devel
65BuildRequires:  giflib-devel
66BuildRequires:  gtk2-devel
67BuildRequires:  mesa-libGL-devel
68BuildRequires:  libXinerama-devel
69BuildRequires:  libXScrnSaver-devel
70BuildRequires:  libXv-devel
71BuildRequires:  libXvMC-devel
72BuildRequires:  libXxf86dga-devel
73BuildRequires:  libXxf86vm-devel
74BuildRequires:  libass-devel
75BuildRequires:  libpng-devel
76BuildRequires:  libjpeg-devel
77BuildRequires:  libdvdread
78BuildRequires:  libmpcdec-devel >= 1.2.1
79BuildRequires:  librtmp-devel >= 2.3
80BuildRequires:  speex-devel >= 1.1
81%if %{?_dist_release} != "vl5"
82%{?with_vaapi:BuildRequires:libva-devel}
83%endif
84BuildRequires:  libvdpau-devel
85BuildRequires:  libvorbis-devel
86%if %{?_dist_release} != "vl5"
87%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
88%endif
89BuildRequires:  lzo-devel >= 2
90BuildRequires:  pulseaudio-lib-devel
91BuildRequires:  speex-devel >= 1.1
92BuildRequires:  twolame-devel
93BuildRequires:  xorg-x11-devel
94BuildRequires:  yasm
95BuildRequires:  zlib-devel
96
97# *-devel packages provided by other self-build-* should only be listed
98# in self-build-%{name}.spec as PreReq.
99##Requires:     self-build-mplayer-codecs
100##BuildRequires:        self-build-libdvdcss
101##BuildRequires:  self-build-lame
102##BuildRequires:  self-build-libdca
103##BuildRequires:  self-build-x264 >= 0.0.0-15.20110322
104##BuildRequires:  self-build-xvidcore >= 0.9.2
105##BuildRequires:  self-build-faad2 >= 2.6.1
106##BuildRequires:  self-build-libmpeg2
107
108Requires:       TrueType-vlgothic
109Requires:       mesa-libGL
110
111BuildRoot:      %{_tmppath}/%{name}-%{version}-root
112
113
114%description
115MPlayer can play most standard video formats out of the box and almost
116all others with the help of external codecs.
117MPlayer currently works best from the command line, but visual feedback
118for many functions is available from its onscreen status display (OSD),
119which is also used for displaying subtitles.
120MPlayer also has a GUI with skin support and several unofficial alternative
121graphical frontends are available.
122
123MEncoder is a command line video encoder for advanced users that can
124be built from the MPlayer source tree. Unofficial graphical frontends
125exist but arenot included.
126
127MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
128support for some newer codecs are not yet inpmlemented.
129You should install mplayer-codecs package if you want to play videos
130using those new codecs.
131
132%description -l ja
133MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
134またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
135で再生できます。
136現在の MPlayer はコマンドラインから使うのが一番便利ですが、
137多くの操作は字幕と同様に、
138オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
139MPlayer には スキンを変更できる GUI も用意されていますし、
140また複数の非公式なフロントエンドも利用できます。
141
142MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
143非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
144
145MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
146を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
147いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
148をインストールする必要があります。
149
150
151%prep
152#%setup -q -n MPlayer-%{version}%{extver}
153%setup -q -n mplayer-export-%{svndate}
154
155%patch2 -p1 -b .vine
156%patch8 -p1 -b .manlinks
157%patch14 -p1 -b .nodvdcss
158%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
159
160# ## apply the DVB app. patches
161# unzip %{SOURCE100}
162# cat>ffmpeg<<EOF
163# Subproject commit 4f84e728dad84a366a2d183da03b7d92cb20fb23
164# EOF
165# %patch101 -p1 -b .vine
166# %patch102 -p1 -b .vine
167# %patch103 -p1 -b .vine
168# patch -p1 < mplayer-patches-%{dvbappver}/0004-improved-stream-selection-by-limiting-the-switch-wit.patch || exit 1
169# patch -p1 < mplayer-patches-%{dvbappver}/0005-extended-DVB-options-to-support-more-cards-and-speci.patch || exit 1
170# %patch106 -p1 -b .vine
171# %patch107 -p1 -b .vine
172# patch -p1 < mplayer-patches-%{dvbappver}/0008-supports-PMT-contents-change.patch || exit 1
173# patch -p1 < mplayer-patches-%{dvbappver}/0009-supports-video-frame-size-change.patch || exit 1
174
175# %patch111 -p1 -b .vine
176# patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0002-add-support-for-audio-channel-reconfiguration.patch || exit 1
177# %patch113 -p1 -b .vine
178# patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0004-fixed-sample-rate-calculation-in-SBR-AAC-HE_AAC.patch || exit 1
179
180%build
181./configure \
182    --prefix=%{_prefix} \
183    --bindir=%{_bindir} \
184    --datadir=%{_datadir}/mplayer \
185    --mandir=%{_mandir} \
186    --confdir=%{_sysconfdir}/mplayer \
187    --libdir=%{_libdir} \
188    \
189    --extra-cflags="$RPM_OPT_FLAGS" \
190    --language=ja,en \
191    --enable-joystick \
192    --enable-gui --enable-menu \
193    --enable-radio --enable-radio-capture \
194    --enable-runtime-cpudetection \
195    \
196    --disable-dvdread-internal \
197    --disable-libdvdcss-internal \
198    --disable-nemesi \
199    \
200    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
201    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
202    %{!?with_faac:--disable-faac} \
203    --disable-libmpeg2-internal \
204    --disable-libopenjpeg \
205    \
206    --disable-bitmap-font \
207    --disable-dga1 --disable-dga2 \
208    --disable-directfb \
209    --disable-svga \
210    --disable-termcap \
211    --enable-xvmc \
212    --with-xvmclib=XvMCW \
213    \
214    --disable-arts --disable-esd --disable-jack --disable-openal \
215    ;
216
217%{__make} V=1 %{?_smp_mflags}
218
219%install
220%{__rm} -rf ${RPM_BUILD_ROOT}
221%{__make} install INSTALLSTRIP= \
222    prefix=${RPM_BUILD_ROOT}%{_prefix} \
223    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
224    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
225    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
226    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
227    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
228    ;
229
230## install some default config files
231%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
232%{__install} -pm 644 etc/example.conf \
233    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
234%{__install} -pm 644 etc/{input,menu,codecs}.conf \
235    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
236
237# Icons
238install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
239%__mv $RPM_BUILD_ROOT%{_datadir}/pixmaps/mplayer.png \
240    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
241
242# install default skin
243%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
244pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
245%{__tar} xjf %{SOURCE1}
246%{__ln_s} Blue default
247popd
248
249# make sybolic link to ttf font for subtitle
250for i in %{ttfontlist}; do
251    if [ -e %{ttfontdir}/$i.ttf ];then
252        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
253        break;
254    fi;
255done
256
257## install TOOLS
258for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
259%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
260done
261
262for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
263%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
264done
265
266for file in vobshift.py ; do
267%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
268done
269
270%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
271%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
272
273
274%clean
275%{__rm} -rf ${RPM_BUILD_ROOT}
276
277%post
278touch --no-create %{_datadir}/icons/hicolor
279if [ -x %{_bindir}/gtk-update-icon-cache ]; then
280  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
281fi
282%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
283
284%postun
285%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
286touch --no-create %{_datadir}/icons/hicolor
287if [ -x %{_bindir}/gtk-update-icon-cache ]; then
288  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
289fi || :
290
291
292%files
293%defattr(-,root,root)
294#%doc AUTHORS Changelog Copyright LICENSE README
295%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
296%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
297%config(noreplace) %{_sysconfdir}/mplayer/input.conf
298%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
299%{_bindir}/mplayer
300%{_bindir}/gmplayer
301%{_bindir}/mencoder
302%{_datadir}/mplayer/skins/Blue
303%{_datadir}/mplayer/skins/default
304%{_datadir}/mplayer/subfont.ttf
305%{_datadir}/applications/mplayer.desktop
306%{_datadir}/icons/hicolor/48x48/apps/mplayer.png
307%{_mandir}/man1/mplayer.1*
308%{_mandir}/man1/mencoder.1*
309## TOOLS
310%{_bindir}/aconvert
311%{_bindir}/calcbpp
312%{_bindir}/countquant
313%{_bindir}/divx2svcd
314%{_bindir}/dvd2divxscript
315%{_bindir}/mencvcd
316%{_bindir}/midentify
317%{_bindir}/mpconsole
318%{_bindir}/qepdvcd
319%{_bindir}/subsearch
320%{_bindir}/vobshift
321%{_datadir}/mplayer/*.fp
322
323
324%changelog
325* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
326- updated snapshot 20111217 (with ffmpeg 0.9)
327
328* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
329- s/self-build-libdvdnav/libdvdnav/
330
331* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
332- updated %%SOURCE1
333  - update to 1.8
334
335* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
336- dropped BuildRequires: esound-devel
337
338* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
339- new upstream release
340  - ready for Vine Linux 6
341  - revived support for Vine Linux 5
342- added BuildRequires:
343  - libass-devel
344  - librtmp-devel >= 2.3
345  - speex-devel >= 1.1
346
347* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
348- added BuildRequires:
349  - aalib-devel
350  - enca-devel
351  - lzo-devel
352  - speex-devel
353
354* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
355- updated fixed %{name}-config.patch
356  - applied %{name}-config-20100709-vine.patch
357
358* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
359- change release to sync with self-build-mplayer
360
361* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
362- updated source snapshot 20100709
363- renamed %%Source10 to mplayer-snapshot-vine.sh
364- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
365- added BuildRequires: libvpx-devel >= 0.9.1
366
367* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
368- updated source snapshot 20100621
369
370* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
371- updated source snapshot 20100615
372- added BuildRequires: libXinerama-devel
373- dropped vl4 support
374
375* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
376- updated source snapshot 20100410
377
378* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
379- updated source snapshot 20100401
380
381* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
382- updated source snapshot 20100326
383
384* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
385- updated source snapshot 20100317
386
387* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
388- updated source snapshot 20100216
389- moved scripts from TOOLS
390- added --disable-libopenjpeg in configure options
391
392* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
393- updated source snapshot 20100201
394- dropped obsolete patches
395- added BuildRequires:
396  - libvdpau-devel
397  - libXScrnSaver-devel
398
399* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
400- update mplayer-config-20091215-vine.patch
401- update mplayer-20091215-x86_32-compile.patch
402- added --enable-runtime-cpudetection in configure options
403
404* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
405- source snapshot 20091031
406  - updated mplayer-20091031-x86_32-compile.patch
407
408* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
409- source snapshot 20091003
410
411* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
412- change release to sync with self-build-mplayer
413
414* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
415- source snapshot 20090905
416- added settings for vl6
417
418* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
419- source snapshot 20090821
420- replaced BR: libungif-devel with BR: giflib-devel
421
422* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
423- source snapshot 20090722
424
425* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
426- source snapshot 20090702
427
428* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
429- source snapshot 20090611
430
431* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
432- added Requires: TrueType-vlgothic
433
434* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
435- source snapshot 20090522
436  - build with x264 >= 0.0.0-9.20090522
437  - updated mplayer-20090522-nodvdcss.patch
438
439* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
440- change release to sync with self-build-mplayer
441
442* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
443- source snapshot 20090502
444- updated mplayer-20090503-x86_32-compile.patch
445- updated mplayer-20090502-nodvdcss.patch
446
447* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
448- applied mplayer-config-vine.patch
449
450* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
451- source snapshot 20090327
452- updated mplayer-20090327-x86_32-compile.patch
453- updated mplayer-20090325-nodvdcss.patch
454- dropped gmplayer-about-vine.patch
455- install some default config files
456- added configure options:
457  - --disable-termcap
458  - --enable-xvmc
459  - --with-xvmclib=XvMCW
460- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
461- fixed %%files for *.conf
462
463* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
464- source snapshot 20090305
465
466* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
467- source snapshot 20090227
468
469* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
470- source snapshot 20090216
471
472* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
473- source snapshot 20090206
474- dropped mplayer-man-zh_CN.patch
475- updated mplayer-20090206-nodvdcss.patch
476- changed to PreReq:  self-build-faad2 from faad2-devel
477- added PreReq:  self-build-libmad
478
479* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
480- source snapshot 20090131
481
482* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
483- change release to sync with self-build-mplayer
484
485* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
486- source snapshot
487- update mplayer-20090122-nodvdcss.patch
488- added BuildRequires:
489  - faad2-devel
490  - libmpcdec-devel
491  - twolame-devel
492  - yasm
493  - faac-devel (as PreReq in self-build-%{name})
494  - lame-devel (as PreReq in self-build-%{name})
495  - libdca-devel (as PreReq in self-build-%{name})
496  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
497  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
498
499* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
500- source snapshot
501- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
502  --disable-faad-internal in configure options
503- dropped gmplayer-add-flv-extension.patch
504
505* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
506- source snapshot
507- fixed License
508- added some patches from RPM Fusion
509- updated gmplayer-about-vine.patch for 20081001 snapshot
510- added BuildRequires:  libdvdread
511- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
512- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
513  in configure options
514#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
515
516* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
517- fixed License
518- added some devel packages to support OpenGL
519
520* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
521- spec in utf8
522- fix sybolic link of subfont for vl5
523
524* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
525- add "Patch105: CVE-2008-1558.patch".
526
527* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
528- build with new versioning policy.
529- fix Source[01] URLs.
530- add "Patch200: gmplayer-about-vine.patch".
531- add "Patch201: gmplayer-add-flv-extension.patch".
532
533* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
534- add four official security patches (CVE-2008-0485, CVE-2008-0486,
535  CVE-2008-0629, CVE-2008-0630)
536- add mplayer-1.0rc2-20080211-stream_cddb.patch
537
538* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
539- change source download URL. <BTS:VineLinux:603>
540
541* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
542- fix CONFDIR for make install. <BTS:wishes:33>
543
544* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
545- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.