source: projects/specs/trunk/nonfree/self-build-mplayer-codecs/self-build-mplayer-codecs-vl.spec @ 620

Revision 620, 5.2 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname mplayer-codecs
2%define name    self-build-%{pkgname}
3%define version 20071007
4%define release 6%{?_dist_release}
5
6%ifarch %{ix86}
7%define source0path MPlayer/releases/codecs/essential-%{version}.tar.bz2
8%endif
9%ifarch ppc
10%define source0path MPlayer/releases/codecs/essential-ppc-%{version}.tar.bz2
11%endif
12%ifarch x86_64
13%define source0path MPlayer/releases/codecs/essential-amd64-%{version}.tar.bz2
14%endif
15
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23
24License:        GPL
25Group:          Restricted Software
26
27Requires(post):         self-build-setup >= 0.9.9
28Requires:               libstdc++3
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32Packager:       munepi
33
34%description
35Binary codecs for MPlayer.
36
37If you install this package, it automaticaly downloads source
38code ,compile it, and create rpm packages of %{pkgname}-%{version}.
39And the created rpm packages are automatically installed
40if installation is executed by apt-get command or synaptic
41package manager.
42
43[Note]
44This package requires many other packages to compile
45targetsoftware. So it consume more disk space than usual.
46Also installation takes logner time because of compilation.
47(This will take a few minutes to quarter or half of an hour,
48depends on building environment)
49
50[About self-build package]
51For some kind of software, distributing of binary package
52may viorate the patent or law. Therefore we chose self-build
53packge, create binary package on your machine, for such kind
54of softwares instead of distributing binary package.
55
56Please obey the national law when you use the created binary
57packages. And if you want to use the softwares using patented
58thechnology, it may be required to get a permission, make an
59agreement or purchas a license. Please consider it with your
60purpose or way of use and take appropriate action.
61
62%description -l ja
63MPlayer 用のバイナリ Codec です。
64
65このパッケージをインストールすると、自動的にソースコードを
66ダウンロードしてコンパイルし、%{pkgname}-%{version}
67の rpm パッケージを作成します。
68また apt-get コマンドや synaptic パッケージマネージャから実行
69した場合は、作成された rpm パッケージのインストールも自動的に
70行います。
71
72[注意]
73コンパイルに必要な多くの関連パッケージを要求するので通常より
74ディスクの領域を多く消費します。
75またインストール時にコンパイルを行うため、通常より時間がかか
76る場合があります。(環境にもよりますが数分から数十分程度)
77
78[self-build パッケージについて]
79ソフトウェアによってはバイナリパッケージの配布が特許や法律に
80違反する可能性があるものがあります。その為、このような問題が
81懸念されるソフトウェアについてはバイナリパッケージを直接配布
82せずに、ユーザの環境でバイナリを作成する self-build パッケー
83ジという方法を採っています。
84
85作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
86アのライセンス、および利用する国の各種法令に従ってください。
87また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
88センスの購入などが必要となる場合がありますので、利用する目的
89や形態に応じて各自で判断し適切な対応を取ってください。
90
91%prep
92[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98
99
100%clean
101%{__rm} -rf ${RPM_BUILD_ROOT}
102
103%posttrans
104/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
105  http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 2250
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}/*
110
111%changelog
112* Sun Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-6
113- renamed %%{Source0} to mplayer-codecs-vl.spec
114
115* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-5
116- added Requires: libstdc++3
117
118* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-4
119- dropped BuildArch: noarch
120
121* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-3
122- added BuildArch: noarch
123- avoided to execute self-build-rpm.sh on RPM transaction
124  - moved %%post actions to %%posttrans
125
126* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-2
127- spec in utf8
128- fixed %%release for new versioning policy in mplayer-codecs.spec
129- dropped ttfontdir variable in mplayer-codecs.spec
130
131* Sun Jun 08 2008 Atsushi SHICHI <ats777@gmail.com> 20071007-1
132- build with new versioning policy.
133- fix <BTS:VineLinux:603>.
134  - add ">= 0.7-1" to "PreReq: self-build-setup".
135  - add mirror URLs to self-build-rpm.sh.
136
137* Sun Mar 2 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-0vl2
138- change source download URL. (see <BTS:VineLinux:603>)
139
140* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 20071007-0vl1
141- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.