source: projects/specs/trunk/nonfree/self-build-mplayer-codecs/self-build-mplayer-codecs-vl.spec @ 9279

Revision 9279, 5.3 KB checked in by munepi, 9 years ago (diff)

dropped Requires: libstdc++3

Line 
1%define pkgname mplayer-codecs
2%define name    self-build-%{pkgname}
3%define version 20071007
4%define release 7%{?_dist_release}
5
6%ifarch %{ix86}
7%define source0path MPlayer/releases/codecs/essential-%{version}.tar.bz2
8%endif
9%ifarch ppc
10%define source0path MPlayer/releases/codecs/essential-ppc-%{version}.tar.bz2
11%endif
12%ifarch x86_64
13%define source0path MPlayer/releases/codecs/essential-amd64-%{version}.tar.bz2
14%endif
15
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23
24License:        GPL
25Group:          Restricted Software
26
27Requires(post):         self-build-setup >= 0.9.9
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Packager:       munepi
32
33%description
34Binary codecs for MPlayer.
35
36If you install this package, it automaticaly downloads source
37code ,compile it, and create rpm packages of %{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42[Note]
43This package requires many other packages to compile
44targetsoftware. So it consume more disk space than usual.
45Also installation takes logner time because of compilation.
46(This will take a few minutes to quarter or half of an hour,
47depends on building environment)
48
49[About self-build package]
50For some kind of software, distributing of binary package
51may viorate the patent or law. Therefore we chose self-build
52packge, create binary package on your machine, for such kind
53of softwares instead of distributing binary package.
54
55Please obey the national law when you use the created binary
56packages. And if you want to use the softwares using patented
57thechnology, it may be required to get a permission, make an
58agreement or purchas a license. Please consider it with your
59purpose or way of use and take appropriate action.
60
61%description -l ja
62MPlayer 用のバイナリ Codec です。
63
64このパッケージをインストールすると、自動的にソースコードを
65ダウンロードしてコンパイルし、%{pkgname}-%{version}
66の rpm パッケージを作成します。
67また apt-get コマンドや synaptic パッケージマネージャから実行
68した場合は、作成された rpm パッケージのインストールも自動的に
69行います。
70
71[注意]
72コンパイルに必要な多くの関連パッケージを要求するので通常より
73ディスクの領域を多く消費します。
74またインストール時にコンパイルを行うため、通常より時間がかか
75る場合があります。(環境にもよりますが数分から数十分程度)
76
77[self-build パッケージについて]
78ソフトウェアによってはバイナリパッケージの配布が特許や法律に
79違反する可能性があるものがあります。その為、このような問題が
80懸念されるソフトウェアについてはバイナリパッケージを直接配布
81せずに、ユーザの環境でバイナリを作成する self-build パッケー
82ジという方法を採っています。
83
84作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
85アのライセンス、および利用する国の各種法令に従ってください。
86また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
87センスの購入などが必要となる場合がありますので、利用する目的
88や形態に応じて各自で判断し適切な対応を取ってください。
89
90%prep
91[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
92
93%install
94%{__rm} -rf ${RPM_BUILD_ROOT}
95%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
96%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
104  http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 2250
105
106%files
107%defattr(-,root,root)
108%{_datadir}/%{name}/*
109
110%changelog
111* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-7
112- dropped Requires: libstdc++3
113
114* Sun Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-6
115- renamed %%{Source0} to mplayer-codecs-vl.spec
116
117* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-5
118- added Requires: libstdc++3
119
120* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-4
121- dropped BuildArch: noarch
122
123* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-3
124- added BuildArch: noarch
125- avoided to execute self-build-rpm.sh on RPM transaction
126  - moved %%post actions to %%posttrans
127
128* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-2
129- spec in utf8
130- fixed %%release for new versioning policy in mplayer-codecs.spec
131- dropped ttfontdir variable in mplayer-codecs.spec
132
133* Sun Jun 08 2008 Atsushi SHICHI <ats777@gmail.com> 20071007-1
134- build with new versioning policy.
135- fix <BTS:VineLinux:603>.
136  - add ">= 0.7-1" to "PreReq: self-build-setup".
137  - add mirror URLs to self-build-rpm.sh.
138
139* Sun Mar 2 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-0vl2
140- change source download URL. (see <BTS:VineLinux:603>)
141
142* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 20071007-0vl1
143- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.