source: projects/specs/trunk/nonfree/self-build-kino/kino-vl.spec @ 615

Revision 615, 5.6 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1##TODO: udev
2Name: kino
3Version: 1.3.4
4Release: 2%{?_dist_release}
5Summary: Kino - A simple non-linear video editor
6Summary(ja): Kino - シンプルなノンリニアビデオ編集ツール
7
8Group: Applications/Multimedia
9License: GPLv2+
10URL: http://www.kinodv.org/
11Source0: http://prdownloads.sourceforge.net/kino/%{name}-%{version}.tar.gz
12Patch0:         %{name}-udev.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: desktop-file-utils
16BuildRequires: gettext
17BuildRequires: intltool
18BuildRequires: libsamplerate-devel
19BuildRequires: libdv-devel
20BuildRequires: libavc1394-devel
21BuildRequires: libraw1394-devel
22BuildRequires: libiec61883-devel
23BuildRequires: libogg-devel
24BuildRequires: libvorbis-devel
25BuildRequires: gtk2-devel >= 2.6.0
26BuildRequires: XOrg-devel
27BuildRequires: imlib-devel
28BuildRequires: libxml2-devel
29BuildRequires: perl
30# *-devel packages provided by other self-build-* should only be listed
31# in self-build-%{name}.spec as Requires(post).
32# BuildRequires: libquicktime-devel
33# BuildRequires: ffmpeg-devel
34
35Requires: libdv
36Requires: libavc1394
37Requires: libraw1394
38Requires: libogg
39Requires: libvorbis
40Requires: gtk2
41Requires: imlib
42Requires: libxml2
43Requires(post): shared-mime-info
44
45# These packages provided by other self-build-* should only be listed
46# in self-build-%{name}.spec as Requires(post).
47# Requires: ffmpeg
48# Requires: ffmpeg2theora
49
50%description
51The new generation of digital camcorders use the Digital Video (DV) data
52format. Kino allows you to record, create, edit, and play movies recorded
53with DV camcorders. Unlike other editors, this program uses many keyboard
54commands for fast navigating and editing inside the movie.
55
56%description -l ja
57デジタルビデオカメラの新世代は
58Digital Video (DV) データフォーマットを使います。
59Kino は DV デジタルビデオカメラで録画された動画を
60録画、作成、編集、再生できます。
61他の編集ソフトとは異なり、
62動画の中へ素早く移動や編集するために
63多くのキーボードコマンドを使えます。
64
65%package        devel
66Summary:        Development package for %{name}
67Group:          Development/Libraries
68Requires:       %{name} = %{version}-%{release}
69
70%description    devel
71The new generation of digital camcorders use the Digital Video (DV) data
72format. Kino allows you to record, create, edit, and play movies recorded
73with DV camcorders. Unlike other editors, this program uses many keyboard
74commands for fast navigating and editing inside the movie.
75
76This package contains development files to build kino plugins.
77
78
79%prep
80%setup -q
81%patch0 -p1 -b .udev
82
83
84%build
85%configure \
86    --disable-static \
87    --disable-dependency-tracking \
88    --disable-local-ffmpeg \
89    --enable-quicktime \
90    ;
91
92%__make %{?_smp_mflags}
93
94
95%install
96%__rm -rf $RPM_BUILD_ROOT
97%__make install DESTDIR=$RPM_BUILD_ROOT
98%__ln_s -f kino $RPM_BUILD_ROOT%{_bindir}/kino2raw
99%__rm $RPM_BUILD_ROOT%{_datadir}/applications/Kino.desktop
100%__ln_s Kino.desktop kino.desktop
101
102%find_lang kino
103
104desktop-file-install \
105    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
106    --add-category AudioVideoEditing \
107    --add-category X-AudioVideoCapture \
108    kino.desktop
109
110## remove unuse files
111%__rm -f %{buildroot}%{_libdir}/kino-gtk2/lib*.la
112
113%check
114%__make check
115
116%post
117%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null
118
119%postun
120%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null
121
122%clean
123[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
124
125%files -f kino.lang
126%defattr(-,root,root,-)
127%doc AUTHORS BUGS COPYING ChangeLog NEWS README* TODO
128%{_bindir}/kino
129%{_bindir}/kino2raw
130%{_mandir}/man1/*
131%{_datadir}/kino
132%{_datadir}/applications/*kino.desktop
133%{_datadir}/pixmaps/kino.png
134%exclude %config(noreplace) %{_sysconfdir}/udev/rules.d/kino.rules
135%{_datadir}/mime/packages/kino.xml
136%{_libdir}/kino-gtk2
137
138
139%files devel
140%defattr(-,root,root,-)
141%{_includedir}/kino
142
143%changelog
144* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
145- change release to sync with self-build-kino.spec
146
147* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
148- new upstream release
149  - with recent ffmpeg
150
151* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
152- added devel subpackage
153  - dropped Obsoletes: %{name}-devel
154- added BuildRequires:
155  - desktop-file-utils
156  - gettext
157  - intltool
158- added --disable-local-ffmpeg --enable-quicktime in configure options
159
160* Fri Jun 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
161- new upstream release
162- added BuildRequires: libiec61883-devel
163- added %%description -l ja
164- dropped --with-avcodec and added --disable-static in configure options
165
166* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.2-1vl5
167- new upstream release
168- fixed gnome-kino.desktop
169- remove lib*.la
170- applied new versioning policy, spec in utf-8
171
172* Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.1-0vl1
173- new upstream release
174- run update-mime-database at %post and %postun section
175- rebuilt with new libraw1394
176
177* Sun May 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-0vl2
178- added BuildRequires: libsamplerate-devel
179
180* Thu Apr 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-0vl1
181- new upstream release
182
183* Wed Jan 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
184- new upstream release
185- gtk2 version
186
187* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-0vl1
188- Build for Vine Linux
189- add Japanese translation for summary and desktop files.
190
191* Mon Feb 24 2003 Dag Wieers <dag@wieers.com> - 0.6.4-0
192- Updated to 0.6.4.
193
194* Wed Feb 12 2003 Dag Wieers <dag@wieers.com> - 0.6.3-0
195- Initial package. (using dar)
Note: See TracBrowser for help on using the repository browser.