source: projects/specs/trunk/nonfree/self-build-kino/kino-vl.spec @ 1816

Revision 1816, 5.7 KB checked in by munepi, 14 years ago (diff)

added self-build-mjpegtools

Line 
1##TODO: udev
2Name: kino
3Version: 1.3.4
4Release: 3%{?_dist_release}
5Summary: Kino - A simple non-linear video editor
6Summary(ja): Kino - シンプルなノンリニアビデオ編集ツール
7
8Group: Applications/Multimedia
9License: GPLv2+
10URL: http://www.kinodv.org/
11Source0: http://prdownloads.sourceforge.net/kino/%{name}-%{version}.tar.gz
12Patch0:         %{name}-udev.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: desktop-file-utils
16BuildRequires: gettext
17BuildRequires: intltool
18BuildRequires: libsamplerate-devel
19BuildRequires: libdv-devel
20BuildRequires: libavc1394-devel
21BuildRequires: libraw1394-devel
22BuildRequires: libiec61883-devel
23BuildRequires: libogg-devel
24BuildRequires: libvorbis-devel
25BuildRequires: gtk2-devel >= 2.6.0
26BuildRequires: XOrg-devel
27BuildRequires: imlib-devel
28BuildRequires: libxml2-devel
29BuildRequires: perl
30# *-devel packages provided by other self-build-* should only be listed
31# in self-build-%{name}.spec as Requires(post).
32# BuildRequires: libquicktime-devel
33# BuildRequires: ffmpeg-devel
34
35Requires: libdv
36Requires: libavc1394
37Requires: libraw1394
38Requires: libogg
39Requires: libvorbis
40Requires: gtk2
41Requires: imlib
42Requires: libxml2
43Requires(post): shared-mime-info
44
45# These packages provided by other self-build-* should only be listed
46# in self-build-%{name}.spec as Requires(post).
47# Requires: mjpegtools
48# Requires: mplayer
49# Requires: ffmpeg
50# Requires: ffmpeg2theora
51
52%description
53The new generation of digital camcorders use the Digital Video (DV) data
54format. Kino allows you to record, create, edit, and play movies recorded
55with DV camcorders. Unlike other editors, this program uses many keyboard
56commands for fast navigating and editing inside the movie.
57
58%description -l ja
59デジタルビデオカメラの新世代は
60Digital Video (DV) データフォーマットを使います。
61Kino は DV デジタルビデオカメラで録画された動画を
62録画、作成、編集、再生できます。
63他の編集ソフトとは異なり、
64動画の中へ素早く移動や編集するために
65多くのキーボードコマンドを使えます。
66
67%package        devel
68Summary:        Development package for %{name}
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71
72%description    devel
73The new generation of digital camcorders use the Digital Video (DV) data
74format. Kino allows you to record, create, edit, and play movies recorded
75with DV camcorders. Unlike other editors, this program uses many keyboard
76commands for fast navigating and editing inside the movie.
77
78This package contains development files to build kino plugins.
79
80
81%prep
82%setup -q
83%patch0 -p1 -b .udev
84
85
86%build
87%configure \
88    --disable-static \
89    --disable-dependency-tracking \
90    --disable-local-ffmpeg \
91    --enable-quicktime \
92    ;
93
94%__make %{?_smp_mflags}
95
96
97%install
98%__rm -rf $RPM_BUILD_ROOT
99%__make install DESTDIR=$RPM_BUILD_ROOT
100%__ln_s -f kino $RPM_BUILD_ROOT%{_bindir}/kino2raw
101%__rm $RPM_BUILD_ROOT%{_datadir}/applications/Kino.desktop
102%__ln_s Kino.desktop kino.desktop
103
104%find_lang kino
105
106desktop-file-install \
107    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
108    --add-category AudioVideoEditing \
109    --add-category X-AudioVideoCapture \
110    kino.desktop
111
112## remove unuse files
113%__rm -f %{buildroot}%{_libdir}/kino-gtk2/lib*.la
114
115%check
116%__make check
117
118%post
119%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null
120
121%postun
122%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null
123
124%clean
125[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
126
127%files -f kino.lang
128%defattr(-,root,root,-)
129%doc AUTHORS BUGS COPYING ChangeLog NEWS README* TODO
130%{_bindir}/kino
131%{_bindir}/kino2raw
132%{_mandir}/man1/*
133%{_datadir}/kino
134%{_datadir}/applications/*kino.desktop
135%{_datadir}/pixmaps/kino.png
136%exclude %config(noreplace) %{_sysconfdir}/udev/rules.d/kino.rules
137%{_datadir}/mime/packages/kino.xml
138%{_libdir}/kino-gtk2
139
140
141%files devel
142%defattr(-,root,root,-)
143%{_includedir}/kino
144
145%changelog
146* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-3
147- change release to sync with self-build-kino.spec
148
149* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
150- change release to sync with self-build-kino.spec
151
152* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
153- new upstream release
154  - with recent ffmpeg
155
156* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
157- added devel subpackage
158  - dropped Obsoletes: %{name}-devel
159- added BuildRequires:
160  - desktop-file-utils
161  - gettext
162  - intltool
163- added --disable-local-ffmpeg --enable-quicktime in configure options
164
165* Fri Jun 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
166- new upstream release
167- added BuildRequires: libiec61883-devel
168- added %%description -l ja
169- dropped --with-avcodec and added --disable-static in configure options
170
171* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.2-1vl5
172- new upstream release
173- fixed gnome-kino.desktop
174- remove lib*.la
175- applied new versioning policy, spec in utf-8
176
177* Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.1-0vl1
178- new upstream release
179- run update-mime-database at %post and %postun section
180- rebuilt with new libraw1394
181
182* Sun May 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-0vl2
183- added BuildRequires: libsamplerate-devel
184
185* Thu Apr 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-0vl1
186- new upstream release
187
188* Wed Jan 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
189- new upstream release
190- gtk2 version
191
192* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-0vl1
193- Build for Vine Linux
194- add Japanese translation for summary and desktop files.
195
196* Mon Feb 24 2003 Dag Wieers <dag@wieers.com> - 0.6.4-0
197- Updated to 0.6.4.
198
199* Wed Feb 12 2003 Dag Wieers <dag@wieers.com> - 0.6.3-0
200- Initial package. (using dar)
Note: See TracBrowser for help on using the repository browser.