source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 9398

Revision 9398, 12.7 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.4.5
5%define _gstpb_ver      1.4.5
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.4.5
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109
110%find_lang gst-plugins-ugly-%{major}
111
112%clean
113%__rm -rf %{buildroot}
114
115
116%files -f gst-plugins-ugly-%{major}.lang
117%defattr(-,root,root)
118%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
119%{_datadir}/gstreamer-%{major}/presets
120# ugly plugins without external dependencies
121%{_libdir}/gstreamer-%{major}/*.so
122
123# ugly plugins with external dependencies, but in the main package
124# %{_libdir}/gstreamer-%{major}/libgstmad.so
125
126# %files devel
127# %defattr(-,root,root)
128# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
129
130
131%changelog
132* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
133- new upstream relase
134
135* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
136- new upstream relase
137
138* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
139- new upstream relase
140
141* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
142- rebuild with libcdio-0.92
143
144* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
145- new upstream relase
146
147* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
148- new upstream relase
149
150* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
151- new upstream relase
152
153* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
154- new upstream relase
155
156* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
157- new upstream relase
158
159* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
160- new upstream relase
161
162* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
163- new upstream relase
164
165* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
166- new upstream relase
167
168* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
169- new upstream relase
170
171* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
172- new upstream relase
173
174* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
175- new upstream relase
176
177* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
178- new upstream relase
179
180* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
181- new upstream relase
182- rename package
183
184* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
185- new upstream relase
186
187* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
188- new upstream relase
189- built with new x264
190- License: LGPLv2+
191
192* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
193- new upstream relase
194
195* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
196- new upstream relase
197
198* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
199- new upstream relase
200
201* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
202- new upstream relase
203
204* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
205- new upstream relase
206
207* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
208- new upstream relase
209- enable mpeg2dec with libmpeg2-devel in %%configure
210
211* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
212- change release to sync with self-build-gstreamer-plugins-ugly
213
214* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
215- dropped BuildRequires: gtk-doc >= 1.3
216  - disable-gtk-doc in configure options
217  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
218
219* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
220- new upstream relase
221
222* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
223- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
224
225* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
226- new upstream relase
227
228* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
229- upstream release
230- delete --disable-a52dec configure option
231- delete %%with_lame macro
232- added japanase summary and description
233
234* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
235- upstream release
236- update %%_gst_ver
237
238* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
239- add NoSource: 0
240
241* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
242- add %%with_lame macro
243  - enable lame support if rpmbuild with '--with lame'
244
245* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
246- upstream release
247
248* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
249- upstream release
250- add libgstdvdsub.so
251
252* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
253- upstream release
254- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
255- add libgstasf.so
256
257* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
258- fix typo
259
260* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
261- initial package based on gstreamer-plugins
262- new upstream release
263  - change major to 0.10
264- update dependencies
265- update %%configure options
266
267* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
268- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
269
270* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
271- added missing alsa plugin
272
273* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
274- new upstream release
275- added alsa and cairo plugins
276
277* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
278- new upstream release
279
280* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
281- new upstream release
282
283* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
284- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
285
286* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
287- added libgstcdparania.so for gnome-cd (gnome-media)
288- BuildRequires: cdparanoia-devel
289
290* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
291- drop BuildRequires: xmms-devel, Requires: xmms
292
293* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
294- libgstvideo4linux2.so temoporally omitted for ppc
295  (will be back later, I hope)
296
297* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
298- new upstream release
299- s/Copyright/License/
300- includes plugins depend on main package libraries only
301
302* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
303- new upstream release
304
305* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
306- new upstream release
307
308* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
309- new upstream release
310
311* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
312- new upstream release
313
314* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
315- build with -fPIC on alpha
316
317* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
318- modified scripts
319
320* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
321- new upstream release
322
323* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
324- disable some plugins.
325
326* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
327- new upstream release
328- initial build for Vine Linux
329
330* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
331- Include ia64
332- Add BuildRequires: autoconf automake
333
334* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
335- rebuild
336
337* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
338- rebuild
339
340* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
341- rebuild
342- disable tests
343
344* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
345- rebuild
346
347* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
348- fix libdir for ia64.
349
350* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
351- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
352- Add devel package
353
354* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
355- 0.5.0
356- apparently, festival-devel isn't needed.
357
358* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
359- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
360
361* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
362- excludearch the arches that can't build gstreamer cothreads
363- well it isn't really SMP-safe
364- add patch for including pthread.h when required
365- prereq gconftool
366- fix typo that broke schema installation in post
367
368* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
369- initial "official" import
370- munge tarball for legal cleanliness
371
372* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
373- 0.4.2
374
375* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
376- 0.4.1
377- install the gconf schema
378- use %%configure
379
380* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
381- update to 0.4.0
382- give explicit vorbis include path, don't run vorbis test
383
384* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
385- collapse into one package to preserve some sanity
386
387* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
388- added more BuildRequires and Requires
389- rearranged some plugins
390- added changelog ;)
Note: See TracBrowser for help on using the repository browser.