source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 9791

Revision 9791, 12.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.6.1
5%define _gstpb_ver      1.6.1
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.6.1
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109%__rm -rf %{buildroot}%{_datadir}/gtk-doc
110
111%find_lang gst-plugins-ugly-%{major}
112
113%clean
114%__rm -rf %{buildroot}
115
116
117%files -f gst-plugins-ugly-%{major}.lang
118%defattr(-,root,root)
119%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
120%{_datadir}/gstreamer-%{major}/presets
121# ugly plugins without external dependencies
122%{_libdir}/gstreamer-%{major}/*.so
123
124# ugly plugins with external dependencies, but in the main package
125# %{_libdir}/gstreamer-%{major}/libgstmad.so
126
127# %files devel
128# %defattr(-,root,root)
129# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
130
131
132%changelog
133* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
134- new upstream relase
135
136* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
137- new upstream relase
138
139* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
140- new upstream relase
141
142* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
143- new upstream relase
144
145* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
146- rebuild with libcdio-0.92
147
148* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
149- new upstream relase
150
151* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
152- new upstream relase
153
154* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
155- new upstream relase
156
157* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
158- new upstream relase
159
160* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
161- new upstream relase
162
163* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
164- new upstream relase
165
166* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
167- new upstream relase
168
169* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
170- new upstream relase
171
172* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
173- new upstream relase
174
175* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
176- new upstream relase
177
178* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
179- new upstream relase
180
181* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
182- new upstream relase
183
184* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
185- new upstream relase
186- rename package
187
188* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
189- new upstream relase
190
191* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
192- new upstream relase
193- built with new x264
194- License: LGPLv2+
195
196* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
197- new upstream relase
198
199* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
200- new upstream relase
201
202* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
203- new upstream relase
204
205* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
206- new upstream relase
207
208* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
209- new upstream relase
210
211* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
212- new upstream relase
213- enable mpeg2dec with libmpeg2-devel in %%configure
214
215* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
216- change release to sync with self-build-gstreamer-plugins-ugly
217
218* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
219- dropped BuildRequires: gtk-doc >= 1.3
220  - disable-gtk-doc in configure options
221  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
222
223* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
224- new upstream relase
225
226* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
227- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
228
229* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
230- new upstream relase
231
232* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
233- upstream release
234- delete --disable-a52dec configure option
235- delete %%with_lame macro
236- added japanase summary and description
237
238* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
239- upstream release
240- update %%_gst_ver
241
242* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
243- add NoSource: 0
244
245* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
246- add %%with_lame macro
247  - enable lame support if rpmbuild with '--with lame'
248
249* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
250- upstream release
251
252* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
253- upstream release
254- add libgstdvdsub.so
255
256* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
257- upstream release
258- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
259- add libgstasf.so
260
261* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
262- fix typo
263
264* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
265- initial package based on gstreamer-plugins
266- new upstream release
267  - change major to 0.10
268- update dependencies
269- update %%configure options
270
271* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
272- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
273
274* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
275- added missing alsa plugin
276
277* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
278- new upstream release
279- added alsa and cairo plugins
280
281* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
282- new upstream release
283
284* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
285- new upstream release
286
287* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
288- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
289
290* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
291- added libgstcdparania.so for gnome-cd (gnome-media)
292- BuildRequires: cdparanoia-devel
293
294* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
295- drop BuildRequires: xmms-devel, Requires: xmms
296
297* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
298- libgstvideo4linux2.so temoporally omitted for ppc
299  (will be back later, I hope)
300
301* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
302- new upstream release
303- s/Copyright/License/
304- includes plugins depend on main package libraries only
305
306* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
307- new upstream release
308
309* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
310- new upstream release
311
312* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
313- new upstream release
314
315* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
316- new upstream release
317
318* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
319- build with -fPIC on alpha
320
321* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
322- modified scripts
323
324* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
325- new upstream release
326
327* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
328- disable some plugins.
329
330* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
331- new upstream release
332- initial build for Vine Linux
333
334* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
335- Include ia64
336- Add BuildRequires: autoconf automake
337
338* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
339- rebuild
340
341* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
342- rebuild
343
344* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
345- rebuild
346- disable tests
347
348* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
349- rebuild
350
351* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
352- fix libdir for ia64.
353
354* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
355- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
356- Add devel package
357
358* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
359- 0.5.0
360- apparently, festival-devel isn't needed.
361
362* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
363- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
364
365* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
366- excludearch the arches that can't build gstreamer cothreads
367- well it isn't really SMP-safe
368- add patch for including pthread.h when required
369- prereq gconftool
370- fix typo that broke schema installation in post
371
372* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
373- initial "official" import
374- munge tarball for legal cleanliness
375
376* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
377- 0.4.2
378
379* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
380- 0.4.1
381- install the gconf schema
382- use %%configure
383
384* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
385- update to 0.4.0
386- give explicit vorbis include path, don't run vorbis test
387
388* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
389- collapse into one package to preserve some sanity
390
391* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
392- added more BuildRequires and Requires
393- rearranged some plugins
394- added changelog ;)
Note: See TracBrowser for help on using the repository browser.