source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/self-build-gstreamer1-plugins-bad-vl.spec @ 7303

Revision 7303, 7.0 KB checked in by Takemikaduchi, 11 years ago (diff)

mesa-libGLU: fix BR,
others: new upstream release

Line 
1%define pkgname gstreamer1-plugins-bad
2%define majorminor   1.0
3%define gstreamer    gstreamer1
4%define gst_minver   1.0.5
5%define gstpb_minver 1.0.5
6%define _gst_ver     1.0.5
7%define release 1%{?_dist_release}
8
9%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{_gst_ver}.tar.xz
10
11Summary:        Package to automatically build %{pkgname} rpm package
12Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
13Name:           self-build-%{pkgname}
14Version:        %{_gst_ver}
15Release:        %{release}
16Source0:        %{pkgname}-vl.spec
17License:        LGPLv2+ and LGPLv2
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.9.9
21
22# (build)requies of target package.
23Requires: %{gstreamer} >= %{gst_minver}
24Requires(post): %{gstreamer}-devel >= %{gst_minver}
25Requires(post): %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
26
27Requires(post): check
28Requires(post): gettext
29Requires(post): PyXML
30Requires(post): libXt-devel
31
32Requires(post): bzip2-devel
33Requires(post): celt-devel
34Requires(post): exempi-devel
35Requires(post): jasper-devel
36#Requires(post): ladspa-devel
37Requires(post): libass-devel
38Requires(post): libdc1394-devel
39Requires(post): libdvdnav-devel
40Requires(post): libexif-devel
41#Requires(post): libiptcdata-devel
42Requires(post): kate-devel
43Requires(post): libmodplug-devel
44Requires(post): libmpcdec-devel
45#Requires(post): libofa-devel
46Requires(post): librsvg2-devel
47Requires(post): libsndfile-devel
48#Requires(post): libtimidity-devel
49Requires(post): libvpx-devel
50Requires(post): mesa-libGLU-devel
51Requires(post): openssl-devel
52Requires(post): orc-devel
53#Requires(post): schroedinger-devel
54Requires(post): SDL-devel
55#Requires(post): slv2-devel
56Requires(post): soundtouch-devel
57Requires(post): wavpack-devel
58#Requires(post): wildmidi-devel
59#Requires(post): zbar-devel
60Requires(post): libmms-devel
61Requires(post): twolame-devel
62#Requires(post): libmimic-devel
63# self build
64Requires(post): self-build-libdca
65Requires(post): self-build-faad2
66Requires(post): self-build-xvidcore
67Requires(post): self-build-mjpegtools
68
69BuildArch:      noarch
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
72Packager:       Takemikaduchi
73
74%description
75GStreamer is a streaming media framework, based on graphs of elements which
76operate on media data.
77
78This package contains plug-ins that have licensing issues, aren't tested
79well enough, or the code is not of good enough quality.
80
81If you install this package, it automaticaly downloads source
82code, compile it, and create rpm packages of
83%{pkgname}-%{version}.
84And the created rpm packages are automatically installed
85if installation is executed by apt-get command or synaptic
86package manager.
87
88
89[Note]
90This package requires many other packages to compile
91targetsoftware. So it consume more disk space than usual.
92Also installation takes logner time because of compilation.
93(This will take a few minutes to quarter or half of an hour,
94depends on building environment)
95
96[About self-build package]
97For some kind of software, distributing of binary package
98may viorate the patent or law. Therefore we chose self-build
99packge, create binary package on your machine, for such kind
100of softwares instead of distributing binary package.
101
102Please obey the national law when you use the created binary
103packages. And if you want to use the softwares using patented
104thechnology, it may be required to get a permission, make an
105agreement or purchas a license. Please consider it with your
106purpose or way of use and take appropriate action.
107
108# '
109
110%description -l ja
111gstreamer-plugins-bad は GStreamer ストリーミングメディア
112フレームワーク用 bad プラグイン集です。
113
114このパッケージをインストールすると、自動的にソースコードを
115ダウンロードしてコンパイルし、%{pkgname}-%{version}
116の rpm パッケージを作成します。
117また apt-get コマンドや synaptic パッケージマネージャから実行
118した場合は、作成された rpm パッケージのインストールも自動的に
119行います。
120
121
122[注意]
123コンパイルに必要な多くの関連パッケージを要求するので通常より
124ディスクの領域を多く消費します。
125またインストール時にコンパイルを行うため、通常より時間がかか
126る場合があります。(環境にもよりますが数分から数十分程度)
127
128[self-build パッケージについて]
129ソフトウェアによってはバイナリパッケージの配布が特許や法律に
130違反する可能性があるものがあります。その為、このような問題が
131懸念されるソフトウェアについてはバイナリパッケージを直接配布
132せずに、ユーザの環境でバイナリを作成する self-build パッケー
133ジという方法を採っています。
134
135作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
136アのライセンス、および利用する国の各種法令に従ってください。
137また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
138センスの購入などが必要となる場合がありますので、利用する目的
139や形態に応じて各自で判断し適切な対応を取ってください。
140
141%prep
142[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
143
144
145%install
146%{__rm} -rf ${RPM_BUILD_ROOT}
147%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149
150
151%clean
152%{__rm} -rf ${RPM_BUILD_ROOT}
153
154%posttrans
155/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 333000
156/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
157                                 %{pkgname}-devel-%{version}-%{release}
158
159
160%files
161%defattr(-,root,root)
162%{_datadir}/%{name}
163
164%changelog
165* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
166- new upstream release
167
168* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
169- new upstream release
170
171* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
172- new upstream release
173- rename package
174
175* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
176- new upstream release
177- added Requires(post): libvpx-devel
178
179* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
180- s/self-build-libdvdnav/libdvdnav/
181
182* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
183- new upstream release
184- added Requires(post):
185  - libmms-devel
186  - librtmp-devel
187
188* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
189- new upstream release
190
191* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
192- new upstream release
193
194* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
195- new upstream release
196- renamed %%{Source0} to gstreamer-plugins-bad-vl.spec
197- added Requires(post): libvdpau-devel
198- check version between original spec and self-build spec in %%prep
199
200* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
201- new upstream release
202
203* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
204- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.