source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/self-build-gstreamer1-plugins-bad-vl.spec @ 10716

Revision 10716, 8.9 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define pkgname gstreamer1-plugins-bad
2%define majorminor   1.0
3%define gstreamer    gstreamer1
4%define gst_minver   1.8.2
5%define gstpb_minver 1.8.2
6%define _gst_ver     1.8.2
7%define release 1%{?_dist_release}
8
9%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{_gst_ver}.tar.xz
10
11Summary:        Package to automatically build %{pkgname} rpm package
12Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
13Name:           self-build-%{pkgname}
14Version:        %{_gst_ver}
15Release:        %{release}
16Source0:        %{pkgname}-vl.spec
17License:        LGPLv2+ and LGPLv2
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.9.9
21
22# (build)requies of target package.
23Requires: %{gstreamer} >= %{gst_minver}
24Requires(post): %{gstreamer}-devel >= %{gst_minver}
25Requires(post): %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
26Requires(post): %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
27
28Requires(post): check
29Requires(post): gettext
30Requires(post): PyXML
31Requires(post): libXt-devel
32
33Requires(post): bzip2-devel
34Requires(post): celt-devel
35Requires(post): exempi-devel
36Requires(post): jasper-devel
37#Requires(post): ladspa-devel
38Requires(post): libass-devel
39Requires(post): libdc1394-devel
40Requires(post): libdvdnav-devel
41Requires(post): libexif-devel
42#Requires(post): libiptcdata-devel
43Requires(post): kate-devel
44Requires(post): libmodplug-devel
45Requires(post): libmpcdec-devel
46#Requires(post): libofa-devel
47Requires(post): librsvg2-devel
48Requires(post): libsndfile-devel
49#Requires(post): libtimidity-devel
50Requires(post): libvpx-devel
51Requires(post): mesa-libGLU-devel
52Requires(post): openssl-devel
53Requires(post): orc-devel
54#Requires(post): schroedinger-devel
55Requires(post): SDL-devel
56#Requires(post): slv2-devel
57Requires(post): soundtouch-devel
58Requires(post): wavpack-devel
59#Requires(post): wildmidi-devel
60#Requires(post): zbar-devel
61Requires(post): libmms-devel
62Requires(post): twolame-devel
63#Requires(post): libmimic-devel
64# self build
65Requires(post): self-build-libdca
66Requires(post): self-build-faad2
67Requires(post): self-build-xvidcore
68Requires(post): self-build-mjpegtools
69
70
71Obsoletes: gstreamer1-plugins-bad < %{version}-%{release}
72
73BuildArch:      noarch
74BuildRoot:      %{_tmppath}/%{name}-%{version}-root
75
76Packager:       Takemikaduchi
77
78%description
79GStreamer is a streaming media framework, based on graphs of elements which
80operate on media data.
81
82This package contains plug-ins that have licensing issues, aren't tested
83well enough, or the code is not of good enough quality.
84
85If you install this package, it automaticaly downloads source
86code, compile it, and create rpm packages of
87%{pkgname}-%{version}.
88And the created rpm packages are automatically installed
89if installation is executed by apt-get command or synaptic
90package manager.
91
92
93[Note]
94This package requires many other packages to compile
95targetsoftware. So it consume more disk space than usual.
96Also installation takes logner time because of compilation.
97(This will take a few minutes to quarter or half of an hour,
98depends on building environment)
99
100[About self-build package]
101For some kind of software, distributing of binary package
102may viorate the patent or law. Therefore we chose self-build
103packge, create binary package on your machine, for such kind
104of softwares instead of distributing binary package.
105
106Please obey the national law when you use the created binary
107packages. And if you want to use the softwares using patented
108thechnology, it may be required to get a permission, make an
109agreement or purchas a license. Please consider it with your
110purpose or way of use and take appropriate action.
111
112# '
113
114%description -l ja
115gstreamer-plugins-bad は GStreamer ストリーミングメディア
116フレームワーク用 bad プラグイン集です。
117
118このパッケージをインストールすると、自動的にソースコードを
119ダウンロードしてコンパイルし、%{pkgname}-%{version}
120の rpm パッケージを作成します。
121また apt-get コマンドや synaptic パッケージマネージャから実行
122した場合は、作成された rpm パッケージのインストールも自動的に
123行います。
124
125
126[注意]
127コンパイルに必要な多くの関連パッケージを要求するので通常より
128ディスクの領域を多く消費します。
129またインストール時にコンパイルを行うため、通常より時間がかか
130る場合があります。(環境にもよりますが数分から数十分程度)
131
132[self-build パッケージについて]
133ソフトウェアによってはバイナリパッケージの配布が特許や法律に
134違反する可能性があるものがあります。その為、このような問題が
135懸念されるソフトウェアについてはバイナリパッケージを直接配布
136せずに、ユーザの環境でバイナリを作成する self-build パッケー
137ジという方法を採っています。
138
139作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
140アのライセンス、および利用する国の各種法令に従ってください。
141また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
142センスの購入などが必要となる場合がありますので、利用する目的
143や形態に応じて各自で判断し適切な対応を取ってください。
144
145%prep
146[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
147
148
149%install
150%{__rm} -rf ${RPM_BUILD_ROOT}
151%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
152%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
153
154
155%clean
156%{__rm} -rf ${RPM_BUILD_ROOT}
157
158%posttrans
159/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 277000
160
161
162%files
163%defattr(-,root,root)
164%{_datadir}/%{name}
165
166%changelog
167* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
168- new upstream release
169
170* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
171- new upstream release
172
173* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
174- new upstream release
175
176* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-3
177- rebuild with gnutls-3.4.7
178
179* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-2
180- rebuild with nettle-3.1.1
181
182* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
183- new upstream release
184
185* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
186- new upstream release
187
188* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-2
189- changed Group to System Environment/Libraries
190
191* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
192- new upstream release
193
194* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
195- new upstream release
196
197* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
198- new upstream release
199
200* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
201- new upstream release
202
203* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
204- new upstream release
205
206* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
207- new upstream release
208
209* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
210- new upstream release
211
212* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
213- new upstream release
214
215* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
216- new upstream release
217
218* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
219- new upstream release
220
221* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
222- new upstream release
223
224* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
225- new upstream release
226
227* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
228- new upstream release
229
230* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
231- new upstream release
232
233* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
234- new upstream release
235
236* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
237- new upstream release
238- rename package
239
240* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
241- new upstream release
242- added Requires(post): libvpx-devel
243
244* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
245- s/self-build-libdvdnav/libdvdnav/
246
247* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
248- new upstream release
249- added Requires(post):
250  - libmms-devel
251  - librtmp-devel
252
253* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
254- new upstream release
255
256* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
257- new upstream release
258
259* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
260- new upstream release
261- renamed %%{Source0} to gstreamer-plugins-bad-vl.spec
262- added Requires(post): libvdpau-devel
263- check version between original spec and self-build spec in %%prep
264
265* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
266- new upstream release
267
268* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
269- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.