source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 7786

Revision 7786, 14.3 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.0.10
5%define gstpb_minver 1.0.10
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer1-plugins-bad
9Version: 1.0.10
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: bzip2-devel
27BuildRequires: celt-devel
28BuildRequires: exempi-devel
29BuildRequires: jasper-devel
30#BuildRequires: ladspa-devel
31BuildRequires: libass-devel
32BuildRequires: libdc1394-devel
33BuildRequires: libdvdnav-devel
34BuildRequires: libexif-devel
35#BuildRequires: libiptcdata-devel
36BuildRequires: kate-devel
37BuildRequires: libmodplug-devel
38BuildRequires: libmpcdec-devel
39#BuildRequires: libofa-devel
40BuildRequires: librsvg2-devel
41BuildRequires: libsndfile-devel
42#BuildRequires: libtimidity-devel
43BuildRequires: libvpx-devel
44BuildRequires: mesa-libGLU-devel
45BuildRequires: openssl-devel
46BuildRequires: orc-devel
47#BuildRequires: schroedinger-devel
48BuildRequires: SDL-devel
49#BuildRequires: slv2-devel
50BuildRequires: soundtouch-devel
51BuildRequires: wavpack-devel
52#BuildRequires: wildmidi-devel
53#BuildRequires: zbar-devel
54BuildRequires: libmms-devel
55BuildRequires: twolame-devel
56#BuildRequires: libmimic-devel
57
58# self build
59#BuildRequires: libdca-devel
60#BuildRequires: faad2-devel
61#BuildRequires: xvidcore-devel
62#BuildRequires: mjpegtools-devel
63
64
65%description
66GStreamer is a streaming media framework, based on graphs of elements which
67operate on media data.
68
69This package contains plug-ins that have licensing issues, aren't tested
70well enough, or the code is not of good enough quality.
71
72
73# %package extras
74# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
75# Group: Applications/Multimedia
76# Requires: %{name} = %{version}-%{release}
77
78# %description extras
79# GStreamer is a streaming media framework, based on graphs of elements which
80# operate on media data.
81
82# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
83# tested well enough, or the code is not of good enough quality.
84
85# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
86# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
87# very much and require additional libraries to be installed.
88
89
90%prep
91%setup -q -n gst-plugins-bad-%{version}
92
93%build
94%configure \
95        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
96
97# Don't use rpath!
98%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
99%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
100%{__make} %{?_smp_mflags}
101
102
103%install
104%{__rm} -rf %{buildroot}
105%{__make} install DESTDIR="%{buildroot}"
106
107# Clean out files that should not be part of the rpm.
108%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
109%{__rm} -f %{buildroot}%{_libdir}/*.la
110
111# conflict with gstreamer1-plugins-bad
112%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
113%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
115%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
116
117REMOVE_MODULE_LIST=" \
118        libgstadpcmdec.so \
119        libgstadpcmenc.so \
120        libgstasfmux.so \
121        libgstaudiovisualizers.so \
122        libgstautoconvert.so \
123        libgstbayer.so \
124        libgstbz2.so \
125        libgstcamerabin2.so \
126        libgstcoloreffects.so \
127        libgstdataurisrc.so \
128        libgstdebugutilsbad.so \
129        libgstdtmf.so \
130        libgstdvb.so \
131        libgstfestival.so \
132        libgstfieldanalysis.so \
133        libgstfragmented.so \
134        libgstfrei0r.so \
135        libgstgaudieffects.so \
136        libgstgdp.so \
137        libgstgeometrictransform.so \
138        libgstgsm.so \
139        libgstid3tag.so \
140        libgstinter.so \
141        libgstinterlace.so \
142        libgstjpegformat.so \
143        libgstliveadder.so \
144        libgstmpegpsdemux.so \
145        libgstmpegtsdemux.so \
146        libgstmpegpsmux.so \
147        libgstmpegtsmux.so \
148        libgstmidi.so \
149        libgstneonhttpsrc.so \
150        libgstpcapparse.so \
151        libgstpnm.so \
152        libgstrawparse.so \
153        libgstremovesilence.so \
154        libgstresindvd.so \
155        libgstrfbsrc.so \
156        libgstrtpmux.so \
157        libgstrtpvp8.so \
158        libgstscaletempoplugin.so \
159        libgstsdpelem.so \
160        libgstsegmentclip.so \
161        libgstshm.so \
162        libgstsmooth.so \
163        libgstsoundtouch.so \
164        libgstspeed.so \
165        libgstsubenc.so \
166        libgstvideoparsersbad.so \
167        libgsty4mdec.so"
168for file in $REMOVE_MODULE_LIST; do
169        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
170done
171
172%clean
173%{__rm} -rf %{buildroot}
174
175
176%post -p /sbin/ldconfig
177
178%postun -p /sbin/ldconfig
179
180
181%files
182%defattr(-,root,root,-)
183%doc AUTHORS COPYING README REQUIREMENTS
184%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
185%{_libdir}/gstreamer-%{majorminor}/libgstcelt.so
186%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
187%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
188%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
189%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
190%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
191%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
192%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
193%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
194%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
195%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
196%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
197%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
198
199
200%changelog
201* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
202- new upstream release
203
204* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
205- new upstream release
206
207* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
208- new upstream release
209
210* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
211- new upstream release
212
213* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
214- new upstream release
215
216* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
217- new upstream release
218
219* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
220- new upstream release
221
222* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
223- new upstream release
224- rename package
225
226* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
227- new upstream release
228- added BuildRequires: libvpx-devel
229
230* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
231- s/self-build-libdvdnav/libdvdnav/
232
233* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
234- new upstream release
235- added BuildRequires:
236  - libmms-devel
237  - librtmp-devel
238
239* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
240- new upstream release
241
242* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
243- new upstream release
244
245* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
246- new upstream release
247- added BuildRequires: libvdpau-devel
248
249* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
250- new upstream release
251
252* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
253- new upstream release
254- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
255  gst-plugins-bad-0.10.5-mms-seek.patch
256
257* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
258- new upstream release
259- dropped devel and devel-docs subpackages
260
261* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
262- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
263- changed to BuildRequires:  self-build-faad2 from faad2-devel
264
265* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
266- initial build based on RPM Fusion package
267
268* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
269- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
270
271* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
272- Rebuild for new x264 (using patch from Rathann)
273
274* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
275- New upstream release 0.10.9
276- Rebuild for new directfb
277
278* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
279- Rebuild for new x264 and to generate new magic gstreamer provides
280
281* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
282- Enable DVD navigation plugin
283
284* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
285- Release bump to keep rpmfusion version higher then livna
286
287* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
288- New upstream release 0.10.8
289- Merge changes from latest freshrpms package: enable ofa and dirac plugins
290
291* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
292- Rebuild for new x264
293
294* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
295- New upstream release 0.10.7
296- Drop many upstreamed patches
297
298* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
299- Rebuild for new x264
300
301* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
302- Enable dc1394 plugin
303
304* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
305- New upstream release 0.10.6-1
306- Drop many upstreamed patches
307- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
308
309* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
310- Fix compilation with gcc 4.3
311
312* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
313- Add flv demuxer from CVS (livna bug 1846)
314
315* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
316- Add patch fixing compilation with mjpegtools 1.9.0rc3
317
318* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
319- Add patch from upstream vcs which makes mms honor your connection speed
320  settings
321- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
322
323* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
324- Rebuild for new faad2
325
326* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
327- Rebuild for new libdca
328
329* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
330- Rebuild for new (old) faad2 (livna bug 1679)
331
332* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
333- Update mythtvsrc code to CVS version (livna bug 1660)
334
335* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
336- No libgstreal.so on ppc / ppc64
337
338* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
339- Fix detection of libdts with current livna libtds, this might need to be
340  changed back again for rpmfusion, depending on how libdts will look there
341
342* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
343- Add mythtvsrc plugin (livna 1646)
344- Put some less often used plugins, which bring in also usually not installed
345  deps in a -extras package
346
347* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
348- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
349- Set release to 4 to be higher as both livna and freshrpms latest release
350- Set package name and origin to rpmfusion
351- Make mpeg2enc plugin compile with current mjpegtools
352- Make the real plugins search for the RealPlayer .so files in various
353  known possible locations instead of using only one hardcoded path to them
354- Make the wildmidi plugin work with the default Fedora timidity patch set
355- Add a couple of missing modtracker mimetypes to the modplug plugin
356- Use the system version of libmodplug
357- Fix building of the neonsrc plugin with the latest (rawhide) neon
358- Disable the ladspa plugin as this has been added to Fedora's rawhide
359  gstreamer-plugins-good
360- Don't put an rpath in the .so's on x86_64
361- Re-enable gtk-doc now that we have a -devel package again
362- Enable libtimidity plugin
363- Fix detection of (and linking with) libdca for the dtsdec plugin
364
365* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
366- Update to 0.10.5.
367- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
368- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
369- Enable new nas, x264, wildmidi and libsndfile plugins.
370- Re-add devel package now that we have a main shared lib and header files.
371- Add check build requirement.
372
373* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
374- Update to 0.10.4 for F7.
375- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
376  somewhat more, maybe then it'll be worth re-enabling.
377- Re-enable wavpack, it works again now.
378- Enable libcdaudio support.
379- Enable jack support.
380- Enable ladspa support.
381- Enable mpeg2enc (mjpegtools) support.
382- Remove no longer present libgstvideo4linux2.so and add all new plugins.
383- Remove all gtk-doc references (all gone...?) and devel package too.
384
385* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
386- Update faad2 patch to also update the plugin sources, not just configure.
387
388* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
389- Try to rebuild against new wavpack 4.40 from Extras : Fails.
390- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
391- Try to include patch to update wavpack plugin source from 0.10.3.2
392  pre-release : Fails to find wavpack/md5.h.
393- Give up and disable wavpack support for now, sorry! Patches welcome.
394- Include patch to fix faad2 2.5 detection.
395- Add soundtouch support.
396
397* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
398- Update to 0.10.3.
399- Add new translations.
400- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
401- Add new libmusicbrainz support.
402
403* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
404- Add libmms support, thanks to Daniel S. Rogers.
405
406* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
407- Update to 0.10.1.
408- Add libgstcdxaparse.so and libgstfreeze.so.
409- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
410
411* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
412- Update to 0.10.0.1, add new plugins.
413- Spec file cleanup and rebuild for FC5.
414
415* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
416- 0.10.0-0.gst.1
417- new release
418
419* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
420- 0.9.7-0.gst.1
421- new release with 0.10 major/minor
422
423* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
424- new release
425- remove tta patch
426- don't check for languages, no translations yet
427- added gtk-doc
428
429* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
430- 0.9.4-0.gst.1
431- new release
432- added speed plugin
433
434* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
435- 0.9.3-0.gst.1
436- new release
437
Note: See TracBrowser for help on using the repository browser.