source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 7938

Revision 7938, 14.9 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.2.0
5%define gstpb_minver 1.2.0
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer1-plugins-bad
9Version: 1.2.0
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
21
22BuildRequires: check
23BuildRequires: gettext
24BuildRequires: PyXML
25BuildRequires: libXt-devel
26
27BuildRequires: bzip2-devel
28BuildRequires: celt-devel
29BuildRequires: exempi-devel
30BuildRequires: jasper-devel
31#BuildRequires: ladspa-devel
32BuildRequires: libass-devel
33BuildRequires: libdc1394-devel
34BuildRequires: libdvdnav-devel
35BuildRequires: libexif-devel
36#BuildRequires: libiptcdata-devel
37BuildRequires: kate-devel
38BuildRequires: libmodplug-devel
39BuildRequires: libmpcdec-devel
40#BuildRequires: libofa-devel
41BuildRequires: librsvg2-devel
42BuildRequires: libsndfile-devel
43#BuildRequires: libtimidity-devel
44BuildRequires: libvpx-devel
45BuildRequires: mesa-libGLU-devel
46BuildRequires: openssl-devel
47BuildRequires: orc-devel
48#BuildRequires: schroedinger-devel
49BuildRequires: SDL-devel
50#BuildRequires: slv2-devel
51BuildRequires: soundtouch-devel
52BuildRequires: wavpack-devel
53#BuildRequires: wildmidi-devel
54#BuildRequires: zbar-devel
55BuildRequires: libmms-devel
56BuildRequires: twolame-devel
57#BuildRequires: libmimic-devel
58
59# self build
60#BuildRequires: libdca-devel
61#BuildRequires: faad2-devel
62#BuildRequires: xvidcore-devel
63#BuildRequires: mjpegtools-devel
64
65
66%description
67GStreamer is a streaming media framework, based on graphs of elements which
68operate on media data.
69
70This package contains plug-ins that have licensing issues, aren't tested
71well enough, or the code is not of good enough quality.
72
73
74# %package extras
75# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
76# Group: Applications/Multimedia
77# Requires: %{name} = %{version}-%{release}
78
79# %description extras
80# GStreamer is a streaming media framework, based on graphs of elements which
81# operate on media data.
82
83# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
84# tested well enough, or the code is not of good enough quality.
85
86# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
87# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
88# very much and require additional libraries to be installed.
89
90
91%prep
92%setup -q -n gst-plugins-bad-%{version}
93
94%build
95%configure \
96        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
97
98# Don't use rpath!
99%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
100%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
101%{__make} %{?_smp_mflags}
102
103
104%install
105%{__rm} -rf %{buildroot}
106%{__make} install DESTDIR="%{buildroot}"
107
108# Clean out files that should not be part of the rpm.
109%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
110%{__rm} -f %{buildroot}%{_libdir}/*.la
111
112# conflict with gstreamer1-plugins-bad
113%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
114%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
116%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
117%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
118
119REMOVE_MODULE_LIST=" \
120        libgstadpcmdec.so \
121        libgstadpcmenc.so \
122        libgstasfmux.so \
123        libgstaudiovisualizers.so \
124        libgstautoconvert.so \
125        libgstbayer.so \
126        libgstbz2.so \
127        libgstcamerabin2.so \
128        libgstcoloreffects.so \
129        libgstdataurisrc.so \
130        libgstdebugutilsbad.so \
131        libgstdtmf.so \
132        libgstdvb.so \
133        libgstfestival.so \
134        libgstfieldanalysis.so \
135        libgstfragmented.so \
136        libgstfrei0r.so \
137        libgstgaudieffects.so \
138        libgstgdp.so \
139        libgstgeometrictransform.so \
140        libgstgsm.so \
141        libgstid3tag.so \
142        libgstinter.so \
143        libgstinterlace.so \
144        libgstjpegformat.so \
145        libgstliveadder.so \
146        libgstmpegpsdemux.so \
147        libgstmpegtsdemux.so \
148        libgstmpegpsmux.so \
149        libgstmpegtsmux.so \
150        libgstmidi.so \
151        libgstneonhttpsrc.so \
152        libgstpcapparse.so \
153        libgstpnm.so \
154        libgstrawparse.so \
155        libgstremovesilence.so \
156        libgstresindvd.so \
157        libgstrfbsrc.so \
158        libgstrtpmux.so \
159        libgstrtpvp8.so \
160        libgstscaletempoplugin.so \
161        libgstsdpelem.so \
162        libgstsegmentclip.so \
163        libgstshm.so \
164        libgstsmooth.so \
165        libgstsoundtouch.so \
166        libgstspeed.so \
167        libgstsubenc.so \
168        libgstvideoparsersbad.so \
169        libgsty4mdec.so \
170        libgstaccurip.so \
171        libgstaiff.so \
172        libgstaudiofxbad \
173        libgstfreeverb.so \
174        libgstivtc.so \
175        libgstmfc.so \
176        libgstmxf.so \
177        libgstrsvg.so \
178        libgstvideofiltersbad.so \
179        libgstaudiofxbad.so \
180        libgstyadif.so"
181for file in $REMOVE_MODULE_LIST; do
182        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
183done
184
185%clean
186%{__rm} -rf %{buildroot}
187
188
189%post -p /sbin/ldconfig
190
191%postun -p /sbin/ldconfig
192
193
194%files
195%defattr(-,root,root,-)
196%doc AUTHORS COPYING README REQUIREMENTS
197%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
198%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
199%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
200%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
201%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
202%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
203%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
204%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
205%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
206%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
207%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
208%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
209%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
210%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
211%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
212%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
213%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
214
215
216%changelog
217* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
218- new upstream release
219
220* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
221- new upstream release
222
223* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
224- new upstream release
225
226* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
227- new upstream release
228
229* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
230- new upstream release
231
232* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
233- new upstream release
234
235* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
236- new upstream release
237
238* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
239- new upstream release
240
241* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
242- new upstream release
243- rename package
244
245* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
246- new upstream release
247- added BuildRequires: libvpx-devel
248
249* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
250- s/self-build-libdvdnav/libdvdnav/
251
252* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
253- new upstream release
254- added BuildRequires:
255  - libmms-devel
256  - librtmp-devel
257
258* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
259- new upstream release
260
261* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
262- new upstream release
263
264* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
265- new upstream release
266- added BuildRequires: libvdpau-devel
267
268* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
269- new upstream release
270
271* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
272- new upstream release
273- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
274  gst-plugins-bad-0.10.5-mms-seek.patch
275
276* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
277- new upstream release
278- dropped devel and devel-docs subpackages
279
280* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
281- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
282- changed to BuildRequires:  self-build-faad2 from faad2-devel
283
284* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
285- initial build based on RPM Fusion package
286
287* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
288- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
289
290* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
291- Rebuild for new x264 (using patch from Rathann)
292
293* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
294- New upstream release 0.10.9
295- Rebuild for new directfb
296
297* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
298- Rebuild for new x264 and to generate new magic gstreamer provides
299
300* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
301- Enable DVD navigation plugin
302
303* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
304- Release bump to keep rpmfusion version higher then livna
305
306* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
307- New upstream release 0.10.8
308- Merge changes from latest freshrpms package: enable ofa and dirac plugins
309
310* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
311- Rebuild for new x264
312
313* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
314- New upstream release 0.10.7
315- Drop many upstreamed patches
316
317* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
318- Rebuild for new x264
319
320* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
321- Enable dc1394 plugin
322
323* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
324- New upstream release 0.10.6-1
325- Drop many upstreamed patches
326- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
327
328* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
329- Fix compilation with gcc 4.3
330
331* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
332- Add flv demuxer from CVS (livna bug 1846)
333
334* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
335- Add patch fixing compilation with mjpegtools 1.9.0rc3
336
337* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
338- Add patch from upstream vcs which makes mms honor your connection speed
339  settings
340- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
341
342* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
343- Rebuild for new faad2
344
345* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
346- Rebuild for new libdca
347
348* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
349- Rebuild for new (old) faad2 (livna bug 1679)
350
351* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
352- Update mythtvsrc code to CVS version (livna bug 1660)
353
354* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
355- No libgstreal.so on ppc / ppc64
356
357* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
358- Fix detection of libdts with current livna libtds, this might need to be
359  changed back again for rpmfusion, depending on how libdts will look there
360
361* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
362- Add mythtvsrc plugin (livna 1646)
363- Put some less often used plugins, which bring in also usually not installed
364  deps in a -extras package
365
366* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
367- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
368- Set release to 4 to be higher as both livna and freshrpms latest release
369- Set package name and origin to rpmfusion
370- Make mpeg2enc plugin compile with current mjpegtools
371- Make the real plugins search for the RealPlayer .so files in various
372  known possible locations instead of using only one hardcoded path to them
373- Make the wildmidi plugin work with the default Fedora timidity patch set
374- Add a couple of missing modtracker mimetypes to the modplug plugin
375- Use the system version of libmodplug
376- Fix building of the neonsrc plugin with the latest (rawhide) neon
377- Disable the ladspa plugin as this has been added to Fedora's rawhide
378  gstreamer-plugins-good
379- Don't put an rpath in the .so's on x86_64
380- Re-enable gtk-doc now that we have a -devel package again
381- Enable libtimidity plugin
382- Fix detection of (and linking with) libdca for the dtsdec plugin
383
384* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
385- Update to 0.10.5.
386- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
387- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
388- Enable new nas, x264, wildmidi and libsndfile plugins.
389- Re-add devel package now that we have a main shared lib and header files.
390- Add check build requirement.
391
392* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
393- Update to 0.10.4 for F7.
394- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
395  somewhat more, maybe then it'll be worth re-enabling.
396- Re-enable wavpack, it works again now.
397- Enable libcdaudio support.
398- Enable jack support.
399- Enable ladspa support.
400- Enable mpeg2enc (mjpegtools) support.
401- Remove no longer present libgstvideo4linux2.so and add all new plugins.
402- Remove all gtk-doc references (all gone...?) and devel package too.
403
404* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
405- Update faad2 patch to also update the plugin sources, not just configure.
406
407* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
408- Try to rebuild against new wavpack 4.40 from Extras : Fails.
409- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
410- Try to include patch to update wavpack plugin source from 0.10.3.2
411  pre-release : Fails to find wavpack/md5.h.
412- Give up and disable wavpack support for now, sorry! Patches welcome.
413- Include patch to fix faad2 2.5 detection.
414- Add soundtouch support.
415
416* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
417- Update to 0.10.3.
418- Add new translations.
419- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
420- Add new libmusicbrainz support.
421
422* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
423- Add libmms support, thanks to Daniel S. Rogers.
424
425* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
426- Update to 0.10.1.
427- Add libgstcdxaparse.so and libgstfreeze.so.
428- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
429
430* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
431- Update to 0.10.0.1, add new plugins.
432- Spec file cleanup and rebuild for FC5.
433
434* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
435- 0.10.0-0.gst.1
436- new release
437
438* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
439- 0.9.7-0.gst.1
440- new release with 0.10 major/minor
441
442* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
443- new release
444- remove tta patch
445- don't check for languages, no translations yet
446- added gtk-doc
447
448* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
449- 0.9.4-0.gst.1
450- new release
451- added speed plugin
452
453* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
454- 0.9.3-0.gst.1
455- new release
456
Note: See TracBrowser for help on using the repository browser.