source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec @ 6410

Revision 6410, 6.6 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname gstreamer-plugins-ugly
2%define major           0.10
3%define _gst_ver        0.10.26
4%define _gstpb_ver      0.10.26
5%define version 0.10.19
6%define release 1%{?_dist_release}
7
8%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           self-build-%{pkgname}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source101:      gstreamer-plugins-ugly-x264.patch
17License:        LGPLv2+
18Group:          Restricted Software
19
20Requires(post):         self-build-setup >= 0.9.9
21
22# (build)requies of target package.
23Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
24Requires(post):         gstreamer-devel >= %{_gst_ver}
25Requires(post):         gstreamer-plugins-base-devel >= %{_gstpb_ver}
26#Requires(post):                gtk-doc >= 1.3
27Requires(post):         python >= 2.1, python-pyxml
28Requires(post):         glib2-devel >= 2.6
29Requires(post):         twolame-devel
30Requires(post):         liboil-devel >= 0.3.0
31Requires(post):         libcdio-devel >= 0.82
32Requires(post):         libdvdread-devel
33Requires(post):         PyXML
34Requires(post):         self-build-libmad >= 0.15
35Requires(post):         libid3tag-devel >= 0.15
36Requires(post):         self-build-ffmpeg
37Requires(post):         self-build-x264
38Requires(post):         self-build-libmpeg2
39Requires(post):         self-build-a52dec
40Requires(post):         self-build-lame
41Requires(post):         self-build-libmad
42
43
44BuildArch:      noarch
45BuildRoot:      %{_tmppath}/%{name}-%{version}-root
46
47Packager:       munepi
48
49%description
50gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
51streaming-media framework.
52
53If you install this package, it automaticaly downloads source
54code, compile it, and create rpm packages of
55%{pkgname}-%{version}.
56And the created rpm packages are automatically installed
57if installation is executed by apt-get command or synaptic
58package manager.
59
60
61[Note]
62This package requires many other packages to compile
63targetsoftware. So it consume more disk space than usual.
64Also installation takes logner time because of compilation.
65(This will take a few minutes to quarter or half of an hour,
66depends on building environment)
67
68[About self-build package]
69For some kind of software, distributing of binary package
70may viorate the patent or law. Therefore we chose self-build
71packge, create binary package on your machine, for such kind
72of softwares instead of distributing binary package.
73
74Please obey the national law when you use the created binary
75packages. And if you want to use the softwares using patented
76thechnology, it may be required to get a permission, make an
77agreement or purchas a license. Please consider it with your
78purpose or way of use and take appropriate action.
79
80%description -l ja
81gstreamer-plugins-ugly は GStreamer ストリーミングメディア
82フレームワーク用 ugly プラグイン集です。
83
84このパッケージをインストールすると、自動的にソースコードを
85ダウンロードしてコンパイルし、%{pkgname}-%{version}
86の rpm パッケージを作成します。
87また apt-get コマンドや synaptic パッケージマネージャから実行
88した場合は、作成された rpm パッケージのインストールも自動的に
89行います。
90
91
92[注意]
93コンパイルに必要な多くの関連パッケージを要求するので通常より
94ディスクの領域を多く消費します。
95またインストール時にコンパイルを行うため、通常より時間がかか
96る場合があります。(環境にもよりますが数分から数十分程度)
97
98[self-build パッケージについて]
99ソフトウェアによってはバイナリパッケージの配布が特許や法律に
100違反する可能性があるものがあります。その為、このような問題が
101懸念されるソフトウェアについてはバイナリパッケージを直接配布
102せずに、ユーザの環境でバイナリを作成する self-build パッケー
103ジという方法を採っています。
104
105作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
106アのライセンス、および利用する国の各種法令に従ってください。
107また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
108センスの購入などが必要となる場合がありますので、利用する目的
109や形態に応じて各自で判断し適切な対応を取ってください。
110
111
112%prep
113[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
114
115
116%install
117%{__rm} -rf ${RPM_BUILD_ROOT}
118%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121
122
123%clean
124%{__rm} -rf ${RPM_BUILD_ROOT}
125
126%posttrans
127/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
128
129%files
130%defattr(-,root,root)
131%{_datadir}/%{name}
132
133%changelog
134* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
135- new upstream relase
136
137* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
138- new upstream relase
139- built with new x264
140- License: LGPLv2+
141
142* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
143- new upstream relase
144
145* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
146- new upstream relase
147
148* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
149- new upstream relase
150
151* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
152- new upstream relase
153- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
154
155* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
156- new upstream relase
157
158* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
159- new upstream relase
160- added Requires(post): self-build-libmpeg2
161  - enable mpeg2dec with libmpeg2-devel in %%configure
162- check version between original spec and self-build spec in %%prep
163
164* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
165- avoided to execute self-build-rpm.sh on RPM transaction
166  - moved %%post actions to %%posttrans
167
168* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
169- added BuildArch: noarch
170- dropped PreReq: gtk-doc >= 1.3
171
172* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
173- new upstream relase
174
175* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
176- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
177
178* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
179- new upstream relase
180
181* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
182- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.