source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec @ 5297

Revision 5297, 6.5 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%define pkgname gstreamer-plugins-ugly
2%define major           0.10
3%define _gst_ver        0.10.18
4%define _gstpb_ver      0.10.26
5%define release 1%{?_dist_release}
6
7%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{_gst_ver}.tar.bz2
8
9Summary:        Package to automatically build %{pkgname} rpm package
10Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
11Name:           self-build-%{pkgname}
12Version:        %{_gst_ver}
13Release:        %{release}
14Source0:        %{pkgname}-vl.spec
15Source101:      gstreamer-plugins-ugly-x264.patch
16License:        LGPLv2+
17Group:          Restricted Software
18
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
23Requires(post):         gstreamer-devel >= %{_gst_ver}
24Requires(post):         gstreamer-plugins-base-devel >= %{_gstpb_ver}
25#Requires(post):                gtk-doc >= 1.3
26Requires(post):         python >= 2.1, python-pyxml
27Requires(post):         glib2-devel >= 2.6
28Requires(post):         twolame-devel
29Requires(post):         liboil-devel >= 0.3.0
30Requires(post):         libcdio-devel >= 0.82
31Requires(post):         libdvdread-devel
32Requires(post):         PyXML
33Requires(post):         self-build-libmad >= 0.15
34Requires(post):         libid3tag-devel >= 0.15
35Requires(post):         self-build-ffmpeg
36Requires(post):         self-build-x264
37Requires(post):         self-build-libmpeg2
38Requires(post):         self-build-a52dec
39Requires(post):         self-build-lame
40Requires(post):         self-build-libmad
41
42
43BuildArch:      noarch
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45
46Packager:       munepi
47
48%description
49gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
50streaming-media framework.
51
52If you install this package, it automaticaly downloads source
53code, compile it, and create rpm packages of
54%{pkgname}-%{version}.
55And the created rpm packages are automatically installed
56if installation is executed by apt-get command or synaptic
57package manager.
58
59
60[Note]
61This package requires many other packages to compile
62targetsoftware. So it consume more disk space than usual.
63Also installation takes logner time because of compilation.
64(This will take a few minutes to quarter or half of an hour,
65depends on building environment)
66
67[About self-build package]
68For some kind of software, distributing of binary package
69may viorate the patent or law. Therefore we chose self-build
70packge, create binary package on your machine, for such kind
71of softwares instead of distributing binary package.
72
73Please obey the national law when you use the created binary
74packages. And if you want to use the softwares using patented
75thechnology, it may be required to get a permission, make an
76agreement or purchas a license. Please consider it with your
77purpose or way of use and take appropriate action.
78
79%description -l ja
80gstreamer-plugins-ugly は GStreamer ストリーミングメディア
81フレームワーク用 ugly プラグイン集です。
82
83このパッケージをインストールすると、自動的にソースコードを
84ダウンロードしてコンパイルし、%{pkgname}-%{version}
85の rpm パッケージを作成します。
86また apt-get コマンドや synaptic パッケージマネージャから実行
87した場合は、作成された rpm パッケージのインストールも自動的に
88行います。
89
90
91[注意]
92コンパイルに必要な多くの関連パッケージを要求するので通常より
93ディスクの領域を多く消費します。
94またインストール時にコンパイルを行うため、通常より時間がかか
95る場合があります。(環境にもよりますが数分から数十分程度)
96
97[self-build パッケージについて]
98ソフトウェアによってはバイナリパッケージの配布が特許や法律に
99違反する可能性があるものがあります。その為、このような問題が
100懸念されるソフトウェアについてはバイナリパッケージを直接配布
101せずに、ユーザの環境でバイナリを作成する self-build パッケー
102ジという方法を採っています。
103
104作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
105アのライセンス、および利用する国の各種法令に従ってください。
106また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
107センスの購入などが必要となる場合がありますので、利用する目的
108や形態に応じて各自で判断し適切な対応を取ってください。
109
110
111%prep
112[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
113
114
115%install
116%{__rm} -rf ${RPM_BUILD_ROOT}
117%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120
121
122%clean
123%{__rm} -rf ${RPM_BUILD_ROOT}
124
125%posttrans
126/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
127
128%files
129%defattr(-,root,root)
130%{_datadir}/%{name}
131
132%changelog
133* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
134- new upstream relase
135- built with new x264
136- License: LGPLv2+
137
138* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
139- new upstream relase
140
141* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
142- new upstream relase
143
144* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
145- new upstream relase
146
147* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
148- new upstream relase
149- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
150
151* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
152- new upstream relase
153
154* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
155- new upstream relase
156- added Requires(post): self-build-libmpeg2
157  - enable mpeg2dec with libmpeg2-devel in %%configure
158- check version between original spec and self-build spec in %%prep
159
160* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
161- avoided to execute self-build-rpm.sh on RPM transaction
162  - moved %%post actions to %%posttrans
163
164* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
165- added BuildArch: noarch
166- dropped PreReq: gtk-doc >= 1.3
167
168* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
169- new upstream relase
170
171* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
172- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
173
174* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
175- new upstream relase
176
177* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
178- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.