source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 6410

Revision 6410, 11.3 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.26
5%define _gstpb_ver      0.10.26
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer-plugins-ugly
10Version:        0.10.19
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer >= %{_gst_ver}
19Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer-devel >= %{_gst_ver}
27BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
47
48%description
49GStreamer is a streaming-media framework, based on graphs of filters which
50operate on media data. Applications using this library can do anything
51from real-time sound processing to playing videos, and just about anything
52else media-related.  Its plugin-based architecture means that new data
53types or processing capabilities can be added simply by installing new
54plugins.
55
56This package contains a set of plug-ins that have good quality and
57correct functionality, but distributing them might pose problems. The
58license on either the plug-ins or the supporting libraries might not
59be how the GStreamer authors like. The code might be widely known to
60present patent problems.
61
62%description -l ja
63GStreamer はメディアデータ操作用の filter graph をベースにしたスト
64リーミングメディアフレームワークです。 このライブラリを使用すれば
65アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
66メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
67イン方式を採用していることから、新しい種類のデータや機能への対応が、
68プラグインを追加することで簡単に実現できます。
69
70このパッケージは品質も機能も問題は無いものの、配布すると問題になる
71可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
72ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
73関連するコードとして良く知られています。
74
75# %package devel
76# Summary:      Documentation files for GStreamer ugly plugins.
77# Summary(ja):  GStreamer ugly プラグインのドキュメント
78# Group:                Development/Libraries
79# Requires:     %{name} = %{version}-%{release}
80
81# %description devel
82# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
83# リーミングメディアフレームワークです。 このライブラリを使用すれば
84# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
85# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
86# イン方式を採用していることから、新しい種類のデータや機能への対応が、
87# プラグインを追加することで簡単に実現できます。
88
89# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
90
91
92%prep
93%setup -q -n gst-plugins-ugly-%{version}
94
95
96%build
97%configure \
98    --disable-static \
99    --disable-amrnb \
100    --disable-sidplay \
101
102%__make %{?_smp_mflags}
103
104%install
105%__rm -rf %{buildroot}
106%makeinstall
107
108# Clean out files that should not be part of the rpm.
109%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
110%__rm -f %{buildroot}%{_libdir}/*.{a,la}
111
112%find_lang gst-plugins-ugly-%{major}
113
114%clean
115%__rm -rf %{buildroot}
116
117
118%files -f gst-plugins-ugly-%{major}.lang
119%defattr(-,root,root)
120%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
121%{_datadir}/gstreamer-%{major}/presets
122# ugly plugins without external dependencies
123%{_libdir}/gstreamer-%{major}/*.so
124
125# ugly plugins with external dependencies, but in the main package
126# %{_libdir}/gstreamer-%{major}/libgstmad.so
127
128# %files devel
129# %defattr(-,root,root)
130# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
131
132
133%changelog
134* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
135- new upstream relase
136
137* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
138- new upstream relase
139- built with new x264
140- License: LGPLv2+
141
142* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
143- new upstream relase
144
145* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
146- new upstream relase
147
148* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
149- new upstream relase
150
151* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
152- new upstream relase
153
154* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
155- new upstream relase
156
157* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
158- new upstream relase
159- enable mpeg2dec with libmpeg2-devel in %%configure
160
161* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
162- change release to sync with self-build-gstreamer-plugins-ugly
163
164* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
165- dropped BuildRequires: gtk-doc >= 1.3
166  - disable-gtk-doc in configure options
167  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
168
169* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
170- new upstream relase
171
172* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
173- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
174
175* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
176- new upstream relase
177
178* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
179- upstream release
180- delete --disable-a52dec configure option
181- delete %%with_lame macro
182- added japanase summary and description
183
184* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
185- upstream release
186- update %%_gst_ver
187
188* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
189- add NoSource: 0
190
191* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
192- add %%with_lame macro
193  - enable lame support if rpmbuild with '--with lame'
194
195* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
196- upstream release
197
198* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
199- upstream release
200- add libgstdvdsub.so
201
202* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
203- upstream release
204- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
205- add libgstasf.so
206
207* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
208- fix typo
209
210* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
211- initial package based on gstreamer-plugins
212- new upstream release
213  - change major to 0.10
214- update dependencies
215- update %%configure options
216
217* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
218- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
219
220* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
221- added missing alsa plugin
222
223* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
224- new upstream release
225- added alsa and cairo plugins
226
227* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
228- new upstream release
229
230* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
231- new upstream release
232
233* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
234- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
235
236* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
237- added libgstcdparania.so for gnome-cd (gnome-media)
238- BuildRequires: cdparanoia-devel
239
240* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
241- drop BuildRequires: xmms-devel, Requires: xmms
242
243* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
244- libgstvideo4linux2.so temoporally omitted for ppc
245  (will be back later, I hope)
246
247* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
248- new upstream release
249- s/Copyright/License/
250- includes plugins depend on main package libraries only
251
252* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
253- new upstream release
254
255* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
256- new upstream release
257
258* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
259- new upstream release
260
261* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
262- new upstream release
263
264* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
265- build with -fPIC on alpha
266
267* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
268- modified scripts
269
270* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
271- new upstream release
272
273* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
274- disable some plugins.
275
276* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
277- new upstream release
278- initial build for Vine Linux
279
280* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
281- Include ia64
282- Add BuildRequires: autoconf automake
283
284* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
285- rebuild
286
287* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
288- rebuild
289
290* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
291- rebuild
292- disable tests
293
294* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
295- rebuild
296
297* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
298- fix libdir for ia64.
299
300* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
301- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
302- Add devel package
303
304* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
305- 0.5.0
306- apparently, festival-devel isn't needed.
307
308* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
309- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
310
311* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
312- excludearch the arches that can't build gstreamer cothreads
313- well it isn't really SMP-safe
314- add patch for including pthread.h when required
315- prereq gconftool
316- fix typo that broke schema installation in post
317
318* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
319- initial "official" import
320- munge tarball for legal cleanliness
321
322* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
323- 0.4.2
324
325* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
326- 0.4.1
327- install the gconf schema
328- use %%configure
329
330* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
331- update to 0.4.0
332- give explicit vorbis include path, don't run vorbis test
333
334* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
335- collapse into one package to preserve some sanity
336
337* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
338- added more BuildRequires and Requires
339- rearranged some plugins
340- added changelog ;)
Note: See TracBrowser for help on using the repository browser.