source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 8803

Revision 8803, 11.5 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: libcdio-paranoia
others: new upstream release or rebuild

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.26
5%define _gstpb_ver      0.10.26
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer-plugins-ugly
10Version:        0.10.19
11Release:        2%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
16
17Patch2:         gstreamer-plugins-ugly-libcdio-0.92.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21Requires:       gstreamer >= %{_gst_ver}
22Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
23Requires:       glib2
24Requires:       libid3tag
25# Don't require libmad because they are provided by
26# self-build-libmad packages.
27#Requires:      libmad
28
29BuildRequires:  gstreamer-devel >= %{_gst_ver}
30BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
31#BuildRequires: gtk-doc >= 1.3
32BuildRequires:  python >= 2.1, python-pyxml
33BuildRequires:  glib2-devel >= 2.6
34BuildRequires:  twolame-devel
35BuildRequires:  libid3tag-devel >= 0.15
36BuildRequires:  liboil-devel >= 0.3.0
37BuildRequires:  libcdio-devel >= 0.82
38BuildRequires:  libdvdread-devel
39BuildRequires:  PyXML
40
41# *-devel packages provided by other self-build-* should only be listed
42# in self-build-%{name}.spec as PreReq.
43##BuildRequires:        x264-devel
44##BuildRequires:        libmpeg2-devel
45##BuildRequires:        a52dec-devel
46##BuildRequires:        lame-devel
47##BuildRequires:        libmad-devel >= 0.15
48
49Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
50
51%description
52GStreamer is a streaming-media framework, based on graphs of filters which
53operate on media data. Applications using this library can do anything
54from real-time sound processing to playing videos, and just about anything
55else media-related.  Its plugin-based architecture means that new data
56types or processing capabilities can be added simply by installing new
57plugins.
58
59This package contains a set of plug-ins that have good quality and
60correct functionality, but distributing them might pose problems. The
61license on either the plug-ins or the supporting libraries might not
62be how the GStreamer authors like. The code might be widely known to
63present patent problems.
64
65%description -l ja
66GStreamer はメディアデータ操作用の filter graph をベースにしたスト
67リーミングメディアフレームワークです。 このライブラリを使用すれば
68アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
69メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
70イン方式を採用していることから、新しい種類のデータや機能への対応が、
71プラグインを追加することで簡単に実現できます。
72
73このパッケージは品質も機能も問題は無いものの、配布すると問題になる
74可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
75ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
76関連するコードとして良く知られています。
77
78# %package devel
79# Summary:      Documentation files for GStreamer ugly plugins.
80# Summary(ja):  GStreamer ugly プラグインのドキュメント
81# Group:                Development/Libraries
82# Requires:     %{name} = %{version}-%{release}
83
84# %description devel
85# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
86# リーミングメディアフレームワークです。 このライブラリを使用すれば
87# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
88# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
89# イン方式を採用していることから、新しい種類のデータや機能への対応が、
90# プラグインを追加することで簡単に実現できます。
91
92# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
93
94
95%prep
96%setup -q -n gst-plugins-ugly-%{version}
97%patch2 -p1 -b .cdio
98
99%build
100%configure \
101    --disable-static \
102    --disable-amrnb \
103    --disable-sidplay \
104
105%__make %{?_smp_mflags}
106
107%install
108%__rm -rf %{buildroot}
109%makeinstall
110
111# Clean out files that should not be part of the rpm.
112%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
113%__rm -f %{buildroot}%{_libdir}/*.{a,la}
114
115%find_lang gst-plugins-ugly-%{major}
116
117%clean
118%__rm -rf %{buildroot}
119
120
121%files -f gst-plugins-ugly-%{major}.lang
122%defattr(-,root,root)
123%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
124%{_datadir}/gstreamer-%{major}/presets
125# ugly plugins without external dependencies
126%{_libdir}/gstreamer-%{major}/*.so
127
128# ugly plugins with external dependencies, but in the main package
129# %{_libdir}/gstreamer-%{major}/libgstmad.so
130
131# %files devel
132# %defattr(-,root,root)
133# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
134
135
136%changelog
137* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-2
138- rebuild with libcdio-0.92
139- add patch2 (gstreamer-plugins-ugly-libcdio-0.92.patch)
140
141* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
142- new upstream relase
143
144* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
145- new upstream relase
146- built with new x264
147- License: LGPLv2+
148
149* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
150- new upstream relase
151
152* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
153- new upstream relase
154
155* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
156- new upstream relase
157
158* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
159- new upstream relase
160
161* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
162- new upstream relase
163
164* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
165- new upstream relase
166- enable mpeg2dec with libmpeg2-devel in %%configure
167
168* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
169- change release to sync with self-build-gstreamer-plugins-ugly
170
171* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
172- dropped BuildRequires: gtk-doc >= 1.3
173  - disable-gtk-doc in configure options
174  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
175
176* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
177- new upstream relase
178
179* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
180- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
181
182* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
183- new upstream relase
184
185* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
186- upstream release
187- delete --disable-a52dec configure option
188- delete %%with_lame macro
189- added japanase summary and description
190
191* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
192- upstream release
193- update %%_gst_ver
194
195* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
196- add NoSource: 0
197
198* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
199- add %%with_lame macro
200  - enable lame support if rpmbuild with '--with lame'
201
202* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
203- upstream release
204
205* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
206- upstream release
207- add libgstdvdsub.so
208
209* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
210- upstream release
211- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
212- add libgstasf.so
213
214* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
215- fix typo
216
217* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
218- initial package based on gstreamer-plugins
219- new upstream release
220  - change major to 0.10
221- update dependencies
222- update %%configure options
223
224* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
225- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
226
227* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
228- added missing alsa plugin
229
230* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
231- new upstream release
232- added alsa and cairo plugins
233
234* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
235- new upstream release
236
237* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
238- new upstream release
239
240* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
241- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
242
243* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
244- added libgstcdparania.so for gnome-cd (gnome-media)
245- BuildRequires: cdparanoia-devel
246
247* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
248- drop BuildRequires: xmms-devel, Requires: xmms
249
250* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
251- libgstvideo4linux2.so temoporally omitted for ppc
252  (will be back later, I hope)
253
254* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
255- new upstream release
256- s/Copyright/License/
257- includes plugins depend on main package libraries only
258
259* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
260- new upstream release
261
262* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
263- new upstream release
264
265* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
266- new upstream release
267
268* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
269- new upstream release
270
271* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
272- build with -fPIC on alpha
273
274* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
275- modified scripts
276
277* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
278- new upstream release
279
280* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
281- disable some plugins.
282
283* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
284- new upstream release
285- initial build for Vine Linux
286
287* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
288- Include ia64
289- Add BuildRequires: autoconf automake
290
291* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
292- rebuild
293
294* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
295- rebuild
296
297* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
298- rebuild
299- disable tests
300
301* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
302- rebuild
303
304* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
305- fix libdir for ia64.
306
307* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
308- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
309- Add devel package
310
311* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
312- 0.5.0
313- apparently, festival-devel isn't needed.
314
315* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
316- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
317
318* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
319- excludearch the arches that can't build gstreamer cothreads
320- well it isn't really SMP-safe
321- add patch for including pthread.h when required
322- prereq gconftool
323- fix typo that broke schema installation in post
324
325* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
326- initial "official" import
327- munge tarball for legal cleanliness
328
329* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
330- 0.4.2
331
332* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
333- 0.4.1
334- install the gconf schema
335- use %%configure
336
337* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
338- update to 0.4.0
339- give explicit vorbis include path, don't run vorbis test
340
341* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
342- collapse into one package to preserve some sanity
343
344* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
345- added more BuildRequires and Requires
346- rearranged some plugins
347- added changelog ;)
Note: See TracBrowser for help on using the repository browser.