source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 9424

Revision 9424, 11.3 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.5.2
8Release:     1%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     https://github.com/gpac/gpac/archive/v%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16Patch2:      gpac-0.4.6-amr.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
21Obsoletes:      %{name}-devel < %{version}
22Obsoletes:      %{name}-devel-static < %{version}
23
24Requires: %{name}-libs = %{version}-%{release}
25BuildRequires:  ImageMagick
26BuildRequires:  SDL-devel
27BuildRequires:  librsvg2-devel >= 2.5.0
28BuildRequires:  libGLU-devel
29BuildRequires:  freeglut-devel
30BuildRequires:  freetype2-devel >= 2.1.4
31BuildRequires:  libjpeg-devel
32BuildRequires:  libpng-devel >= 1.2.5
33BuildRequires:  libxml2-devel
34BuildRequires:  openssl-devel
35#BuildRequires:  openjpeg-devel
36BuildRequires:  pulseaudio-libs-devel
37BuildRequires:  zlib-devel
38BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
39BuildRequires:  libXt-devel
40BuildRequires:  libXpm-devel
41BuildRequires:  libXv-devel
42#BuildRequires:  wxGTK-devel
43%{?_with_mozilla:BuildRequires: gecko-devel}
44#BuildRequires:  doxygen
45BuildRequires:  desktop-file-utils
46%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
47# *-devel packages provided by other self-build-* should only be listed
48# in self-build-%{name}.spec as PreReq.
49#BuildRequires:  a52dec-devel
50#BuildRequires:  faad2-devel
51#BuildRequires:  libmad-devel
52#BuildRequires:  xvidcore-devel >= 1.0.0
53##BuildRequires:  ffmpeg-devel
54
55
56%description
57GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
58from scratch in ANSI C.  The original development goal is to provide a clean,
59small and flexible alternative to the MPEG-4 Systems reference software.
60
61GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
62X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
63MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
64for MP4 and 3GPP(2) files and many tools for scene descriptions
65(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
66
67%package        libs
68Summary:        Library for %{name}
69Group:          System Environment/Libraries
70
71%description    libs
72The %{name}-libs package contains library for %{name}.
73
74
75%package  devel
76Summary:  Development libraries and files for %{name}
77Group:    Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79
80
81%description  devel
82Development libraries and files for gpac.
83
84
85%if %{with_static}
86%package  devel-static
87Summary:  Development libraries and files for %{name}
88Group:    Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90
91
92%description  devel-static
93Static library for gpac.
94%endif
95
96
97%prep
98%setup -q
99## remove extra_libs directory
100%__rm -rf extra_libs
101
102%patch2 -p1 -b .amr
103
104## kwizart - enable dynamic mode - hardcoded with patch2
105# define SONAME number from the first number of gpac version.
106#define soname libgpac.so.0
107#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
108
109# Fix encoding warnings
110%__cp -p Changelog Changelog.origine
111iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
112touch -r Changelog.origine Changelog
113%__rm -rf Changelog.origine
114
115%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
116iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
117touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
118%__rm -rf doc/ipmpx_syntax.bt.origine
119
120
121# executable ./configure
122chmod +x configure
123
124%build
125%configure \
126    --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
127  --X11-path=%{_prefix} \
128  --libdir=%{_lib} \
129    --disable-oss-audio \
130    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
131    %{?_with_amr:--enable-amr} \
132    --disable-static \
133    --use-js=no \
134    \
135    --disable-wx \
136    ;
137
138#Avoid mess with setup.h
139%__cp -p config.h include/gpac
140
141# Parallele build will fail
142%__make all
143%__make sggen
144
145# ## kwizart - build doxygen doc for devel
146# pushd doc
147# doxygen
148# popd
149
150%install
151%__rm -rf $RPM_BUILD_ROOT
152%__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
153
154#Install generated sggen binaries
155#MPEG4 SVG X3D
156for b in MPEG4 X3D; do
157  pushd applications/generators/${b}
158    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
159  popd
160done
161
162#config.h like but not only
163#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
164%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
165touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
166touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
167touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
168%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
169
170
171%clean
172%__rm -rf $RPM_BUILD_ROOT
173
174%post libs -p /sbin/ldconfig
175
176%postun libs -p /sbin/ldconfig
177
178
179%files
180%defattr(-,root,root,-)
181%doc AUTHORS BUGS Changelog COPYING README TODO
182%{_bindir}/MP4*
183%{_bindir}/*Gen
184%{_datadir}/gpac/
185%{_mandir}/man1/*.1.*
186
187%files libs
188%defattr(-,root,root)
189%{_libdir}/libgpac.so.*
190%{_libdir}/gpac/
191
192%files devel
193%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
194%defattr(-,root,root)
195%{_includedir}/gpac/
196%{_libdir}/libgpac.so
197
198%if %{with_static}
199%files devel-static
200%defattr(-,root,root,-)
201%{_libdir}/libgpac_static.a
202%else
203%exclude %{_libdir}/libgpac_static.a
204%endif
205
206
207%changelog
208* Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
209- new upstream release
210- remove Patch1 (gpac-0.5.0-libdir.patch)
211
212* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
213- rebuilt
214
215* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
216- remove BuildRequires: xmlrpc-epi-devel
217
218* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
219- added Obsoletes: %{name} < %{version} and so on.
220
221* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
222- rebuild
223
224* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
225- new upstream release
226
227* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
228- rebuild
229
230* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
231- update snapshot svn20111217
232- removed upstreamed/obsolated patches
233
234* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
235- rebuilt with internal openjpeg
236  - added --use-openjpeg=local in configure options
237- added --enable-pic in configure options
238
239* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
240- rebuild
241
242* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
243- removed doxygen support
244
245* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
246- change release to sync with self-build-gpac
247
248* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
249- rebuild
250
251* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
252- added --use-js=no in configure
253- added devel-static subpackage
254
255* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
256- change release to sync with self-build-gpac
257
258* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
259- change release to sync with self-build-gpac
260
261* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
262- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
263- corrected default %%defattr
264
265* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
266- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
267  - rebuilt with ffmpeg-devel by self-build-ffmpeg
268
269* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
270- initial build based on RPM Fusion
271  - without Osmo4 and its plugins for Mozilla browsers
272  - added --disable-wx in configure options
273  - included %%{_libdir}/libgpac_static.a in devel subpackage
274
275* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
276- Fix -devel doc timestamp which leads to multilib conflict
277  ( RPM Fusion #270 )
278
279* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
280- Fix for ppc64
281
282* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
283- Update to 0.4.5 (final)
284- Drop upstreamed patches - Rewrite some
285- Add More BR.
286- Conditionalize --with mozilla amr
287
288* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
289- Fix for Large File Support (was livna #2075 )
290
291* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
292- Enable devel-static
293- Conditionalize Osmo4 (buggy).
294- Clean the spec
295
296* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
297- Update to 20080217.
298- Split libs.
299- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
300- Add openjpeg-devel missing BR
301- Static patching instead of dyn patch when possible.
302- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
303- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
304- Exclude static lib
305
306* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
307- Use %%{smp_mflags}
308- Oops, we're actually 0.4.5
309- Fix gpac so filenames
310- Only install nposmozilla when %%{with_firefox} is set
311
312* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
313- Update to 20080211cvs
314- Disable osmozilla, doesn't build with xulrunner
315- Fix builds with gcc 4.3
316
317* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
318- Rebuild for rawhide
319
320* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
321- Update to v4.4
322
323* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
324- Update to cvs 20070526
325- Enable conditional build ( 3gpp firefox )
326
327* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
328- Update to cvs 20070411
329
330* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
331- Update to 20061208
332- Uses firefox-devel (since fc6!)
333- Drop tutorial
334- Use version-DEV-date with libgpac.so
335- Disabled osmozilla
336- Fix soname
337- Enabled gprof
338
339* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
340- gpac snapshot.sh
341- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
342- TODO: - no-soname make option for libgpac.so
343  - static lib in devel - needed ?
344  - osmozilla - xpt link problem.
345  - Osmo4: segmentation fault on exit.
346  - MP4Client: segmentation fault on launch.
347  - The program 'Osmo4' received an X Window System error:
348  "The error was 'BadMatch (invalid parameter attributes)'.
349  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
350  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
351
352* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
353- Update to 0.4.2cvs20061017
354- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
355- Enable mozilla plugin: osmozilla.
356- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
357- Provide documentation html in doc .
358- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
359- Various corrections.
360
361* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
362- lib64 fixes
363
364* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
365- initial package
Note: See TracBrowser for help on using the repository browser.