source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 9215

Revision 9215, 11.2 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.5.0
8Release:     5%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16Patch1:      gpac-0.5.0-libdir.patch
17Patch2:      gpac-0.4.6-amr.patch
18
19BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
20
21Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
22Obsoletes:      %{name}-devel < %{version}
23Obsoletes:      %{name}-devel-static < %{version}
24
25Requires: %{name}-libs = %{version}-%{release}
26BuildRequires:  ImageMagick
27BuildRequires:  SDL-devel
28BuildRequires:  librsvg2-devel >= 2.5.0
29BuildRequires:  libGLU-devel
30BuildRequires:  freeglut-devel
31BuildRequires:  freetype2-devel >= 2.1.4
32BuildRequires:  libjpeg-devel
33BuildRequires:  libpng-devel >= 1.2.5
34BuildRequires:  libxml2-devel
35BuildRequires:  openssl-devel
36#BuildRequires:  openjpeg-devel
37BuildRequires:  pulseaudio-libs-devel
38BuildRequires:  zlib-devel
39BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
40BuildRequires:  libXt-devel
41BuildRequires:  libXpm-devel
42BuildRequires:  libXv-devel
43#BuildRequires:  wxGTK-devel
44%{?_with_mozilla:BuildRequires: gecko-devel}
45#BuildRequires:  doxygen
46BuildRequires:  desktop-file-utils
47%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
48# *-devel packages provided by other self-build-* should only be listed
49# in self-build-%{name}.spec as PreReq.
50#BuildRequires:  a52dec-devel
51#BuildRequires:  faad2-devel
52#BuildRequires:  libmad-devel
53#BuildRequires:  xvidcore-devel >= 1.0.0
54##BuildRequires:  ffmpeg-devel
55
56
57%description
58GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
59from scratch in ANSI C.  The original development goal is to provide a clean,
60small and flexible alternative to the MPEG-4 Systems reference software.
61
62GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
63X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
64MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
65for MP4 and 3GPP(2) files and many tools for scene descriptions
66(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
67
68%package        libs
69Summary:        Library for %{name}
70Group:          System Environment/Libraries
71
72%description    libs
73The %{name}-libs package contains library for %{name}.
74
75
76%package  devel
77Summary:  Development libraries and files for %{name}
78Group:    Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81
82%description  devel
83Development libraries and files for gpac.
84
85
86%if %{with_static}
87%package  devel-static
88Summary:  Development libraries and files for %{name}
89Group:    Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91
92
93%description  devel-static
94Static library for gpac.
95%endif
96
97
98%prep
99%setup -q -n gpac
100## remove extra_libs directory
101%__rm -rf extra_libs
102
103%patch1 -p1 -b .libdir
104%patch2 -p1 -b .amr
105
106## kwizart - enable dynamic mode - hardcoded with patch2
107# define SONAME number from the first number of gpac version.
108#define soname libgpac.so.0
109#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
110
111# Fix encoding warnings
112%__cp -p Changelog Changelog.origine
113iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
114touch -r Changelog.origine Changelog
115%__rm -rf Changelog.origine
116
117%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
118iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
119touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
120%__rm -rf doc/ipmpx_syntax.bt.origine
121
122
123# executable ./configure
124chmod +x configure
125
126%build
127%configure \
128    --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
129  --X11-path=%{_prefix} \
130  --libdir=%{_lib} \
131    --disable-oss-audio \
132    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
133    %{?_with_amr:--enable-amr} \
134    --disable-static \
135    --use-js=no \
136    \
137    --disable-wx \
138    ;
139
140#Avoid mess with setup.h
141%__cp -p config.h include/gpac
142
143# Parallele build will fail
144%__make all
145%__make sggen
146
147# ## kwizart - build doxygen doc for devel
148# pushd doc
149# doxygen
150# popd
151
152%install
153%__rm -rf $RPM_BUILD_ROOT
154%__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
155
156#Install generated sggen binaries
157#MPEG4 SVG X3D
158for b in MPEG4 X3D; do
159  pushd applications/generators/${b}
160    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
161  popd
162done
163
164#config.h like but not only
165#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
166%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
167touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
168touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
169touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
170%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
171
172
173%clean
174%__rm -rf $RPM_BUILD_ROOT
175
176%post libs -p /sbin/ldconfig
177
178%postun libs -p /sbin/ldconfig
179
180
181%files
182%defattr(-,root,root,-)
183%doc AUTHORS BUGS Changelog COPYING README TODO
184%{_bindir}/MP4*
185%{_bindir}/*Gen
186%{_datadir}/gpac/
187%{_mandir}/man1/*.1.*
188
189%files libs
190%defattr(-,root,root)
191%{_libdir}/libgpac.so.*
192%{_libdir}/gpac/
193
194%files devel
195%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
196%defattr(-,root,root)
197%{_includedir}/gpac/
198%{_libdir}/libgpac.so
199
200%if %{with_static}
201%files devel-static
202%defattr(-,root,root,-)
203%{_libdir}/libgpac_static.a
204%else
205%exclude %{_libdir}/libgpac_static.a
206%endif
207
208
209%changelog
210* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
211- rebuilt
212
213* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
214- remove BuildRequires: xmlrpc-epi-devel
215
216* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
217- added Obsoletes: %{name} < %{version} and so on.
218
219* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
220- rebuild
221
222* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
223- new upstream release
224
225* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
226- rebuild
227
228* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
229- update snapshot svn20111217
230- removed upstreamed/obsolated patches
231
232* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
233- rebuilt with internal openjpeg
234  - added --use-openjpeg=local in configure options
235- added --enable-pic in configure options
236
237* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
238- rebuild
239
240* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
241- removed doxygen support
242
243* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
244- change release to sync with self-build-gpac
245
246* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
247- rebuild
248
249* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
250- added --use-js=no in configure
251- added devel-static subpackage
252
253* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
254- change release to sync with self-build-gpac
255
256* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
257- change release to sync with self-build-gpac
258
259* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
260- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
261- corrected default %%defattr
262
263* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
264- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
265  - rebuilt with ffmpeg-devel by self-build-ffmpeg
266
267* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
268- initial build based on RPM Fusion
269  - without Osmo4 and its plugins for Mozilla browsers
270  - added --disable-wx in configure options
271  - included %%{_libdir}/libgpac_static.a in devel subpackage
272
273* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
274- Fix -devel doc timestamp which leads to multilib conflict
275  ( RPM Fusion #270 )
276
277* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
278- Fix for ppc64
279
280* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
281- Update to 0.4.5 (final)
282- Drop upstreamed patches - Rewrite some
283- Add More BR.
284- Conditionalize --with mozilla amr
285
286* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
287- Fix for Large File Support (was livna #2075 )
288
289* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
290- Enable devel-static
291- Conditionalize Osmo4 (buggy).
292- Clean the spec
293
294* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
295- Update to 20080217.
296- Split libs.
297- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
298- Add openjpeg-devel missing BR
299- Static patching instead of dyn patch when possible.
300- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
301- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
302- Exclude static lib
303
304* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
305- Use %%{smp_mflags}
306- Oops, we're actually 0.4.5
307- Fix gpac so filenames
308- Only install nposmozilla when %%{with_firefox} is set
309
310* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
311- Update to 20080211cvs
312- Disable osmozilla, doesn't build with xulrunner
313- Fix builds with gcc 4.3
314
315* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
316- Rebuild for rawhide
317
318* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
319- Update to v4.4
320
321* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
322- Update to cvs 20070526
323- Enable conditional build ( 3gpp firefox )
324
325* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
326- Update to cvs 20070411
327
328* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
329- Update to 20061208
330- Uses firefox-devel (since fc6!)
331- Drop tutorial
332- Use version-DEV-date with libgpac.so
333- Disabled osmozilla
334- Fix soname
335- Enabled gprof
336
337* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
338- gpac snapshot.sh
339- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
340- TODO: - no-soname make option for libgpac.so
341  - static lib in devel - needed ?
342  - osmozilla - xpt link problem.
343  - Osmo4: segmentation fault on exit.
344  - MP4Client: segmentation fault on launch.
345  - The program 'Osmo4' received an X Window System error:
346  "The error was 'BadMatch (invalid parameter attributes)'.
347  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
348  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
349
350* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
351- Update to 0.4.2cvs20061017
352- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
353- Enable mozilla plugin: osmozilla.
354- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
355- Provide documentation html in doc .
356- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
357- Various corrections.
358
359* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
360- lib64 fixes
361
362* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
363- initial package
Note: See TracBrowser for help on using the repository browser.