source: projects/specs/trunk/nonfree/self-build-gpac/gpac-vl.spec @ 8607

Revision 8607, 11.3 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: eudev
rtmpdump: add R: gmp-devel
gpac: remove Requires
others: rebuild with eudev

Line 
1#% global svndate  20111217
2
3%define with_static   1
4
5Name:        gpac
6Summary:     MPEG-4 multimedia framework
7Version:     0.5.0
8Release:     4%{?svndate:.svn%svndate}%{?_dist_release}
9License:     LGPLv2+
10Group:       System Environment/Libraries
11URL:         http://gpac.sourceforge.net/
12Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
13#Source0:     gpac-%{svndate}.tar.bz2
14#Source9:     gpac-snapshot-vine.sh
15
16Patch1:      gpac-0.5.0-libdir.patch
17Patch2:      gpac-0.4.6-amr.patch
18
19BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
20
21Obsoletes:      %{name} < %{version}, %{name}-libs < %{version}
22Obsoletes:      %{name}-devel < %{version}
23Obsoletes:      %{name}-devel-static < %{version}
24
25Requires: %{name}-libs = %{version}-%{release}
26BuildRequires:  ImageMagick
27BuildRequires:  SDL-devel
28BuildRequires:  librsvg2-devel >= 2.5.0
29BuildRequires:  libGLU-devel
30BuildRequires:  freeglut-devel
31BuildRequires:  freetype2-devel >= 2.1.4
32BuildRequires:  libjpeg-devel
33BuildRequires:  libpng-devel >= 1.2.5
34BuildRequires:  libxml2-devel
35BuildRequires:  openssl-devel
36#BuildRequires:  openjpeg-devel
37BuildRequires:  pulseaudio-libs-devel
38BuildRequires:  zlib-devel
39BuildRequires:  libogg-devel libvorbis-devel libtheora-devel
40BuildRequires:  libXt-devel
41BuildRequires:  libXpm-devel
42BuildRequires:  libXv-devel
43#BuildRequires:  wxGTK-devel
44%{?_with_mozilla:BuildRequires: gecko-devel}
45#BuildRequires:  doxygen
46BuildRequires:  desktop-file-utils
47%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
48# *-devel packages provided by other self-build-* should only be listed
49# in self-build-%{name}.spec as PreReq.
50#BuildRequires:  a52dec-devel
51#BuildRequires:  faad2-devel
52#BuildRequires:  libmad-devel
53#BuildRequires:  xvidcore-devel >= 1.0.0
54##BuildRequires:  ffmpeg-devel
55
56
57%description
58GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
59from scratch in ANSI C.  The original development goal is to provide a clean,
60small and flexible alternative to the MPEG-4 Systems reference software.
61
62GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
63X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
64MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
65for MP4 and 3GPP(2) files and many tools for scene descriptions
66(MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
67
68%package        libs
69Summary:        Library for %{name}
70Group:          System Environment/Libraries
71
72%description    libs
73The %{name}-libs package contains library for %{name}.
74
75
76%package  devel
77Summary:  Development libraries and files for %{name}
78Group:    Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81
82%description  devel
83Development libraries and files for gpac.
84
85
86%if %{with_static}
87%package  devel-static
88Summary:  Development libraries and files for %{name}
89Group:    Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91
92
93%description  devel-static
94Static library for gpac.
95%endif
96
97
98%prep
99%setup -q -n gpac
100## remove extra_libs directory
101%__rm -rf extra_libs
102
103%patch1 -p1 -b .libdir
104%patch2 -p1 -b .amr
105
106## kwizart - enable dynamic mode - hardcoded with patch2
107# define SONAME number from the first number of gpac version.
108#define soname libgpac.so.0
109#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
110
111# Fix encoding warnings
112%__cp -p Changelog Changelog.origine
113iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
114touch -r Changelog.origine Changelog
115%__rm -rf Changelog.origine
116
117%__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
118iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine >  doc/ipmpx_syntax.bt
119touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
120%__rm -rf doc/ipmpx_syntax.bt.origine
121
122
123# executable ./configure
124chmod +x configure
125
126%build
127%configure \
128    --X11-path=%{_prefix} \
129    --libdir=%{_lib} \
130    %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
131    --enable-pic \
132    --disable-static \
133    --disable-wx \
134    --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
135    --disable-oss-audio \
136    %{?_with_amr:--enable-amr} \
137    --use-js=no \
138    ;
139
140#Avoid mess with setup.h
141cp -p config.h include/gpac
142
143# Parallele build will fail
144%__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
145#{?_smp_mflags}
146%__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
147#{?_smp_mflags}
148
149# ## kwizart - build doxygen doc for devel
150# pushd doc
151# doxygen
152# popd
153
154%install
155%__rm -rf $RPM_BUILD_ROOT
156%__make DESTDIR=$RPM_BUILD_ROOT install install-lib
157
158#Install generated sggen binaries
159#MPEG4 SVG X3D
160for b in MPEG4 X3D; do
161  pushd applications/generators/${b}
162    %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
163  popd
164done
165
166# #Fix doxygen timestamp
167# touch -r Changelog doc/html/*
168
169#config.h like but not only
170#Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
171%__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
172touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
173touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
174touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
175%__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
176
177
178%clean
179%__rm -rf $RPM_BUILD_ROOT
180
181%post libs -p /sbin/ldconfig
182
183%postun libs -p /sbin/ldconfig
184
185
186%files
187%defattr(-,root,root,-)
188%doc AUTHORS BUGS Changelog COPYING README TODO
189%{_bindir}/MP4*
190%{_bindir}/*Gen
191%{_datadir}/gpac/
192%{_mandir}/man1/*.1.*
193
194%files libs
195%defattr(-,root,root)
196%{_libdir}/libgpac.so.*
197%{_libdir}/gpac/
198
199%files devel
200%doc doc/CODING_STYLE doc/ipmpx_syntax.bt
201%defattr(-,root,root)
202%{_includedir}/gpac/
203%{_libdir}/libgpac.so
204
205%if %{with_static}
206%files devel-static
207%defattr(-,root,root,-)
208%{_libdir}/libgpac_static.a
209%else
210%exclude %{_libdir}/libgpac_static.a
211%endif
212
213
214%changelog
215* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
216- remove BuildRequires: xmlrpc-epi-devel
217
218* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
219- added Obsoletes: %{name} < %{version} and so on.
220
221* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
222- rebuild
223
224* Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
225- new upstream release
226
227* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
228- rebuild
229
230* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
231- update snapshot svn20111217
232- removed upstreamed/obsolated patches
233
234* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
235- rebuilt with internal openjpeg
236  - added --use-openjpeg=local in configure options
237- added --enable-pic in configure options
238
239* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
240- rebuild
241
242* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
243- removed doxygen support
244
245* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
246- change release to sync with self-build-gpac
247
248* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
249- rebuild
250
251* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
252- added --use-js=no in configure
253- added devel-static subpackage
254
255* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
256- change release to sync with self-build-gpac
257
258* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
259- change release to sync with self-build-gpac
260
261* Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
262- applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
263- corrected default %%defattr
264
265* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
266- dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
267  - rebuilt with ffmpeg-devel by self-build-ffmpeg
268
269* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
270- initial build based on RPM Fusion
271  - without Osmo4 and its plugins for Mozilla browsers
272  - added --disable-wx in configure options
273  - included %%{_libdir}/libgpac_static.a in devel subpackage
274
275* Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
276- Fix -devel doc timestamp which leads to multilib conflict
277  ( RPM Fusion #270 )
278
279* Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
280- Fix for ppc64
281
282* Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
283- Update to 0.4.5 (final)
284- Drop upstreamed patches - Rewrite some
285- Add More BR.
286- Conditionalize --with mozilla amr
287
288* Mon Sep  8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
289- Fix for Large File Support (was livna #2075 )
290
291* Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
292- Enable devel-static
293- Conditionalize Osmo4 (buggy).
294- Clean the spec
295
296* Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
297- Update to 20080217.
298- Split libs.
299- Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
300- Add openjpeg-devel missing BR
301- Static patching instead of dyn patch when possible.
302- Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
303- Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
304- Exclude static lib
305
306* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
307- Use %%{smp_mflags}
308- Oops, we're actually 0.4.5
309- Fix gpac so filenames
310- Only install nposmozilla when %%{with_firefox} is set
311
312* Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
313- Update to 20080211cvs
314- Disable osmozilla, doesn't build with xulrunner
315- Fix builds with gcc 4.3
316
317* Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
318- Rebuild for rawhide
319
320* Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
321- Update to v4.4
322
323* Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
324- Update to cvs 20070526
325- Enable conditional build ( 3gpp firefox )
326
327* Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
328- Update to cvs 20070411
329
330* Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
331- Update to 20061208
332- Uses firefox-devel (since fc6!)
333- Drop tutorial
334- Use version-DEV-date with libgpac.so
335- Disabled osmozilla
336- Fix soname
337- Enabled gprof
338
339* Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
340- gpac snapshot.sh
341- Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
342- TODO: - no-soname make option for libgpac.so
343  - static lib in devel - needed ?
344  - osmozilla - xpt link problem.
345  - Osmo4: segmentation fault on exit.
346  - MP4Client: segmentation fault on launch.
347  - The program 'Osmo4' received an X Window System error:
348  "The error was 'BadMatch (invalid parameter attributes)'.
349  (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
350  - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
351
352* Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
353- Update to 0.4.2cvs20061017
354- Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
355- Enable mozilla plugin: osmozilla.
356- Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
357- Provide documentation html in doc .
358- Provide tutorial from http://www.wildamerica.com/pages/Marty.html
359- Various corrections.
360
361* Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
362- lib64 fixes
363
364* Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
365- initial package
Note: See TracBrowser for help on using the repository browser.