source: projects/specs/trunk/nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec @ 3143

Revision 3143, 5.3 KB checked in by munepi, 13 years ago (diff)

updated self-build-gstreamer-plugins-ffmpeg self-build-kino self-build-gstreamer-plugins-bad self-build-gstreamer-plugins-ugly self-build-ffmpeg2theora

Line 
1%define pkgname ffmpeg2theora
2%define name    self-build-%{pkgname}
3%define version 0.27
4%define release 1%{?_dist_release}
5
6%define sourceurl       http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source100:      ffmpeg2theora-0.27-ldflags.patch
15License:        GPL
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires(post):         scons
22Requires(post):         libogg-devel >= 1.1
23Requires(post):         libtheora-devel >= 1.1.0
24Requires(post):         libvorbis-devel
25Requires(post):         self-build-ffmpeg >= 0.6.1
26
27BuildArch:      noarch
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Packager:       munepi
31
32%description
33ffmpeg2theora is a tool to convert any file that ffmpeg can
34decode to theora.
35
36If you install this package, it automaticaly downloads source
37code ,compile it, and create rpm packages of %{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42
43[Note]
44This package requires many other packages to compile
45targetsoftware. So it consume more disk space than usual.
46Also installation takes logner time because of compilation.
47(This will take a few minutes to quarter or half of an hour,
48depends on building environment)
49
50[About self-build package]
51For some kind of software, distributing of binary package
52may viorate the patent or law. Therefore we chose self-build
53packge, create binary package on your machine, for such kind
54of softwares instead of distributing binary package.
55
56Please obey the national law when you use the created binary
57packages. And if you want to use the softwares using patented
58thechnology, it may be required to get a permission, make an
59agreement or purchas a license. Please consider it with your
60purpose or way of use and take appropriate action.
61
62%description -l ja
63ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
64に変換するツールです。
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
68パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73
74[注意]
75コンパイルに必要な多くの関連パッケージを要求するので通常より
76ディスクの領域を多く消費します。
77またインストール時にコンパイルを行うため、通常より時間がかか
78る場合があります。(環境にもよりますが数分から数十分程度)
79
80[self-build パッケージについて]
81ソフトウェアによってはバイナリパッケージの配布が特許や法律に
82違反する可能性があるものがあります。その為、このような問題が
83懸念されるソフトウェアについてはバイナリパッケージを直接配布
84せずに、ユーザの環境でバイナリを作成する self-build パッケー
85ジという方法を採っています。
86
87作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
88アのライセンス、および利用する国の各種法令に従ってください。
89また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
90センスの購入などが必要となる場合がありますので、利用する目的
91や形態に応じて各自で判断し適切な対応を取ってください。
92
93
94%prep
95[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
96
97
98%install
99%{__rm} -rf ${RPM_BUILD_ROOT}
100%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103
104
105%clean
106%{__rm} -rf ${RPM_BUILD_ROOT}
107
108%posttrans
109/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 11000
110#/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
111
112%files
113%defattr(-,root,root)
114%{_datadir}/%{name}
115
116%changelog
117* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
118- new upstream release
119- fixed the location of %%sourceurl
120
121* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
122- renamed %%{Source0} to ffmpeg2theora-vl.spec
123
124* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
125- new upstream release
126  - with recent ffmpeg
127
128* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
129- new upstream release
130
131* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
132- added BuildArch: noarch
133- avoided to execute self-build-rpm.sh on RPM transaction
134  - moved %%post actions to %%posttrans
135
136* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
137- new upstream release
138- dropped ffmpeg2theora-0.20-new_ffmpeg.patch
139- added PreReq: scons
140
141* Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
142- spec in utf8
143
144* Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
145- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.