source: projects/specs/trunk/nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec @ 5297

Revision 5297, 5.3 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%define pkgname ffmpeg2theora
2%define name    self-build-%{pkgname}
3%define version 0.28
4%define release 1%{?_dist_release}
5
6%define sourceurl       http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14License:        GPLv2+
15Group:          Restricted Software
16
17Requires(post):         self-build-setup >= 0.9.9
18
19# (build)requies of target package.
20Requires(post):         scons
21Requires(post):         libogg-devel >= 1.1
22Requires(post):         libtheora-devel >= 1.1.0
23Requires(post):         libvorbis-devel
24Requires(post):         self-build-ffmpeg >= 0.6.1
25
26BuildArch:      noarch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Packager:       munepi
30
31%description
32ffmpeg2theora is a tool to convert any file that ffmpeg can
33decode to theora.
34
35If you install this package, it automaticaly downloads source
36code ,compile it, and create rpm packages of %{pkgname}-%{version}.
37And the created rpm packages are automatically installed
38if installation is executed by apt-get command or synaptic
39package manager.
40
41
42[Note]
43This package requires many other packages to compile
44targetsoftware. So it consume more disk space than usual.
45Also installation takes logner time because of compilation.
46(This will take a few minutes to quarter or half of an hour,
47depends on building environment)
48
49[About self-build package]
50For some kind of software, distributing of binary package
51may viorate the patent or law. Therefore we chose self-build
52packge, create binary package on your machine, for such kind
53of softwares instead of distributing binary package.
54
55Please obey the national law when you use the created binary
56packages. And if you want to use the softwares using patented
57thechnology, it may be required to get a permission, make an
58agreement or purchas a license. Please consider it with your
59purpose or way of use and take appropriate action.
60
61%description -l ja
62ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
63に変換するツールです。
64
65このパッケージをインストールすると、自動的にソースコードを
66ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
67パッケージを作成します。
68また apt-get コマンドや synaptic パッケージマネージャから実行
69した場合は、作成された rpm パッケージのインストールも自動的に
70行います。
71
72
73[注意]
74コンパイルに必要な多くの関連パッケージを要求するので通常より
75ディスクの領域を多く消費します。
76またインストール時にコンパイルを行うため、通常より時間がかか
77る場合があります。(環境にもよりますが数分から数十分程度)
78
79[self-build パッケージについて]
80ソフトウェアによってはバイナリパッケージの配布が特許や法律に
81違反する可能性があるものがあります。その為、このような問題が
82懸念されるソフトウェアについてはバイナリパッケージを直接配布
83せずに、ユーザの環境でバイナリを作成する self-build パッケー
84ジという方法を採っています。
85
86作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
87アのライセンス、および利用する国の各種法令に従ってください。
88また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
89センスの購入などが必要となる場合がありますので、利用する目的
90や形態に応じて各自で判断し適切な対応を取ってください。
91
92
93%prep
94[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
95
96
97%install
98%{__rm} -rf ${RPM_BUILD_ROOT}
99%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%posttrans
107/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 11000
108#/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
109
110%files
111%defattr(-,root,root)
112%{_datadir}/%{name}
113
114%changelog
115* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
116- new upstream release
117- License: GPLv2+
118
119* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
120- new upstream release
121- fixed the location of %%sourceurl
122
123* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
124- renamed %%{Source0} to ffmpeg2theora-vl.spec
125
126* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
127- new upstream release
128  - with recent ffmpeg
129
130* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
131- new upstream release
132
133* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
134- added BuildArch: noarch
135- avoided to execute self-build-rpm.sh on RPM transaction
136  - moved %%post actions to %%posttrans
137
138* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
139- new upstream release
140- dropped ffmpeg2theora-0.20-new_ffmpeg.patch
141- added PreReq: scons
142
143* Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
144- spec in utf8
145
146* Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
147- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.