source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 5396

Revision 5396, 11.3 KB checked in by munepi, 12 years ago (diff)

updated self-build-ffmpeg: updated source to v0.9.1

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global version 0.9.1
10#% define svndate       20110326
11%global release 1%{?svndate:.%svndate}%{?_dist_release}
12
13%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
14
15## available for v0.6 or lower
16%global with_libfaad 1
17
18%global with_faac 1
19
20%global with_vaapi 1
21%global with_libvpx 1
22
23Summary:        Package to automatically build %{pkgname} rpm package
24Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
25Name:           %{name}
26Version:        %{version}
27Release:        %{release}
28Source0:        %{pkgname}-vl.spec
29#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
30Source2:        %{pkgname}-snapshot.sh
31# pre-built man files
32Source90:       ffmpeg-%{version}-doc.tar.xz
33
34License:        GPLv2+
35Group:          Restricted Software
36
37Requires(post):         self-build-setup >= 0.9.9
38#Requires(post):                subversion
39
40# (build)requies of target package.
41Requires(post):  bzip2-devel
42Requires(post):  celt-devel
43##Requires(post):  dirac-devel
44Requires(post):  freetype2-devel
45Requires(post): gsm-devel
46Requires(post): imlib2-devel
47Requires(post): libdc1394-devel
48Requires(post): libraw1394-devel
49Requires(post): librtmp-devel >= 2.3
50Requires(post): libtheora-devel
51%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
52Requires(post):  libvdpau-devel
53Requires(post): libvorbis-devel
54%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
55%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
56##Requires(post):  openjpeg-devel
57##Requires(post):  schroedinger-devel
58Requires(post): SDL-devel
59Requires(post):  speex-devel
60##Requires(post):       texi2html
61Requires(post): zlib-devel
62Requires(post): libogg-devel
63Requires(post):         yasm
64Requires(post):         self-build-a52dec
65Requires(post):         self-build-faac
66Requires(post):         self-build-faad2
67Requires(post):         self-build-lame
68Requires(post):         self-build-libdca
69Requires(post):         self-build-x264 >= 0.0.0-18.20111216
70Requires(post):         self-build-xvidcore
71
72BuildRoot:      %{_tmppath}/%{name}-%{version}-root
73
74BuildArch:      noarch
75Packager:       munepi
76
77%description
78FFMpeg is a complete and free Internet live audio and video
79broadcasting solution for Linux/Unix. It also includes a
80digital VCR. It can encode in real time in many formats
81including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
82real, mjpeg, and flash.
83
84If you install this package, it automaticaly downloads source
85code ,compile it, and create rpm packages of %{pkgname}-%{version}.
86And the created rpm packages are automatically installed
87if installation is executed by apt-get command or synaptic
88package manager.
89
90[Note]
91This package requires many other packages to compile
92target software. So it consume more disk space than usual.
93Also installation takes longer time because of compilation.
94(This will take a few minutes to quarter or half of an hour,
95depends on building environment)
96
97[About self-build package]
98For some kind of software, distributing of binary package
99may viorate the patent or law. Therefore we chose self-build
100packge, create binary package on your machine, for such kind
101of softwares instead of distributing binary package.
102
103Please obey the national law when you use the created binary
104packages. And if you want to use the softwares using patented
105thechnology, it may be required to get a permission, make an
106agreement or purchas a license. Please consider it with your
107purpose or way of use and take appropriate action.
108
109%description -l ja
110FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
111ブオーティオ・ビデオブロードキャスティングソリューションです.
112またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
113MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
114多様なフォーマットをリアルタイムにエンコードすることができます.
115
116このパッケージをインストールすると、自動的にソースコードを
117ダウンロードしてコンパイルし、%{pkgname}-%{version}
118の rpm パッケージを作成します。
119また apt-get コマンドや synaptic パッケージマネージャから実行
120した場合は、作成された rpm パッケージのインストールも自動的に
121行います。
122
123[注意]
124コンパイルに必要な多くの関連パッケージを要求するので通常より
125ディスクの領域を多く消費します。
126またインストール時にコンパイルを行うため、通常より時間がかか
127る場合があります。(環境にもよりますが数分から数十分程度)
128
129[self-build パッケージについて]
130ソフトウェアによってはバイナリパッケージの配布が特許や法律に
131違反する可能性があるものがあります。その為、このような問題が
132懸念されるソフトウェアについてはバイナリパッケージを直接配布
133せずに、ユーザの環境でバイナリを作成する self-build パッケー
134ジという方法を採っています。
135
136作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
137アのライセンス、および利用する国の各種法令に従ってください。
138また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
139センスの購入などが必要となる場合がありますので、利用する目的
140や形態に応じて各自で判断し適切な対応を取ってください。
141
142%prep
143[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
144
145%install
146%{__rm} -rf ${RPM_BUILD_ROOT}
147%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150
151%clean
152%{__rm} -rf ${RPM_BUILD_ROOT}
153
154%posttrans
155#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
156/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
157/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
158                                 %{pkgname}-libs-%{version}-%{release} \
159                                 %{pkgname}-devel-%{version}-%{release}
160
161## Rebuild gpac with ffmpeg-devel
162# set locale
163case $LANG in
164    ja*)LOCALE=ja ;;
165    *) LOCALE=C ;;
166esac
167
168Rebuild_gpac_C(){
169    echo -n "     "
170    echo "Rebuild gpac with ffmpeg-devel"
171}
172
173Rebuild_gpac_ja(){
174    echo -n "     "
175    echo "ffmpeg-devel で gpac をリビルドします。"
176}
177
178Rebuild_gpac_$LOCALE
179%{gpac_postinstall}
180
181
182%files
183%defattr(-,root,root)
184%{_datadir}/%{name}
185
186%changelog
187* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
188- new upstream release
189
190* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
191- new upstream release
192- enable CELT decoding via libcelt
193- enable FreeType support
194- drop faad2 support (dropped upstream)
195
196* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
197- added BuildArch: noarch
198
199* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
200- new upstream release
201
202* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
203- new upstream release
204
205* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
206- required latest x264 build
207- added BuildRequires: librtmp-devel >= 2.3
208
209* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
210- new upstream release
211
212* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
213- unpacked source archives
214
215* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
216- fixed some dependencies
217  - Requires(post): libva-devel
218  - Requires(post): libvpx-devel >= 0.9.1
219
220* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
221- new upstream release
222
223* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
224- bumped version to pre-0.6
225- updated source snapshot 20100410
226
227* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
228- fixed self-build log size
229
230* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
231- added ffprobe.1.gz
232
233* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
234- updated source snapshot 20100401
235
236* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
237- renamed %%{Source0} to ffmpeg-vl.spec
238
239* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
240- updated source snapshot 20100216
241  - rebuild with recent x264-devel
242- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
243- added BuildRequires:  libvdpau-devel
244
245* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
246- dropped BuildArch: noarch
247- added ffmpeg.1, ffplay.1, ffserver.1
248
249* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
250- avoided to execute self-build-rpm.sh on RPM transaction
251  - moved %%post actions to %%posttrans
252
253* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
254- added BuildArch: noarch
255- added ffmpeg-0.5-disable-texi2html.patch
256  - dropped PreReq: texi2html
257
258* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
259- added %%{gpac_postinstall} in %%post
260
261* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
262- corrected release number
263
264* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
265- new upstream release
266- added PreReq:
267  - speex-devel
268  - bzip2-devel
269
270* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
271- change release to sync with ffmpeg
272
273* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
274- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
275
276* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
277- 20090202 snapshot
278
279* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
280- 20090110 snapshot
281- dropped some patches
282
283* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
284- source updated (r15488)
285- fixed License: GPLv2+
286- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
287- added BuildRequires: yasm (only %%ix86)
288- applied ffmpeg-cpu.patch (merged from RPM Fusion)
289
290* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
291- spec in utf8
292
293* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
294- run pre-allocate-rpm.sh in %%post
295- set PreReq: self-build-setup >= 0.8
296- change release number
297
298* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
299- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
300  include Source1 in the binary package.
301- drop "Source100: ffmpeg-vine.patch".
302- drop "PreReq: subversion".
303
304* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
305- build with new versioning policy
306- change to use svn export from svn checkout on post install
307- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
308
309* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
310- For all pre-required package that is provied by self-build, 
311  changed to its self-build package
312 
313* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
314- initial build for Vine Linux 4.2
315- snapshot 2008/01/28 + some Rev.11662 2008/01/29
316
317### end of file
Note: See TracBrowser for help on using the repository browser.