source: projects/specs/trunk/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 5297

Revision 5297, 11.2 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%global gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%global pkgname ffmpeg
8%global name    self-build-%{pkgname}
9%global version 0.9
10#% define svndate       20110326
11%global release 1%{?svndate:.%svndate}%{?_dist_release}
12
13%global sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
14
15## available for v0.6 or lower
16%global with_libfaad 1
17
18%global with_faac 1
19
20%global with_vaapi 1
21%global with_libvpx 1
22
23Summary:        Package to automatically build %{pkgname} rpm package
24Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
25Name:           %{name}
26Version:        %{version}
27Release:        %{release}
28Source0:        %{pkgname}-vl.spec
29#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
30Source2:        %{pkgname}-snapshot.sh
31Source90:       ffmpeg-%{version}-doc.tar.xz
32
33License:        GPLv2+
34Group:          Restricted Software
35
36Requires(post):         self-build-setup >= 0.9.9
37#Requires(post):                subversion
38
39# (build)requies of target package.
40Requires(post):  bzip2-devel
41Requires(post):  celt-devel
42##Requires(post):  dirac-devel
43Requires(post):  freetype2-devel
44Requires(post): gsm-devel
45Requires(post): imlib2-devel
46Requires(post): libdc1394-devel
47Requires(post): libraw1394-devel
48Requires(post): librtmp-devel >= 2.3
49Requires(post): libtheora-devel
50%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
51Requires(post):  libvdpau-devel
52Requires(post): libvorbis-devel
53%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
54%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
55##Requires(post):  openjpeg-devel
56##Requires(post):  schroedinger-devel
57Requires(post): SDL-devel
58Requires(post):  speex-devel
59##Requires(post):       texi2html
60Requires(post): zlib-devel
61Requires(post): libogg-devel
62Requires(post):         yasm
63Requires(post):         self-build-a52dec
64Requires(post):         self-build-faac
65Requires(post):         self-build-faad2
66Requires(post):         self-build-lame
67Requires(post):         self-build-libdca
68Requires(post):         self-build-x264 >= 0.0.0-15.20110322
69Requires(post):         self-build-xvidcore
70
71BuildRoot:      %{_tmppath}/%{name}-%{version}-root
72
73BuildArch:      noarch
74Packager:       munepi
75
76%description
77FFMpeg is a complete and free Internet live audio and video
78broadcasting solution for Linux/Unix. It also includes a
79digital VCR. It can encode in real time in many formats
80including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
81real, mjpeg, and flash.
82
83If you install this package, it automaticaly downloads source
84code ,compile it, and create rpm packages of %{pkgname}-%{version}.
85And the created rpm packages are automatically installed
86if installation is executed by apt-get command or synaptic
87package manager.
88
89[Note]
90This package requires many other packages to compile
91target software. So it consume more disk space than usual.
92Also installation takes longer time because of compilation.
93(This will take a few minutes to quarter or half of an hour,
94depends on building environment)
95
96[About self-build package]
97For some kind of software, distributing of binary package
98may viorate the patent or law. Therefore we chose self-build
99packge, create binary package on your machine, for such kind
100of softwares instead of distributing binary package.
101
102Please obey the national law when you use the created binary
103packages. And if you want to use the softwares using patented
104thechnology, it may be required to get a permission, make an
105agreement or purchas a license. Please consider it with your
106purpose or way of use and take appropriate action.
107
108%description -l ja
109FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
110ブオーティオ・ビデオブロードキャスティングソリューションです.
111またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
112MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
113多様なフォーマットをリアルタイムにエンコードすることができます.
114
115このパッケージをインストールすると、自動的にソースコードを
116ダウンロードしてコンパイルし、%{pkgname}-%{version}
117の rpm パッケージを作成します。
118また apt-get コマンドや synaptic パッケージマネージャから実行
119した場合は、作成された rpm パッケージのインストールも自動的に
120行います。
121
122[注意]
123コンパイルに必要な多くの関連パッケージを要求するので通常より
124ディスクの領域を多く消費します。
125またインストール時にコンパイルを行うため、通常より時間がかか
126る場合があります。(環境にもよりますが数分から数十分程度)
127
128[self-build パッケージについて]
129ソフトウェアによってはバイナリパッケージの配布が特許や法律に
130違反する可能性があるものがあります。その為、このような問題が
131懸念されるソフトウェアについてはバイナリパッケージを直接配布
132せずに、ユーザの環境でバイナリを作成する self-build パッケー
133ジという方法を採っています。
134
135作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
136アのライセンス、および利用する国の各種法令に従ってください。
137また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
138センスの購入などが必要となる場合がありますので、利用する目的
139や形態に応じて各自で判断し適切な対応を取ってください。
140
141%prep
142[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
143
144%install
145%{__rm} -rf ${RPM_BUILD_ROOT}
146%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
147%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149
150%clean
151%{__rm} -rf ${RPM_BUILD_ROOT}
152
153%posttrans
154#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
155/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
156/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
157                                 %{pkgname}-libs-%{version}-%{release} \
158                                 %{pkgname}-devel-%{version}-%{release}
159
160## Rebuild gpac with ffmpeg-devel
161# set locale
162case $LANG in
163    ja*)LOCALE=ja ;;
164    *) LOCALE=C ;;
165esac
166
167Rebuild_gpac_C(){
168    echo -n "     "
169    echo "Rebuild gpac with ffmpeg-devel"
170}
171
172Rebuild_gpac_ja(){
173    echo -n "     "
174    echo "ffmpeg-devel で gpac をリビルドします。"
175}
176
177Rebuild_gpac_$LOCALE
178%{gpac_postinstall}
179
180
181%files
182%defattr(-,root,root)
183%{_datadir}/%{name}
184
185%changelog
186* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
187- new upstream release
188- enable CELT decoding via libcelt
189- enable FreeType support
190- drop faad2 support (dropped upstream)
191
192* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
193- added BuildArch: noarch
194
195* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
196- new upstream release
197
198* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
199- new upstream release
200
201* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
202- required latest x264 build
203- added BuildRequires: librtmp-devel >= 2.3
204
205* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
206- new upstream release
207
208* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
209- unpacked source archives
210
211* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
212- fixed some dependencies
213  - Requires(post): libva-devel
214  - Requires(post): libvpx-devel >= 0.9.1
215
216* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
217- new upstream release
218
219* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
220- bumped version to pre-0.6
221- updated source snapshot 20100410
222
223* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
224- fixed self-build log size
225
226* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
227- added ffprobe.1.gz
228
229* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
230- updated source snapshot 20100401
231
232* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
233- renamed %%{Source0} to ffmpeg-vl.spec
234
235* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
236- updated source snapshot 20100216
237  - rebuild with recent x264-devel
238- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
239- added BuildRequires:  libvdpau-devel
240
241* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
242- dropped BuildArch: noarch
243- added ffmpeg.1, ffplay.1, ffserver.1
244
245* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
246- avoided to execute self-build-rpm.sh on RPM transaction
247  - moved %%post actions to %%posttrans
248
249* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
250- added BuildArch: noarch
251- added ffmpeg-0.5-disable-texi2html.patch
252  - dropped PreReq: texi2html
253
254* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
255- added %%{gpac_postinstall} in %%post
256
257* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
258- corrected release number
259
260* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
261- new upstream release
262- added PreReq:
263  - speex-devel
264  - bzip2-devel
265
266* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
267- change release to sync with ffmpeg
268
269* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
270- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
271
272* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
273- 20090202 snapshot
274
275* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
276- 20090110 snapshot
277- dropped some patches
278
279* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
280- source updated (r15488)
281- fixed License: GPLv2+
282- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
283- added BuildRequires: yasm (only %%ix86)
284- applied ffmpeg-cpu.patch (merged from RPM Fusion)
285
286* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
287- spec in utf8
288
289* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
290- run pre-allocate-rpm.sh in %%post
291- set PreReq: self-build-setup >= 0.8
292- change release number
293
294* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
295- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
296  include Source1 in the binary package.
297- drop "Source100: ffmpeg-vine.patch".
298- drop "PreReq: subversion".
299
300* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
301- build with new versioning policy
302- change to use svn export from svn checkout on post install
303- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
304
305* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
306- For all pre-required package that is provied by self-build, 
307  changed to its self-build package
308 
309* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
310- initial build for Vine Linux 4.2
311- snapshot 2008/01/28 + some Rev.11662 2008/01/29
312
313### end of file
Note: See TracBrowser for help on using the repository browser.