source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 4991

Revision 4991, 10.4 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg

Line 
1#TODO: Build with openjpeg, opencore-amr
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5## available for v0.6 or lower
6%define with_libfaad 1
7
8%define with_faac 1
9
10%define with_vaapi 1
11%define with_libvpx 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.6.3
16Release:        3%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18Source1:        %{name}-snapshot.sh
19
20# pre-built man files
21Source90:       ffmpeg.1.gz
22Source91:       ffplay.1.gz
23Source92:       ffserver.1.gz
24Source93:       ffprobe.1.gz
25
26# CVE-2011-3362
27# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=91d5da9321c52e8197fb14046ebb335f3e6ff4a0;hp=08ddfb77a1aff378345026ba49fea9fb93ff1e70
28Patch1:         ffmpeg-0.6.3-CVE-2011-3362.patch
29# CVE-2011-3973, CVE-2011-3974
30# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=bd968d260aef322fb32e254a3de0d2036c57bd56;hp=00c5cf4beb0e45e936544a5766b56e241ae03234
31Patch2:         ffmpeg-0.6.3-CVE-2011-3974.patch
32
33License:        GPLv2+
34Group:          Applications/Multimedia
35URL:            http://ffmpeg.org/
36
37BuildRequires:  bzip2-devel
38##BuildRequires:  dirac-devel
39BuildRequires:  gsm-devel
40BuildRequires:  imlib2-devel
41BuildRequires:  libdc1394-devel
42BuildRequires:  libraw1394-devel
43BuildRequires:  librtmp-devel >= 2.3
44BuildRequires:  libtheora-devel
45%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
46BuildRequires:  libvdpau-devel
47BuildRequires:  libvorbis-devel
48%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
50##BuildRequires:  openjpeg-devel
51##BuildRequires:  schroedinger-devel
52BuildRequires:  SDL-devel
53BuildRequires:  speex-devel
54##BuildRequires:        texi2html
55BuildRequires:  zlib-devel
56BuildRequires:  libogg-devel
57BuildRequires:  yasm
58# *-devel packages provided by other self-build-* should only be listed
59# in self-build-%{name}.spec as PreReq.
60#BuildRequires: a52dec-devel
61#BuildRequires: faac-devel
62#BuildRequires: lame-devel
63#BuildRequires: libdca-devel
64#BuildRequires: faad2-devel
65#BuildRequires: x264-devel >= 0.0.0-15.20110322
66#BuildRequires: xvidcore-devel
67
68Requires:       %{name}-libs = %{version}-%{release}
69
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
72%description
73FFMpeg is a complete and free Internet live audio and video
74broadcasting solution for Linux/Unix. It also includes a digital
75VCR. It can encode in real time in many formats including MPEG1 audio
76and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
77
78%package libs
79Summary: Libraries for %{name}
80Group: System Environment/Libraries
81
82%description libs
83FFMpeg is a complete and free Internet live audio and video
84broadcasting solution for Linux/Unix. It also includes a digital
85VCR. It can encode in real time in many formats including MPEG1 audio
86and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
87
88This package contains the libraries for %{name}.
89
90%package devel
91Summary: Development package for %{name}
92Group: Development/Libraries
93Requires: %{name}-libs = %{version}-%{release}
94Requires: pkgconfig
95
96%description devel
97FFMpeg is a complete and free Internet live audio and video
98broadcasting solution for Linux/Unix. It also includes a digital
99VCR. It can encode in real time in many formats including MPEG1 audio
100and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
101
102This package contains development files for %{name}.
103
104
105%prep
106%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
107#% setup -q
108#%patch0 -p1 -b .textrel
109%patch1 -p1 -b .CVE-2011-3362
110%patch2 -p1 -b .CVE-2011-3974
111
112%build
113%ifarch ppc
114# compile with -mlongcall on ppc/ppc64 (rf804)
115export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
116%endif
117
118./configure \
119    --prefix=%{_prefix} \
120    --incdir=%{_includedir}/%{name} \
121    --shlibdir=%{_libdir} \
122    --libdir=%{_libdir} \
123    --mandir=%{_mandir} \
124    --arch=%{_target_cpu} \
125%ifarch %{ix86}
126    --cpu=%{_target_cpu} \
127%endif
128%ifarch ppc
129    --cpu=g3 \
130    --enable-pic \
131%endif
132    --enable-runtime-cpudetect \
133    --extra-cflags="$RPM_OPT_FLAGS" \
134    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
135    --enable-bzlib \
136    --enable-zlib \
137    --enable-libdc1394 \
138    %{?_with_libdirac:--enable-libdirac} \
139    %{?with_faac:--enable-libfaac --enable-nonfree} \
140    %{?with_libfaad:--enable-libfaad} \
141    --enable-libgsm \
142    --enable-libmp3lame \
143    %{?_with_openjpeg:--enable-libopenjpeg} \
144    --enable-librtmp \
145    --enable-libspeex \
146    --enable-libtheora \
147    --enable-libvorbis \
148    %{?with_libvpx:--enable-libvpx} \
149    --enable-libx264 \
150    --enable-libxvid \
151    \
152    --enable-x11grab \
153    --enable-avfilter \
154    --enable-postproc \
155    --enable-pthreads \
156    --disable-static \
157    --enable-shared \
158    --enable-gpl \
159    --disable-doc \
160    --disable-debug \
161    --disable-stripping \
162    ;
163
164%{__make} %{?_smp_mflags}
165#% {__make}
166#%{__make} documentation
167
168
169%install
170%__make install DESTDIR=$RPM_BUILD_ROOT
171
172# ## install tool/qt-faststart
173# %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
174
175## install man
176%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
177%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
178    $RPM_BUILD_ROOT%{_mandir}/man1/
179
180
181%clean
182%{__rm} -rf $RPM_BUILD_ROOT
183
184%post libs -p /sbin/ldconfig
185
186%postun libs -p /sbin/ldconfig
187
188%files
189%defattr(-,root,root,-)
190%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
191%{_bindir}/ffmpeg
192%{_bindir}/ffplay
193%{_bindir}/ffprobe
194%{_bindir}/ffserver
195#%{_bindir}/qt-faststart
196%{_mandir}/man1/ffmpeg.1*
197%{_mandir}/man1/ffplay.1*
198%{_mandir}/man1/ffprobe.1*
199%{_mandir}/man1/ffserver.1*
200%{_datadir}/ffmpeg
201
202
203%files libs
204%defattr(-,root,root,-)
205%{_libdir}/lib*.so.*
206
207%files devel
208%defattr(-,root,root,-)
209%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
210%{_includedir}/ffmpeg
211%{_libdir}/pkgconfig/lib*.pc
212%{_libdir}/lib*.so
213
214
215%changelog
216* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
217- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
218  from git.videolan.org
219
220* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
221- change release to sync with self-build-ffmpeg-vl.spec
222
223* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
224- new upstream release
225
226* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
227- new upstream release
228
229* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
230- required latest x264 build
231- added BuildRequires: librtmp-devel >= 2.3
232- build PIC objects on PPC
233#- add qt-faststart tool
234
235* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
236- new upstream release
237
238* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
239- change release to sync with self-build-ffmpeg-vl.spec
240
241* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
242- added BuildRequires: libvpx-devel >= 0.9.1
243
244* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
245- new upstream release
246
247* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
248- bumped version to pre-0.6
249
250* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
251- updated source snapshot 20100410
252
253* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
254- change release to sync with self-build-ffmpeg-vl.spec
255
256* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
257- change release to sync with self-build-ffmpeg-vl.spec
258
259* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
260- updated source snapshot 20100401
261
262* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
263- updated source snapshot 20100326
264
265* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
266- change release to sync with self-build-ffmpeg
267
268* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
269- updated source snapshot 20100216
270  - rebuild with recent x264-devel
271- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
272- added BuildRequires:  libvdpau-devel
273
274* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
275- change release to sync with self-build-ffmpeg
276
277* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
278- change release to sync with self-build-ffmpeg
279
280* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
281- applied ffmpeg-0.5-disable-texi2html.patch
282  - dropped BuildRequires: texi2html
283
284* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
285- change release to sync with self-build-ffmpeg
286
287* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
288- corrected release number
289
290* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
291- new upstream release
292- added BuildRequires:
293  - speex-devel
294  - bzip2-devel
295
296* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
297- 20090227 snapshot
298
299* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
300- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
301
302* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
303- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
304- dropped Requires: a52dec, faad2 in ffmpeg-libs
305
306* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
307- 20090202 snapshot
308
309* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
310- 20090110 snapshot
311- dropped some patches
312
313* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
314- source updated (r15488)
315- fixed License: GPLv2+
316- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
317- added BuildRequires: yasm (only %%ix86)
318- applied ffmpeg-cpu.patch (merged from RPM Fusion)
319
320* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
321- spec in utf8
322
323* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
324- change release to sync with self-build-ffmpeg
325
326* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
327- drop "Patch100: ffmpeg-vine.patch".
328
329* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
330- build with new versioning policy
331- change to use svn export from svn checkout on post install
332- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
333
334* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
335- [self-build-ffmpeg.spec]
336  For all pre-required package that is provied by self-build, 
337  changed to its self-build package
338
339* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
340- initial build for Vine Linux 4.2
341- snapshot 2008/01/28 + some Rev.11662 2008/01/29
342
343### end of file
Note: See TracBrowser for help on using the repository browser.