source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 10030

Revision 10030, 13.2 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%global with_faac       1
6%global with_vaapi      1
7%global with_libvpx     1
8
9%global major_version   2.8
10
11Summary:        Digital VCR and streaming server
12Name:           ffmpeg
13Version:        %{major_version}.6
14Release:        1%{?svndate:.%svndate}%{?_dist_release}
15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
16## prebuilt man pages
17
18%if 0%{?_with_amr:1}
19License:        GPLv3+
20%else
21License:        GPLv2+
22%endif
23Group:          Applications/Multimedia
24URL:            http://ffmpeg.org/
25
26BuildRequires:  bzip2-devel
27BuildRequires:  celt-devel
28##BuildRequires: dirac-devel
29BuildRequires:  freetype2-devel
30##BuildRequires: frei0r-devel
31BuildRequires:  gnutls-devel
32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
35BuildRequires:  libogg-devel
36BuildRequires:  libass-devel
37%{!?_without_cdio:BuildRequires: libcdio-devel}
38%{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
39#libcrystalhd is currently broken
40%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
41BuildRequires:  libraw1394-devel
42BuildRequires:  librtmp-devel >= 2.3
43BuildRequires:  libtheora-devel
44%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
45BuildRequires:  libvdpau-devel
46BuildRequires:  libvorbis-devel
47%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
48BuildRequires:  libXvMC-devel
49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
50%{!?_without_openal:BuildRequires: openal-soft-devel}
51%{?_with_opencv:BuildRequires: opencv-devel}
52%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
53##BuildRequires:  schroedinger-devel
54BuildRequires:  SDL-devel
55BuildRequires:  speex-devel
56##BuildRequires:        texi2html
57BuildRequires:  zlib-devel
58BuildRequires:  yasm
59# *-devel packages provided by other self-build-* should only be listed
60# in self-build-%{name}.spec as PreReq.
61#BuildRequires: a52dec-devel
62#BuildRequires: faac-devel
63#BuildRequires: lame-devel
64#BuildRequires: libdca-devel
65#BuildRequires: x264-devel >= 0.0.0-18.20111216
66#BuildRequires: xvidcore-devel
67
68Requires:       %{name}-libs = %{version}-%{release}
69
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
72Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
73
74%description
75FFMpeg is a complete and free Internet live audio and video
76broadcasting solution for Linux/Unix. It also includes a digital
77VCR. It can encode in real time in many formats including MPEG1 audio
78and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
79
80%package libs
81Summary: Libraries for %{name}
82Group: System Environment/Libraries
83
84%description libs
85FFMpeg is a complete and free Internet live audio and video
86broadcasting solution for Linux/Unix. It also includes a digital
87VCR. It can encode in real time in many formats including MPEG1 audio
88and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
89
90This package contains the libraries for %{name}.
91
92%package devel
93Summary: Development package for %{name}
94Group: Development/Libraries
95Requires: %{name}-libs = %{version}-%{release}
96Requires: pkgconfig
97
98%description devel
99FFMpeg is a complete and free Internet live audio and video
100broadcasting solution for Linux/Unix. It also includes a digital
101VCR. It can encode in real time in many formats including MPEG1 audio
102and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
103
104This package contains development files for %{name}.
105
106
107%prep
108%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
109
110%__sed -i "s/-O3 -g/$RPM_OPT_FLAGS/" configure
111
112%build
113%ifarch ppc
114# compile with -mlongcall on ppc/ppc64 (rf804)
115export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
116%endif
117
118./configure \
119    --prefix=%{_prefix} \
120    --incdir=%{_includedir}/%{name} \
121    --shlibdir=%{_libdir} \
122    --libdir=%{_libdir} \
123    --mandir=%{_mandir} \
124    --arch=%{_target_cpu} \
125%ifarch %{ix86}
126    --cpu=%{_target_cpu} \
127%endif
128%ifarch ppc
129    --cpu=g3 \
130    --enable-pic \
131%endif
132    --enable-runtime-cpudetect \
133    --extra-cflags="$RPM_OPT_FLAGS" \
134    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
135    --enable-bzlib \
136    %{!?_with_crystalhd:--disable-crystalhd} \
137    --enable-zlib \
138    %{?_with_frei0r:--enable-frei0r} \
139    --enable-gnutls \
140    --enable-libass \
141    %{!?_without_cdio:--enable-libcdio} \
142    --enable-libcelt \
143    --enable-libdc1394 \
144    %{?_with_libdirac:--enable-libdirac} \
145    %{?with_faac:--enable-libfaac --enable-nonfree} \
146    --enable-libfreetype \
147    --enable-libgsm \
148    --enable-libmp3lame \
149    %{!?_without_openal:--enable-openal} \
150    %{?_with_opencv:--enable-libopencv} \
151    %{?_with_openjpeg:--enable-libopenjpeg} \
152    --enable-librtmp \
153    --enable-libspeex \
154    --enable-libtheora \
155    --enable-libvorbis \
156    %{?with_libvpx:--enable-libvpx} \
157    --enable-libx264 \
158    --enable-libx265 \
159    --enable-libxvid \
160    \
161    --enable-x11grab \
162    --enable-avfilter \
163    --enable-postproc \
164    --enable-pthreads \
165    --disable-static \
166    --enable-shared \
167    --enable-gpl \
168    --disable-debug \
169    --disable-stripping \
170    \
171    --disable-doc --disable-htmlpages --disable-podpages --disable-txtpages \
172    %{?enable_avconv:--enable-avconv} \
173    ;
174
175%__make %{?_smp_mflags}
176
177%__make alltools
178
179
180%install
181%__make install DESTDIR=$RPM_BUILD_ROOT
182
183## install tool/qt-faststart
184%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
185
186# ## install man
187# %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
188# %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
189
190
191%clean
192%{__rm} -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195
196%postun libs -p /sbin/ldconfig
197
198%files
199%defattr(-,root,root,-)
200%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
201%{?enable_avconv:%{_bindir}/avconv}
202%{_bindir}/ffmpeg
203%{_bindir}/ffplay
204%{_bindir}/ffprobe
205%{_bindir}/ffserver
206%{_bindir}/qt-faststart
207%{?enable_avconv:%{_mandir}/man1/avconv.1*}
208# %{_mandir}/man1/ffmpeg*.1*
209# %{_mandir}/man1/ffplay*.1*
210# %{_mandir}/man1/ffprobe*.1*
211# %{_mandir}/man1/ffserver*.1*
212%{_datadir}/ffmpeg
213
214
215%files libs
216%defattr(-,root,root,-)
217%{_libdir}/lib*.so.*
218# %{_mandir}/man3/lib*.3.gz
219
220%files devel
221%defattr(-,root,root,-)
222%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
223%{_includedir}/ffmpeg
224%{_libdir}/pkgconfig/lib*.pc
225%{_libdir}/lib*.so
226
227
228%changelog
229* Mon Feb 15 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.6-1
230- new upstream release
231
232* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
233- new upstream release
234
235* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
236- rebuild with gnutls-3.4.7
237
238* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
239- new upstream release
240
241* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
242- new upstream release
243
244* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
245- new upstream release
246
247* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
248- new upstream release
249
250* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
251- new upstream release
252
253* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
254- new upstream release
255
256* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
257- new upstream release
258
259* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
260- new upstream release
261
262* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
263- add BuildRequires: libcdio-paranoia-devel
264
265* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
266- new upstream release
267
268* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
269- new upstream release
270
271* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
272- new upstream release
273
274* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
275- new upstream release
276- added man pages
277  - added Source10: ffmpeg-1.2.1-doc.tar.xz
278
279* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
280- new upstream release
281
282* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
283- new upstream release
284
285* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
286- libvpx >= 0.9.7
287
288* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
289- new upstream release /x264-0.129
290
291* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
292- new upstream release
293
294* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
295- new upstream release
296
297* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
298- new upstream release
299
300* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
301- new upstream release
302
303* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
304- new upstream release
305
306* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
307- new upstream release
308- enable CELT decoding via libcelt
309- enable FreeType support
310- drop faad2 support (dropped upstream)
311
312* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
313- change release to sync with self-build-ffmpeg-vl.spec
314
315* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
316- new upstream release
317
318* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
319- new upstream release
320
321* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
322- required latest x264 build
323- added BuildRequires: librtmp-devel >= 2.3
324- build PIC objects on PPC
325#- add qt-faststart tool
326
327* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
328- new upstream release
329
330* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
331- change release to sync with self-build-ffmpeg-vl.spec
332
333* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
334- added BuildRequires: libvpx-devel >= 0.9.1
335
336* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
337- new upstream release
338
339* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
340- bumped version to pre-0.6
341
342* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
343- updated source snapshot 20100410
344
345* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
346- change release to sync with self-build-ffmpeg-vl.spec
347
348* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
349- change release to sync with self-build-ffmpeg-vl.spec
350
351* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
352- updated source snapshot 20100401
353
354* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
355- updated source snapshot 20100326
356
357* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
358- change release to sync with self-build-ffmpeg
359
360* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
361- updated source snapshot 20100216
362  - rebuild with recent x264-devel
363- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
364- added BuildRequires:  libvdpau-devel
365
366* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
367- change release to sync with self-build-ffmpeg
368
369* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
370- change release to sync with self-build-ffmpeg
371
372* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
373- applied ffmpeg-0.5-disable-texi2html.patch
374  - dropped BuildRequires: texi2html
375
376* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
377- change release to sync with self-build-ffmpeg
378
379* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
380- corrected release number
381
382* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
383- new upstream release
384- added BuildRequires:
385  - speex-devel
386  - bzip2-devel
387
388* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
389- 20090227 snapshot
390
391* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
392- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
393
394* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
395- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
396- dropped Requires: a52dec, faad2 in ffmpeg-libs
397
398* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
399- 20090202 snapshot
400
401* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
402- 20090110 snapshot
403- dropped some patches
404
405* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
406- source updated (r15488)
407- fixed License: GPLv2+
408- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
409- added BuildRequires: yasm (only %%ix86)
410- applied ffmpeg-cpu.patch (merged from RPM Fusion)
411
412* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
413- spec in utf8
414
415* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
416- change release to sync with self-build-ffmpeg
417
418* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
419- drop "Patch100: ffmpeg-vine.patch".
420
421* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
422- build with new versioning policy
423- change to use svn export from svn checkout on post install
424- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
425
426* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
427- [self-build-ffmpeg.spec]
428  For all pre-required package that is provied by self-build, 
429  changed to its self-build package
430
431* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
432- initial build for Vine Linux 4.2
433- snapshot 2008/01/28 + some Rev.11662 2008/01/29
434
435### end of file
Note: See TracBrowser for help on using the repository browser.