source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 9973

Revision 9973, 13.1 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%global with_faac       1
6%global with_vaapi      1
7%global with_libvpx     1
8
9%global major_version   2.8
10
11Summary:        Digital VCR and streaming server
12Name:           ffmpeg
13Version:        %{major_version}.5
14Release:        1%{?svndate:.%svndate}%{?_dist_release}
15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
16## prebuilt man pages
17
18%if 0%{?_with_amr:1}
19License:        GPLv3+
20%else
21License:        GPLv2+
22%endif
23Group:          Applications/Multimedia
24URL:            http://ffmpeg.org/
25
26BuildRequires:  bzip2-devel
27BuildRequires:  celt-devel
28##BuildRequires: dirac-devel
29BuildRequires:  freetype2-devel
30##BuildRequires: frei0r-devel
31BuildRequires:  gnutls-devel
32BuildRequires:  gsm-devel
33BuildRequires:  imlib2-devel
34BuildRequires:  libdc1394-devel
35BuildRequires:  libogg-devel
36BuildRequires:  libass-devel
37%{!?_without_cdio:BuildRequires: libcdio-devel}
38%{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
39#libcrystalhd is currently broken
40%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
41BuildRequires:  libraw1394-devel
42BuildRequires:  librtmp-devel >= 2.3
43BuildRequires:  libtheora-devel
44%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
45BuildRequires:  libvdpau-devel
46BuildRequires:  libvorbis-devel
47%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
48BuildRequires:  libXvMC-devel
49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
50%{!?_without_openal:BuildRequires: openal-soft-devel}
51%{?_with_opencv:BuildRequires: opencv-devel}
52%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
53##BuildRequires:  schroedinger-devel
54BuildRequires:  SDL-devel
55BuildRequires:  speex-devel
56##BuildRequires:        texi2html
57BuildRequires:  zlib-devel
58BuildRequires:  yasm
59# *-devel packages provided by other self-build-* should only be listed
60# in self-build-%{name}.spec as PreReq.
61#BuildRequires: a52dec-devel
62#BuildRequires: faac-devel
63#BuildRequires: lame-devel
64#BuildRequires: libdca-devel
65#BuildRequires: x264-devel >= 0.0.0-18.20111216
66#BuildRequires: xvidcore-devel
67
68Requires:       %{name}-libs = %{version}-%{release}
69
70BuildRoot:      %{_tmppath}/%{name}-%{version}-root
71
72Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
73
74%description
75FFMpeg is a complete and free Internet live audio and video
76broadcasting solution for Linux/Unix. It also includes a digital
77VCR. It can encode in real time in many formats including MPEG1 audio
78and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
79
80%package libs
81Summary: Libraries for %{name}
82Group: System Environment/Libraries
83
84%description libs
85FFMpeg is a complete and free Internet live audio and video
86broadcasting solution for Linux/Unix. It also includes a digital
87VCR. It can encode in real time in many formats including MPEG1 audio
88and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
89
90This package contains the libraries for %{name}.
91
92%package devel
93Summary: Development package for %{name}
94Group: Development/Libraries
95Requires: %{name}-libs = %{version}-%{release}
96Requires: pkgconfig
97
98%description devel
99FFMpeg is a complete and free Internet live audio and video
100broadcasting solution for Linux/Unix. It also includes a digital
101VCR. It can encode in real time in many formats including MPEG1 audio
102and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
103
104This package contains development files for %{name}.
105
106
107%prep
108%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
109
110%__sed -i "s/-O3 -g/$RPM_OPT_FLAGS/" configure
111
112%build
113%ifarch ppc
114# compile with -mlongcall on ppc/ppc64 (rf804)
115export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
116%endif
117
118./configure \
119    --prefix=%{_prefix} \
120    --incdir=%{_includedir}/%{name} \
121    --shlibdir=%{_libdir} \
122    --libdir=%{_libdir} \
123    --mandir=%{_mandir} \
124    --arch=%{_target_cpu} \
125%ifarch %{ix86}
126    --cpu=%{_target_cpu} \
127%endif
128%ifarch ppc
129    --cpu=g3 \
130    --enable-pic \
131%endif
132    --enable-runtime-cpudetect \
133    --extra-cflags="$RPM_OPT_FLAGS" \
134    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
135    --enable-bzlib \
136    %{!?_with_crystalhd:--disable-crystalhd} \
137    --enable-zlib \
138    %{?_with_frei0r:--enable-frei0r} \
139    --enable-gnutls \
140    --enable-libass \
141    %{!?_without_cdio:--enable-libcdio} \
142    --enable-libcelt \
143    --enable-libdc1394 \
144    %{?_with_libdirac:--enable-libdirac} \
145    %{?with_faac:--enable-libfaac --enable-nonfree} \
146    --enable-libfreetype \
147    --enable-libgsm \
148    --enable-libmp3lame \
149    %{!?_without_openal:--enable-openal} \
150    %{?_with_opencv:--enable-libopencv} \
151    %{?_with_openjpeg:--enable-libopenjpeg} \
152    --enable-librtmp \
153    --enable-libspeex \
154    --enable-libtheora \
155    --enable-libvorbis \
156    %{?with_libvpx:--enable-libvpx} \
157    --enable-libx264 \
158    --enable-libx265 \
159    --enable-libxvid \
160    \
161    --enable-x11grab \
162    --enable-avfilter \
163    --enable-postproc \
164    --enable-pthreads \
165    --disable-static \
166    --enable-shared \
167    --enable-gpl \
168    --disable-debug \
169    --disable-stripping \
170    \
171    --disable-doc --disable-htmlpages --disable-podpages --disable-txtpages \
172    %{?enable_avconv:--enable-avconv} \
173    ;
174
175%__make %{?_smp_mflags}
176
177%__make alltools
178
179
180%install
181%__make install DESTDIR=$RPM_BUILD_ROOT
182
183## install tool/qt-faststart
184%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
185
186# ## install man
187# %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
188# %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
189
190
191%clean
192%{__rm} -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195
196%postun libs -p /sbin/ldconfig
197
198%files
199%defattr(-,root,root,-)
200%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
201%{?enable_avconv:%{_bindir}/avconv}
202%{_bindir}/ffmpeg
203%{_bindir}/ffplay
204%{_bindir}/ffprobe
205%{_bindir}/ffserver
206%{_bindir}/qt-faststart
207%{?enable_avconv:%{_mandir}/man1/avconv.1*}
208# %{_mandir}/man1/ffmpeg*.1*
209# %{_mandir}/man1/ffplay*.1*
210# %{_mandir}/man1/ffprobe*.1*
211# %{_mandir}/man1/ffserver*.1*
212%{_datadir}/ffmpeg
213
214
215%files libs
216%defattr(-,root,root,-)
217%{_libdir}/lib*.so.*
218# %{_mandir}/man3/lib*.3.gz
219
220%files devel
221%defattr(-,root,root,-)
222%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
223%{_includedir}/ffmpeg
224%{_libdir}/pkgconfig/lib*.pc
225%{_libdir}/lib*.so
226
227
228%changelog
229* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
230- new upstream release
231
232* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
233- rebuild with gnutls-3.4.7
234
235* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
236- new upstream release
237
238* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
239- new upstream release
240
241* Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
242- new upstream release
243
244* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
245- new upstream release
246
247* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
248- new upstream release
249
250* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
251- new upstream release
252
253* Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
254- new upstream release
255
256* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
257- new upstream release
258
259* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
260- add BuildRequires: libcdio-paranoia-devel
261
262* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
263- new upstream release
264
265* Fri Oct  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
266- new upstream release
267
268* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
269- new upstream release
270
271* Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
272- new upstream release
273- added man pages
274  - added Source10: ffmpeg-1.2.1-doc.tar.xz
275
276* Thu Apr  4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
277- new upstream release
278
279* Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
280- new upstream release
281
282* Sun Feb  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
283- libvpx >= 0.9.7
284
285* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
286- new upstream release /x264-0.129
287
288* Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
289- new upstream release
290
291* Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
292- new upstream release
293
294* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
295- new upstream release
296
297* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
298- new upstream release
299
300* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
301- new upstream release
302
303* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
304- new upstream release
305- enable CELT decoding via libcelt
306- enable FreeType support
307- drop faad2 support (dropped upstream)
308
309* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
310- change release to sync with self-build-ffmpeg-vl.spec
311
312* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
313- new upstream release
314
315* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
316- new upstream release
317
318* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
319- required latest x264 build
320- added BuildRequires: librtmp-devel >= 2.3
321- build PIC objects on PPC
322#- add qt-faststart tool
323
324* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
325- new upstream release
326
327* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
328- change release to sync with self-build-ffmpeg-vl.spec
329
330* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
331- added BuildRequires: libvpx-devel >= 0.9.1
332
333* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
334- new upstream release
335
336* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
337- bumped version to pre-0.6
338
339* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
340- updated source snapshot 20100410
341
342* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
343- change release to sync with self-build-ffmpeg-vl.spec
344
345* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
346- change release to sync with self-build-ffmpeg-vl.spec
347
348* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
349- updated source snapshot 20100401
350
351* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
352- updated source snapshot 20100326
353
354* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
355- change release to sync with self-build-ffmpeg
356
357* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
358- updated source snapshot 20100216
359  - rebuild with recent x264-devel
360- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
361- added BuildRequires:  libvdpau-devel
362
363* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
364- change release to sync with self-build-ffmpeg
365
366* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
367- change release to sync with self-build-ffmpeg
368
369* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
370- applied ffmpeg-0.5-disable-texi2html.patch
371  - dropped BuildRequires: texi2html
372
373* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
374- change release to sync with self-build-ffmpeg
375
376* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
377- corrected release number
378
379* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
380- new upstream release
381- added BuildRequires:
382  - speex-devel
383  - bzip2-devel
384
385* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
386- 20090227 snapshot
387
388* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
389- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
390
391* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
392- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
393- dropped Requires: a52dec, faad2 in ffmpeg-libs
394
395* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
396- 20090202 snapshot
397
398* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
399- 20090110 snapshot
400- dropped some patches
401
402* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
403- source updated (r15488)
404- fixed License: GPLv2+
405- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
406- added BuildRequires: yasm (only %%ix86)
407- applied ffmpeg-cpu.patch (merged from RPM Fusion)
408
409* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
410- spec in utf8
411
412* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
413- change release to sync with self-build-ffmpeg
414
415* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
416- drop "Patch100: ffmpeg-vine.patch".
417
418* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
419- build with new versioning policy
420- change to use svn export from svn checkout on post install
421- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
422
423* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
424- [self-build-ffmpeg.spec]
425  For all pre-required package that is provied by self-build, 
426  changed to its self-build package
427
428* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
429- initial build for Vine Linux 4.2
430- snapshot 2008/01/28 + some Rev.11662 2008/01/29
431
432### end of file
Note: See TracBrowser for help on using the repository browser.