source: projects/specs/trunk/nonfree/self-build-faac/self-build-faac-vl.spec @ 5085

Revision 5085, 7.2 KB checked in by munepi, 13 years ago (diff)

libdvdnav, libmp4v2: changed to plus category; updated libdvdnav, libdvdread: new upstream release

Line 
1%define pkgname faac
2%define name    self-build-%{pkgname}
3%define version 1.28
4%define release 8%{?_dist_release}
5
6%define enable_libmp4v2_external 1
7
8%define sourceurl0      http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source10:       http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
17Source11:       mp4v2-strcasestr-vine.diff
18
19License:        LGPLv2+
20Group:          Restricted Software
21
22Requires(post):         self-build-setup >= 0.9.9
23
24# (build)requies of target package.
25Requires(post):         nkf
26Requires(post):         autoconf, automake, libtool, gcc-c++
27%if %{enable_libmp4v2_external}
28Requires(post):         libmp4v2-devel
29%endif
30
31BuildArch:      noarch
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34Packager:       munepi
35
36%description
37FAAC is an AAC audio encoder. It currently supports MPEG-4
38LTP, MAIN and LOW COMPLEXITY object types and MAIN and LOW
39MPEG-2 object types. It also supports multichannel and
40gapless encoding.
41
42%if !%{enable_libmp4v2_external}
43The libmp4v2 library provides an abstraction layer for
44working with files using the mp4 container format. This
45library is developed by mpeg4ip project and is an exact copy
46of the library distributed in the mpeg4ip package.
47%endif
48
49If you install this package, it automatically downloads
50source code, compile it, and create
51rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
52And the created rpm packages are automatically installed
53if installation is executed by apt-get command or synaptic
54package manager.
55
56[Note]
57This package requires many other packages to compile
58targetsoftware. So it consume more disk space than usual.
59Also installation takes logner time because of compilation.
60(This will take a few minutes to quarter or half of an hour,
61depends on building environment)
62
63[About self-build package]
64For some kind of software, distributing of binary package
65may viorate the patent or law. Therefore we chose self-build
66packge, create binary package on your machine, for such kind
67of softwares instead of distributing binary package.
68
69Please obey the national law when you use the created binary
70packages. And if you want to use the softwares using patented
71thechnology, it may be required to get a permission, make an
72agreement or purchas a license. Please consider it with your
73purpose or way of use and take appropriate action.
74
75%description -l ja
76FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP,
77Main/Low Complexity object types, Main/LOW MPEG-2 object
78types をサポートしています.またマルチチャンネルやギャップ
79レスエンコーディングもサポートしています.
80
81%if !%{enable_libmp4v2_external}
82libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
83ルで動作するものに対して抽象レイヤーを提供します.このライブ
84ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
85ケージに分散されているライブラリの完全なコピーです.
86%endif
87
88このパッケージをインストールすると、自動的にソースコードを
89ダウンロードしてコンパイルし、%{pkgname}-%{version}
90と libmp4v2-%{version} の rpm パッケージを作成します。
91また apt-get コマンドや synaptic パッケージマネージャから実行
92した場合は、作成された rpm パッケージのインストールも自動的に
93行います。
94
95[注意]
96コンパイルに必要な多くの関連パッケージを要求するので通常より
97ディスクの領域を多く消費します。
98またインストール時にコンパイルを行うため、通常より時間がかか
99る場合があります。(環境にもよりますが数分から数十分程度)
100
101[self-build パッケージについて]
102ソフトウェアによってはバイナリパッケージの配布が特許や法律に
103違反する可能性があるものがあります。その為、このような問題が
104懸念されるソフトウェアについてはバイナリパッケージを直接配布
105せずに、ユーザの環境でバイナリを作成する self-build パッケー
106ジという方法を採っています。
107
108作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
109アのライセンス、および利用する国の各種法令に従ってください。
110また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
111センスの購入などが必要となる場合がありますので、利用する目的
112や形態に応じて各自で判断し適切な対応を取ってください。
113
114
115%prep
116[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
117
118%install
119%{__rm} -rf ${RPM_BUILD_ROOT}
120%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
123%{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
124
125%clean
126%{__rm} -rf ${RPM_BUILD_ROOT}
127
128%posttrans
129/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 25000
130/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
131                                 %{pkgname}-devel-%{version}-%{release}
132
133%files
134%defattr(-,root,root)
135%{_datadir}/%{name}
136
137%changelog
138* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
139- s/self-build-libmp4v2/libmp4v2/
140
141* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
142- renamed %%{Source0} to faac-vl.spec
143
144* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
145- applied mp4v2-strcasestr.diff from lauchpad
146  - fixed wrong declaration of strcasestr() in mpeg4ip.h
147
148* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
149- rebuilt with mp4v2 v1.9.1
150  - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
151
152* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
153- applied a progress bar to show approximately building time
154
155* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
156- added Requires(post): nkf
157
158* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
159- added BuildArch: noarch
160- avoided to execute self-build-rpm.sh on RPM transaction
161  - moved %%post actions to %%posttrans
162
163* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
164- new upstream release
165
166* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
167- fixed Summary: , %%description
168  - removed internal mp4v2
169
170* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
171- new upstream release
172- added PreReq: self-build-libmp4v2
173
174* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
175- spec in utf8
176- remove *.la
177
178* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
179- run pre-allocate-rpm.sh in %%post
180- set PreReq: self-build-setup >= 0.8
181- apply new versioning policy
182
183* Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
184- initial build
185
186### end of file
Note: See TracBrowser for help on using the repository browser.