source: projects/specs/trunk/nonfree/self-build-faac/self-build-faac-vl.spec @ 9440

Revision 9440, 7.4 KB checked in by inagaki, 9 years ago (diff)

2015-03-19 Ryoichi INAGAKI <ryo1@…>

  • self-build-faac: added patch
  • self-build-gstreamer1-plugins-bad: changed Group


Line 
1%define pkgname faac
2%define name    self-build-%{pkgname}
3%define version 1.28
4%define release 9%{?_dist_release}
5
6%define enable_libmp4v2_external 1
7
8%define sourceurl0      http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source10:       http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
17Source11:       mp4v2-strcasestr-vine.diff
18Source12:       mp4v2-2.0.0.patch
19
20License:        LGPLv2+
21Group:          Restricted Software
22
23Requires(post):         self-build-setup >= 0.9.9
24
25# (build)requies of target package.
26Requires(post):         nkf
27Requires(post):         autoconf, automake, libtool, gcc-c++
28%if %{enable_libmp4v2_external}
29Requires(post):         libmp4v2-devel
30%endif
31
32BuildArch:      noarch
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Packager:       munepi
36
37%description
38FAAC is an AAC audio encoder. It currently supports MPEG-4
39LTP, MAIN and LOW COMPLEXITY object types and MAIN and LOW
40MPEG-2 object types. It also supports multichannel and
41gapless encoding.
42
43%if !%{enable_libmp4v2_external}
44The libmp4v2 library provides an abstraction layer for
45working with files using the mp4 container format. This
46library is developed by mpeg4ip project and is an exact copy
47of the library distributed in the mpeg4ip package.
48%endif
49
50If you install this package, it automatically downloads
51source code, compile it, and create
52rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
53And the created rpm packages are automatically installed
54if installation is executed by apt-get command or synaptic
55package manager.
56
57[Note]
58This package requires many other packages to compile
59targetsoftware. So it consume more disk space than usual.
60Also installation takes logner time because of compilation.
61(This will take a few minutes to quarter or half of an hour,
62depends on building environment)
63
64[About self-build package]
65For some kind of software, distributing of binary package
66may viorate the patent or law. Therefore we chose self-build
67packge, create binary package on your machine, for such kind
68of softwares instead of distributing binary package.
69
70Please obey the national law when you use the created binary
71packages. And if you want to use the softwares using patented
72thechnology, it may be required to get a permission, make an
73agreement or purchas a license. Please consider it with your
74purpose or way of use and take appropriate action.
75
76%description -l ja
77FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP,
78Main/Low Complexity object types, Main/LOW MPEG-2 object
79types をサポートしています.またマルチチャンネルやギャップ
80レスエンコーディングもサポートしています.
81
82%if !%{enable_libmp4v2_external}
83libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
84ルで動作するものに対して抽象レイヤーを提供します.このライブ
85ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
86ケージに分散されているライブラリの完全なコピーです.
87%endif
88
89このパッケージをインストールすると、自動的にソースコードを
90ダウンロードしてコンパイルし、%{pkgname}-%{version}
91と libmp4v2-%{version} の rpm パッケージを作成します。
92また apt-get コマンドや synaptic パッケージマネージャから実行
93した場合は、作成された rpm パッケージのインストールも自動的に
94行います。
95
96[注意]
97コンパイルに必要な多くの関連パッケージを要求するので通常より
98ディスクの領域を多く消費します。
99またインストール時にコンパイルを行うため、通常より時間がかか
100る場合があります。(環境にもよりますが数分から数十分程度)
101
102[self-build パッケージについて]
103ソフトウェアによってはバイナリパッケージの配布が特許や法律に
104違反する可能性があるものがあります。その為、このような問題が
105懸念されるソフトウェアについてはバイナリパッケージを直接配布
106せずに、ユーザの環境でバイナリを作成する self-build パッケー
107ジという方法を採っています。
108
109作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
110アのライセンス、および利用する国の各種法令に従ってください。
111また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
112センスの購入などが必要となる場合がありますので、利用する目的
113や形態に応じて各自で判断し適切な対応を取ってください。
114
115
116%prep
117[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
118
119%install
120%{__rm} -rf ${RPM_BUILD_ROOT}
121%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
123%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
124%{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
125%{__install} -m 644 %{SOURCE12} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
126
127%clean
128%{__rm} -rf ${RPM_BUILD_ROOT}
129
130%posttrans
131/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 25000
132/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
133                                 %{pkgname}-devel-%{version}-%{release}
134
135%files
136%defattr(-,root,root)
137%{_datadir}/%{name}
138
139%changelog
140* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-9
141- added Source12 for building with libmp4v2 2.0.0
142
143* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
144- s/self-build-libmp4v2/libmp4v2/
145
146* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
147- renamed %%{Source0} to faac-vl.spec
148
149* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
150- applied mp4v2-strcasestr.diff from lauchpad
151  - fixed wrong declaration of strcasestr() in mpeg4ip.h
152
153* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
154- rebuilt with mp4v2 v1.9.1
155  - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
156
157* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
158- applied a progress bar to show approximately building time
159
160* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
161- added Requires(post): nkf
162
163* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
164- added BuildArch: noarch
165- avoided to execute self-build-rpm.sh on RPM transaction
166  - moved %%post actions to %%posttrans
167
168* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
169- new upstream release
170
171* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
172- fixed Summary: , %%description
173  - removed internal mp4v2
174
175* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
176- new upstream release
177- added PreReq: self-build-libmp4v2
178
179* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
180- spec in utf8
181- remove *.la
182
183* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
184- run pre-allocate-rpm.sh in %%post
185- set PreReq: self-build-setup >= 0.8
186- apply new versioning policy
187
188* Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
189- initial build
190
191### end of file
Note: See TracBrowser for help on using the repository browser.