source: projects/specs/trunk/nonfree/self-build-chromium-ffmpeg/chromium-ffmpeg-vl.spec @ 5627

Revision 5627, 1.9 KB checked in by munepi, 12 years ago (diff)

added self-build-chromium-ffmpeg

Line 
1Name:           chromium-ffmpeg
2Summary:        The ffmpeg lib for Google's opens source browser Chromium
3Summary(ja):    Google オープンソースブラウザ Chromium 用 ffmpeg ライブラリ
4Version:        17.0.963.54
5Release:        1%{?_dist_release}
6License:        BSD
7Group:          Applications/Internet
8# use the official tarball:
9Source0:        http://gsdview.appspot.com/chromium-browser-official/chromium-%{version}.tar.bz2
10
11BuildRequires:  zlib-devel
12Requires:       chromium
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16%description
17FFMPEG library built from the chromium sources.
18
19%prep
20%setup -q -c %{name}-%{version}
21
22%build
23
24## create make files
25pushd chromium-%{version}
26
27##NOTE: Use --depth as a workaround
28./build/gyp_chromium -f make third_party/ffmpeg/ffmpeg.gyp \
29    -Dffmpeg_branding=Chrome \
30    -Dlinux_fpic=1 \
31    %ifarch %{ix86}
32        -Dtarget_arch=ia32 \
33    %endif
34    %ifarch x86_64
35        -Ddisable_sse2=1 \
36        -Dtarget_arch=x64 \
37    %endif
38    %if %{?_dist_release} == "vl6"
39        -Dgcc_version=44 \
40    %endif
41    \
42    --depth=. \
43    ;
44
45#%__make -r %{?_smp_mflags} ffmpeg BUILDTYPE=Release V=1
46cd third_party/ffmpeg
47%__make -r %{?_smp_mflags} -f ffmpeg.Makefile BUILDTYPE=Release V=1
48
49popd
50
51%install
52%__rm -rf %{buildroot}
53%__mkdir_p %{buildroot}%{_libdir}/chromium/
54pushd chromium-%{version}/third_party/ffmpeg/out/Release
55%__cp -a lib*.so %{buildroot}%{_libdir}/chromium/
56popd
57
58
59%clean
60%{__rm} -rf %{buildroot}
61
62%files
63%defattr(-,root,root,-)
64%dir %{_libdir}/chromium
65%{_libdir}/chromium/libffmpegsumo.so
66
67%changelog
68* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
69- updated to 17.0.963.54
70
71* Mon Jan  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
72- updated to 16.0.912.75
73- added BuildRequires dependendies
74
75* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
76- initial release for Vine Linux
Note: See TracBrowser for help on using the repository browser.