source: projects/specs/trunk/nonfree/self-build-chromium-ffmpeg/chromium-ffmpeg-vl.spec @ 6214

Revision 6214, 2.3 KB checked in by munepi, 12 years ago (diff)

updated to 19.0.1084.50

Line 
1Name:           chromium-ffmpeg
2Summary:        The ffmpeg lib for Google's opens source browser Chromium
3Summary(ja):    Google オープンソースブラウザ Chromium 用 ffmpeg ライブラリ
4Version:        19.0.1084.50
5Release:        1%{?_dist_release}
6License:        BSD
7Group:          Applications/Internet
8# use the official tarball:
9Source0:        http://gsdview.appspot.com/chromium-browser-official/chromium-%{version}.tar.bz2
10Patch0:         chromium-ffmpeg-19.0.1084.50-drop-dependencies-base-gyp.patch
11
12Requires:       chromium >= %{version}
13BuildRequires:  zlib-devel
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17%description
18FFMPEG library built from the chromium sources.
19
20%description -l ja
21chromium のソースから FFMPEG ライブラリをビルドします。
22
23%prep
24%setup -q -c %{name}-%{version}
25%patch0 -p1 -b .vine
26
27%build
28
29## create make files
30pushd chromium-%{version}
31
32##NOTE: Use --depth as a workaround
33./build/gyp_chromium -f make third_party/ffmpeg/ffmpeg.gyp \
34    -Dffmpeg_branding=Chrome \
35    -Dlinux_use_gold_flags=0 \
36    -Dlinux_use_gold_binary=0 \
37    -Ddisable_nacl=1 \
38    -Dlinux_fpic=1 \
39    -Ddisable_sse2=1 \
40    %ifarch %{ix86}
41        -Dtarget_arch=ia32 \
42    %endif
43    %ifarch x86_64
44        -Dtarget_arch=x64 \
45    %endif
46    %if %{?_dist_release} == "vl6"
47        -Dgcc_version=44 \
48    %endif
49    \
50    --depth=. \
51    ;
52
53#%__make -r %{?_smp_mflags} ffmpeg BUILDTYPE=Release V=1
54cd third_party/ffmpeg
55%__make -r %{?_smp_mflags} -f ffmpeg.Makefile BUILDTYPE=Release V=1 disable_nacl=1
56
57popd
58
59%install
60%__rm -rf %{buildroot}
61%__mkdir_p %{buildroot}%{_libdir}/chromium/
62pushd chromium-%{version}/third_party/ffmpeg/out/Release
63%__cp -a lib*.so %{buildroot}%{_libdir}/chromium/
64popd
65
66
67%clean
68%{__rm} -rf %{buildroot}
69
70%files
71%defattr(-,root,root,-)
72%dir %{_libdir}/chromium
73%{_libdir}/chromium/libffmpegsumo.so
74
75%changelog
76* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.50-1
77- updated to 19.0.1084.50
78- applied chromium-ffmpeg-19.0.1084.50-drop-dependencies-base-gyp.patch
79
80* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
81- updated to 17.0.963.54
82
83* Mon Jan  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
84- updated to 16.0.912.75
85- added BuildRequires dependendies
86
87* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
88- initial release for Vine Linux
Note: See TracBrowser for help on using the repository browser.