source: projects/specs/trunk/nonfree/self-build-broadcom-wl/self-build-broadcom-wl-vl.spec @ 9103

Revision 9103, 5.6 KB checked in by inagaki, 9 years ago (diff)

2014-11-19 Ryoichi INAGAKI <ryo1@…>

  • self-build-broadcom-wl: updated


Line 
1%define pkgname broadcom-wl
2%define name    self-build-%{pkgname}
3
4%define oname   hybrid-portsrc
5%define over    %(echo %{version} | tr . _)
6
7%ifarch %{ix86}
8%define source0path http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
9%endif
10%ifarch x86_64
11%define source0path http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
12%endif
13
14Summary:        Package to automatically build %{pkgname} rpm package
15Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
16Name:           %{name}
17Version:        6.30.223.248
18Release:        1%{?_dist_release}
19Source0:        %{pkgname}.spec
20Source1:        blacklist-broadcom.conf
21
22License:        Freeware and GPLv2 with exception
23Group:          Restricted Software
24
25Requires(pre):  self-build-setup >= 0.7-1
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28ExclusiveArch:  %{ix86} x86_64
29
30
31%description
32Proprietary hybrid driver for Broadcom wireless adapters.
33
34If you install this package, it automaticaly downloads source
35code ,compile it, and create rpm packages of %{pkgname}-%{version}.
36And the created rpm packages are automatically installed
37if installation is executed by apt-get command or synaptic
38package manager.
39
40[Note]
41This package requires many other packages to compile
42targetsoftware. So it consume more disk space than usual.
43Also installation takes logner time because of compilation.
44(This will take a few minutes to quarter or half of an hour,
45depends on building environment)
46
47[About self-build package]
48For some kind of software, distributing of binary package
49may viorate the patent or law. Therefore we chose self-build
50packge, create binary package on your machine, for such kind
51of softwares instead of distributing binary package.
52
53Please obey the national law when you use the created binary
54packages. And if you want to use the softwares using patented
55thechnology, it may be required to get a permission, make an
56agreement or purchas a license. Please consider it with your
57purpose or way of use and take appropriate action.
58
59%description -l ja
60Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
61
62このパッケージをインストールすると、自動的にソースコードを
63ダウンロードしてコンパイルし、%{pkgname}-%{version}
64の rpm パッケージを作成します。
65また apt-get コマンドや synaptic パッケージマネージャから実行
66した場合は、作成された rpm パッケージのインストールも自動的に
67行います。
68
69[注意]
70コンパイルに必要な多くの関連パッケージを要求するので通常より
71ディスクの領域を多く消費します。
72またインストール時にコンパイルを行うため、通常より時間がかか
73る場合があります。(環境にもよりますが数分から数十分程度)
74
75[self-build パッケージについて]
76ソフトウェアによってはバイナリパッケージの配布が特許や法律に
77違反する可能性があるものがあります。その為、このような問題が
78懸念されるソフトウェアについてはバイナリパッケージを直接配布
79せずに、ユーザの環境でバイナリを作成する self-build パッケー
80ジという方法を採っています。
81
82作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
83アのライセンス、および利用する国の各種法令に従ってください。
84また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
85センスの購入などが必要となる場合がありますので、利用する目的
86や形態に応じて各自で判断し適切な対応を取ってください。
87
88
89%install
90rm -rf %{buildroot}
91install -d %{buildroot}%{_datadir}/%{name}
92install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
93#install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
94sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
95        %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}.spec
96
97
98%clean
99rm -rf %{buildroot}
100
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}.spec "%{source0path}"
104/usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
105
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}/*
110
111
112%changelog
113* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
114- new upstream release
115- dropped SOURCE2
116- updated dmks.conf
117
118* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
119- new upstream release.
120- dropped an old patch.
121- added SOURCE2 to compile for kernel-3.2.x.
122
123* Tue Oct  4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
124- update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
125
126* Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
127- add a patch to fix build failure on linux > 2.6.37
128
129* Sun Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
130- new upstream release
131
132* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
133- add Source2 to fix build failure on kernel >= 2.6.35
134  (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
135
136* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
137- new upstream release
138
139* Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
140- new upstream release
141
142* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
143- fix to ensure Source0 has correct version/release numbers
144
145* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
146- add ExclusiveArch
147
148* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
149- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.