source: projects/specs/trunk/nonfree/self-build-broadcom-wl/self-build-broadcom-wl-vl.spec @ 11260

Revision 11260, 6.5 KB checked in by ara_t, 6 years ago (diff)

update: self-build-broadcom-wl

Line 
1%define pkgname broadcom-wl
2%define name    self-build-%{pkgname}
3
4%define oname   hybrid-portsrc
5%define over    %(echo %{version} | tr . _)
6
7%define downloadurl https://docs.broadcom.com/docs-and-downloads/docs/linux_sta
8
9%ifarch %{ix86}
10%define source0path %{downloadurl}/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
11%endif
12%ifarch x86_64
13%define source0path %{downloadurl}/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
14%endif
15
16Summary:        Package to automatically build %{pkgname} rpm package
17Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
18Name:           %{name}
19Version:        6.30.223.271
20Release:        3%{?_dist_release}
21Source0:        %{pkgname}-vl.spec
22Source1:        blacklist-broadcom.conf
23
24Source100:      broadcom-wl-kernel318.patch
25# Patches from Debian-sid
26Source101:      14-rdtscl.patch
27Source102:      15-linux47.patch
28Source103:      16-linux48.patch
29Source104:      17-fix-kernel-warnings.patch
30Source105:      18-linux411.patch
31Source106:      19-linux412.patch
32
33License:        Freeware and GPLv2 with exception
34Group:          Restricted Software
35
36Requires(pre):  self-build-setup >= 0.7-1
37
38BuildRoot:      %{_tmppath}/%{name}-%{version}-root
39ExclusiveArch:  %{ix86} x86_64
40
41
42%description
43Proprietary hybrid driver for Broadcom wireless adapters.
44
45If you install this package, it automaticaly downloads source
46code ,compile it, and create rpm packages of %{pkgname}-%{version}.
47And the created rpm packages are automatically installed
48if installation is executed by apt-get command or synaptic
49package manager.
50
51[Note]
52This package requires many other packages to compile
53targetsoftware. So it consume more disk space than usual.
54Also installation takes logner time because of compilation.
55(This will take a few minutes to quarter or half of an hour,
56depends on building environment)
57
58[About self-build package]
59For some kind of software, distributing of binary package
60may viorate the patent or law. Therefore we chose self-build
61packge, create binary package on your machine, for such kind
62of softwares instead of distributing binary package.
63
64Please obey the national law when you use the created binary
65packages. And if you want to use the softwares using patented
66thechnology, it may be required to get a permission, make an
67agreement or purchas a license. Please consider it with your
68purpose or way of use and take appropriate action.
69
70%description -l ja
71Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
72
73このパッケージをインストールすると、自動的にソースコードを
74ダウンロードしてコンパイルし、%{pkgname}-%{version}
75の rpm パッケージを作成します。
76また apt-get コマンドや synaptic パッケージマネージャから実行
77した場合は、作成された rpm パッケージのインストールも自動的に
78行います。
79
80[注意]
81コンパイルに必要な多くの関連パッケージを要求するので通常より
82ディスクの領域を多く消費します。
83またインストール時にコンパイルを行うため、通常より時間がかか
84る場合があります。(環境にもよりますが数分から数十分程度)
85
86[self-build パッケージについて]
87ソフトウェアによってはバイナリパッケージの配布が特許や法律に
88違反する可能性があるものがあります。その為、このような問題が
89懸念されるソフトウェアについてはバイナリパッケージを直接配布
90せずに、ユーザの環境でバイナリを作成する self-build パッケー
91ジという方法を採っています。
92
93作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
94アのライセンス、および利用する国の各種法令に従ってください。
95また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
96センスの購入などが必要となる場合がありますので、利用する目的
97や形態に応じて各自で判断し適切な対応を取ってください。
98
99
100%install
101rm -rf %{buildroot}
102install -d %{buildroot}%{_datadir}/%{name}
103install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
104#install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
105sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
106        %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}-vl.spec
107
108# %{__install} -m 644 %{SOURCE100} \
109#            $RPM_BUILD_ROOT/%{_datadir}/%{name}
110%{__install} -m 644 \
111 %{SOURCE101} %{SOURCE102} %{SOURCE103} \
112 %{SOURCE104} %{SOURCE105} %{SOURCE106} \
113 $RPM_BUILD_ROOT/%{_datadir}/%{name}
114
115
116%clean
117rm -rf %{buildroot}
118
119
120%posttrans
121/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{source0path}"
122/usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
123
124
125%files
126%defattr(-,root,root)
127%{_datadir}/%{name}/*
128
129
130%changelog
131* Tue Dec 05 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-3
132- add patches for build with kernel 4.12
133
134* Wed Nov 22 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-2
135- change download URL
136
137* Sat Oct 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.30.223.271-1
138- new upstream release.
139- dropped SOURCE100.
140- fixed date of changelog.
141
142* Sun Aug  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-2
143- added Source100 to build with kernel 3.18
144
145* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
146- new upstream release
147- dropped SOURCE2
148- updated dmks.conf
149
150* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
151- new upstream release.
152- dropped an old patch.
153- added SOURCE2 to compile for kernel-3.2.x.
154
155* Tue Oct  4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
156- update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
157
158* Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
159- add a patch to fix build failure on linux > 2.6.37
160
161* Sat Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
162- new upstream release
163
164* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
165- add Source2 to fix build failure on kernel >= 2.6.35
166  (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
167
168* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
169- new upstream release
170
171* Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
172- new upstream release
173
174* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
175- fix to ensure Source0 has correct version/release numbers
176
177* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
178- add ExclusiveArch
179
180* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
181- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.