source: projects/specs/trunk/nonfree/self-build-broadcom-wl/self-build-broadcom-wl-vl.spec @ 11240

Revision 11240, 6.1 KB checked in by ara_t, 6 years ago (diff)

self-build-broadcom-wl: change URL

Line 
1%define pkgname broadcom-wl
2%define name    self-build-%{pkgname}
3
4%define oname   hybrid-portsrc
5%define over    %(echo %{version} | tr . _)
6
7%define downloadurl https://docs.broadcom.com/docs-and-downloads/docs/linux_sta
8
9%ifarch %{ix86}
10%define source0path %{downloadurl}/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
11%endif
12%ifarch x86_64
13%define source0path %{downloadurl}/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
14%endif
15
16Summary:        Package to automatically build %{pkgname} rpm package
17Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
18Name:           %{name}
19Version:        6.30.223.271
20Release:        2%{?_dist_release}
21Source0:        %{pkgname}-vl.spec
22Source1:        blacklist-broadcom.conf
23
24Source100:      broadcom-wl-kernel318.patch
25
26License:        Freeware and GPLv2 with exception
27Group:          Restricted Software
28
29Requires(pre):  self-build-setup >= 0.7-1
30
31BuildRoot:      %{_tmppath}/%{name}-%{version}-root
32ExclusiveArch:  %{ix86} x86_64
33
34
35%description
36Proprietary hybrid driver for Broadcom wireless adapters.
37
38If you install this package, it automaticaly downloads source
39code ,compile it, and create rpm packages of %{pkgname}-%{version}.
40And the created rpm packages are automatically installed
41if installation is executed by apt-get command or synaptic
42package manager.
43
44[Note]
45This package requires many other packages to compile
46targetsoftware. So it consume more disk space than usual.
47Also installation takes logner time because of compilation.
48(This will take a few minutes to quarter or half of an hour,
49depends on building environment)
50
51[About self-build package]
52For some kind of software, distributing of binary package
53may viorate the patent or law. Therefore we chose self-build
54packge, create binary package on your machine, for such kind
55of softwares instead of distributing binary package.
56
57Please obey the national law when you use the created binary
58packages. And if you want to use the softwares using patented
59thechnology, it may be required to get a permission, make an
60agreement or purchas a license. Please consider it with your
61purpose or way of use and take appropriate action.
62
63%description -l ja
64Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version}
68の rpm パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73[注意]
74コンパイルに必要な多くの関連パッケージを要求するので通常より
75ディスクの領域を多く消費します。
76またインストール時にコンパイルを行うため、通常より時間がかか
77る場合があります。(環境にもよりますが数分から数十分程度)
78
79[self-build パッケージについて]
80ソフトウェアによってはバイナリパッケージの配布が特許や法律に
81違反する可能性があるものがあります。その為、このような問題が
82懸念されるソフトウェアについてはバイナリパッケージを直接配布
83せずに、ユーザの環境でバイナリを作成する self-build パッケー
84ジという方法を採っています。
85
86作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
87アのライセンス、および利用する国の各種法令に従ってください。
88また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
89センスの購入などが必要となる場合がありますので、利用する目的
90や形態に応じて各自で判断し適切な対応を取ってください。
91
92
93%install
94rm -rf %{buildroot}
95install -d %{buildroot}%{_datadir}/%{name}
96install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
97#install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
98sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
99        %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}-vl.spec
100
101%{__install} -m 644 %{SOURCE100} \
102             $RPM_BUILD_ROOT/%{_datadir}/%{name}
103
104
105%clean
106rm -rf %{buildroot}
107
108
109%posttrans
110/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{source0path}"
111/usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
112
113
114%files
115%defattr(-,root,root)
116%{_datadir}/%{name}/*
117
118
119%changelog
120* Wed Nov 22 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-2
121- change download URL
122
123* Sat Oct 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.30.223.271-1
124- new upstream release.
125- dropped SOURCE100.
126- fixed date of changelog.
127
128* Sun Aug  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-2
129- added Source100 to build with kernel 3.18
130
131* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
132- new upstream release
133- dropped SOURCE2
134- updated dmks.conf
135
136* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
137- new upstream release.
138- dropped an old patch.
139- added SOURCE2 to compile for kernel-3.2.x.
140
141* Tue Oct  4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
142- update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
143
144* Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
145- add a patch to fix build failure on linux > 2.6.37
146
147* Sat Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
148- new upstream release
149
150* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
151- add Source2 to fix build failure on kernel >= 2.6.35
152  (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
153
154* Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
155- new upstream release
156
157* Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
158- new upstream release
159
160* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
161- fix to ensure Source0 has correct version/release numbers
162
163* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
164- add ExclusiveArch
165
166* Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
167- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.