source: projects/specs/trunk/nonfree/self-build-avidemux/avidemux-vl.spec @ 4349

Revision 4349, 13.7 KB checked in by munepi, 13 years ago (diff)

updated self-build-avidemux

Line 
1%define _pkgbuilddir %{_builddir}/%{name}_%{version}
2
3Name:           avidemux
4Version:        2.5.2
5Release:        5%{?_dist_release}
6Summary:        Graphical video editing and transcoding tool
7
8Group:          Applications/Multimedia
9License:        GPLv2+
10URL:            http://www.avidemux.org/
11Source0:        http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
12Source1:        %{name}-gtk.desktop
13Source2:        %{name}-qt.desktop
14# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
15# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
16Patch0:         2.5.0-coreImage-parallel-build.patch
17Patch1:         avidemux-2.5-pulseaudio-default.patch
18Patch2:         avidemux-2.4-qt4.patch
19Patch3:         avidemux-2.5-i18n.patch
20Patch4:         avidemux-2.5-libmpeg2enc-altivec.patch
21Patch5:         avidemux-2.5-checkfunction-includes.patch
22Patch6:         avidemux-2.5.1-tmplinktarget.patch
23Patch7:         avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch
24
25## Vine customization patches
26Patch10:         avidemux-2.4.3-alsa-device-default.patch
27Patch11:         avidemux-2.5.2-no-qt4-ui.patch
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
30
31Requires:       %{name}-cli  = %{version}
32Requires:       %{name}-gui = %{version}
33Obsoletes:      %{name}-qt < 2.5.0
34
35# *-devel pacages provided by other self-build-* should only be listed
36# in self-build-%{name}.spec as PreReq.
37
38# Compiling
39BuildRequires:  cmake
40#BuildRequires:  gettext-devel
41BuildRequires:  gettext
42
43# Libraries
44BuildRequires:  nasm >= 0.98.38
45BuildRequires:  libxml2-devel >= 2.6.8
46BuildRequires:  fontconfig-devel
47#BuildRequires:  freetype-devel
48BuildRequires:  freetype2-devel
49BuildRequires:  js-devel
50BuildRequires:  libXv-devel
51BuildRequires:  libXmu-devel
52# Required by gtk: libXi-devel, libXext-devel, libX11-devel
53# Required by qt: libXt-devel, libXext-devel, libX11-devel
54BuildRequires:  libsamplerate-devel
55BuildRequires:  jack-audio-connection-kit-devel
56
57# Sound out
58BuildRequires:  alsa-lib-devel >= 1.0.3
59BuildRequires:  pulseaudio-libs-devel
60
61# Video out
62BuildRequires:  SDL-devel >= 1.2.7
63
64# Audio Codecs
65#BuildRequires:  a52dec-devel >= 0.7.4
66#BuildRequires:  faac-devel >= 1.24
67#BuildRequires:  faad2-devel >= 2.0
68#BuildRequires:  lame-devel >= 3.96.1
69#BuildRequires:  libmad-devel >= 0.15.1
70BuildRequires:  libogg-devel >= 1.1
71BuildRequires:  libvorbis-devel >= 1.0.1
72# BuildRequires:  self-build-a52dec >= 0.7.4
73# BuildRequires:  self-build-faac >= 1.24
74# BuildRequires:  self-build-faad2 >= 2.0
75# BuildRequires:  self-build-lame >= 3.96.1
76# BuildRequires:  self-build-libmad >= 0.15.1
77#BuildRequires:  libdca-devel
78# BuildRequires:  self-build-libdca
79
80# Video Codecs
81#BuildRequires:  xvidcore-devel >= 1.0.2
82#BuildRequires:  x264-devel
83#BuildRequires:  ffmpeg-devel
84# BuildRequires:  self-build-xvidcore >= 1.0.2
85# BuildRequires:  self-build-x264
86# BuildRequires:  self-build-ffmpeg
87
88# FIXME: aften not packaged, add BR when it is
89
90# Finally...
91BuildRequires:  desktop-file-utils
92
93%description
94Avidemux is a free video editor designed for simple cutting, filtering and
95encoding tasks. It supports many file types, including AVI, DVD compatible
96MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
97using projects, job queue and powerful scripting capabilities.
98
99For compatability reasons, avidemux is a meta-package which installs the
100graphical, command line and plugin packages. If you want a smaller setup,
101you may selectively install one or more of the avidemux-* subpackages.
102
103%package cli
104Summary:        CLI for %{name}
105Group:          Applications/Multimedia
106Requires:       %{name} = %{version}-%{release}
107
108%description cli
109This package provides a command-line interface to editing videos with %{name}.
110
111%package gtk
112Summary:        GTK interface for %{name}
113Group:          Applications/Multimedia
114BuildRequires:  gtk2-devel >= 2.8.0
115BuildRequires:  cairo-devel
116# Slightly higher so it is default, but it can be avoided by installing
117# avidemux-qt directly or it can be removed later once avidemux-qt is installed
118Provides:       %{name}-gui = %{version}-%{release}.1
119Requires:       %{name} = %{version}-%{release}
120
121%description gtk
122This package provides the GTK graphical interface for %{name}.
123
124%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
125%package qt
126Summary:        Qt interface for %{name}
127Group:          Applications/Multimedia
128# 4.5.0-9 fixes a failure when there are duplicate translated strings
129# https://bugzilla.redhat.com/show_bug.cgi?id=491514
130BuildRequires:  qt4-devel >= 4.5.0-9
131BuildRequires:  qt4-designer
132Provides:       %{name}-gui = %{version}-%{release}
133Requires:       %{name} = %{version}-%{release}
134
135%description qt
136This package contains the Qt graphical interface for %{name}.
137%endif
138
139%package devel
140Summary:        Development files for %{name}
141Group:          Development/Libraries
142Requires:       %{name} = %{version}-%{release}
143
144%description devel
145This package contains files required to develop with or extend %{name}.
146
147%prep
148%__rm -rf $RPM_BUILD_ROOT
149
150%setup -q -n avidemux_%{version}
151
152# change hardcoded libdir paths
153%ifarch x86_64 ppc64
154%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
155%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
156%endif
157
158%patch0 -p1 -b .parallel
159%patch1 -p1 -b .pulse
160#%patch2 -p1 -b .qt4
161%patch3 -p1 -b .i18n
162%patch4 -p1 -b .altivec
163%patch5 -p1 -b .cfincludes
164#%patch6 -p1 -b .tmplinktarget
165%patch7 -p1 -b .blind
166
167#%patch10 -p1 -b .alsa
168%{!?with_qt_ui:%patch11 -p1 -b .qt4}
169
170%build
171# Out of source build
172%__mkdir_p build && cd build
173%cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
174       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
175       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
176       ..
177%__make %{?_smp_mflags}
178# Create the temp link directory manuall since otherwise it happens too early
179%__mkdir_p %{_pkgbuilddir}/build/%{_lib}
180find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
181     xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
182
183%__mkdir_p ../build_plugins && cd ../build_plugins
184%cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
185       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
186       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
187       ../plugins
188%__make %{?_smp_mflags}
189
190
191%install
192%__rm -rf $RPM_BUILD_ROOT
193# Temporary workaround since the i18n files aren't being built
194%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/%{name}
195
196%__make -C build install DESTDIR=$RPM_BUILD_ROOT
197%__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
198# Install the build configuration for devel package
199%__install -d -m755 $RPM_BUILD_ROOT%{_includedir}
200%__install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
201
202# Find and remove all la files
203find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
204
205# Install .desktop shortcuts
206desktop-file-install --vendor vine \
207    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
208    %{SOURCE1}
209
210%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
211desktop-file-install --vendor vine \
212    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
213    %{SOURCE2}
214%endif
215
216find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
217%find_lang %{name}
218
219%clean
220%__rm -rf $RPM_BUILD_ROOT
221
222%post -p /sbin/ldconfig
223%postun -p /sbin/ldconfig
224
225%files -f %{name}.lang
226%defattr(-,root,root,-)
227%doc AUTHORS COPYING README TODO
228%{_datadir}/%{name}/
229%{_datadir}/ADM_scripts/
230%{_libdir}/libADM*
231%{_libdir}/ADM_plugins/
232
233%files cli
234%defattr(-,root,root,-)
235%{_bindir}/avidemux2_cli
236
237%files gtk
238%defattr(-,root,root,-)
239%{_bindir}/avidemux2_gtk
240%{_datadir}/applications/*gtk*.desktop
241
242%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
243%files qt
244%defattr(-,root,root,-)
245#{_datadir}/%{name}/i18n/
246%{_bindir}/avidemux2_qt4
247%{_datadir}/applications/*qt*.desktop
248%endif
249
250%files devel
251%defattr(-,root,root,-)
252%{_includedir}/ADM_coreConfig.h
253
254
255%changelog
256* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-5
257- dropped BuildRequires: esound-devel
258
259* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
260- add Patch7 (avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch)
261
262* Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
263- unapply avidemux-2.4-qt4.patch
264
265* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
266- change release to sync with self-build-avidemux
267
268* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
269- new upstream release
270
271* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
272- new upstream release
273  - update patches accordingly
274  - build with x264 >= 0.0.0-9.20090522
275- dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
276
277* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
278- corrected release number
279
280* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
281- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
282- changed to PreReq:  self-build-libmad >= 0.15.1 from libmad-devel
283
284* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
285- change release to sync with self-build-avidemux
286
287* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
288- added avidemux-x264.patch from Gentoo
289
290* Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
291- applied avidemux-2.4.3-alsa-device-default.patch
292
293* Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
294- initial build based on RPM Fusion of Fedora package
295  - changed to BuildRequires: gettext from gettext-devel
296  - added BuildRequires: qt4-designer for gtk subpackage
297  - dropped avidemux-2.4.3-qt4.patch
298 
299* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
300- Add CMake patch for PPC64
301- Update patches for 2.4.3
302- Remove outdated libmad patch (Nov. 2007)
303
304* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
305- Add another patch to fix ppc64 build (pointer type), first
306  patch was for libmad
307
308* Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
309- Add patch to fix ppc64 build
310
311* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
312- retag
313
314* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
315- Update to 2.4.3
316
317* Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
318- ppc64 uint_32 fun
319
320* Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
321- rebuild
322
323* Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
324- Update to 2.4.2
325
326* Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
327- Disable --new-faad
328- 20080521 subversion snapshot
329
330* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
331- Disable %%{?_smp_mflags}
332
333* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
334- Update to 2.4.1
335- Don't list the bin files twice, revisited
336- Default to GTK frontend
337
338* Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
339- Make pulseaudio default for sound out
340- Don't list the bin files twice
341- Don't build with arts support
342
343* Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
344- Don't list the .desktop files twice (bz#1870)
345- Oops, we should have %%{svndate}svn in release tag!
346
347* Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
348- F-8/F-7 x86_64 does seem to need --with-newfaad
349
350* Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
351- Update to version 2.4 (20080126svn) and include fixes from devel branch
352
353* Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
354- Fix many copy/paste errors and desktop file's Exec field
355
356* Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
357- Update to 2.4 final
358- Split up desktop files and make them pass desktop-file-validate
359- Add structure to split into gtk and qt pacakges
360- Disable qt4 for now, doesn't compile
361
362* Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
363- move js-include to a place where it is honored
364
365* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
366- Fix macro problem
367- Fix changelog date
368- Rebuild with faad, but don't pass --newfaad
369
370* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
371- Rebuild with no faad
372
373* Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
374- Rebuild for ffmpeg dependency problems
375- Update License: tag per Fedora guidelines
376
377* Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
378- more features with new BR's: x264-devel libXv-devel
379- make a note regarding the libdca-devel problem
380- remove the "0:" from the versioned BR's
381
382* Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
383- don't use smp_mflags during make for now
384
385* Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
386- Update to 2.3.0 Final
387- Use find_lang
388
389* Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
390- Update to 2.1.2
391
392* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
393- switch to new release field
394
395* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
396- add dist
397
398* Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
399- Update to 2.1.0
400- Drop epoch
401- gtk 2.6 now, so drop FC3 support
402
403* Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
404- Remove bogus BR ffmpeg-devel (#555)
405
406* Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
407- Add missing BR desktop-file-utils (thanks to ixs)
408
409* Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
410- Update to 2.0.42
411
412* Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
413- Update to 2.0.34
414- Rename package to avidemux -- no need for avidemux2 afaics
415
416* Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
417- Update to 2.0.34-test1
418- BR gettext, libtool
419
420* Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
421- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.