source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 12427

Revision 12427, 13.5 KB checked in by tomop, 4 years ago (diff)

nsd-4.3.2-1

Line 
1%bcond_with systemd
2
3Summary: Fast and lean authoritative DNS Name Server
4Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
5Name: nsd
6Version: 4.3.2
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: BSD
13Url: http://www.nlnetlabs.nl/%{name}/
14Source: https://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
15Source1: nsd.init
16Source3: nsd.sysconfig
17Source10: nsd.service
18Source11: nsd-keygen.service
19Source12: tmpfiles-nsd.conf
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: flex, libevent-devel, openssl-devel
23Requires(pre): shadow-utils
24%if %{with systemd}
25%global piddir /run/%{name}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29%global piddir %{_localstatedir}/run/%{name}
30Requires(post): /sbin/chkconfig
31Requires(preun): /sbin/chkconfig
32Requires(preun): /sbin/service
33Requires(postun): /sbin/service
34%endif
35
36%description
37NSD is a complete implementation of an authoritative DNS name server.
38For further information about what NSD is and what NSD is not please
39consult the REQUIREMENTS document which is a part of this distribution
40
41%description -l ja
42NSD は Authoritative DNSネームサーバの完全な実装です。
43NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
44
45
46%prep
47%setup -q
48autoreconf
49
50
51%build
52%configure \
53        --with-configdir=%{_sysconfdir}/nsd \
54        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
55        --with-zonesdir=%{_sysconfdir}/nsd \
56        --with-pidfile=%{piddir}/%{name}/%{name}.pid \
57    --with-zonelistfile=%{_sharedstatedir}/nsd/zone.list \
58        --with-ssl \
59        --with-user=nsd \
60        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
61        --with-max-ips=1024 \
62        --with-dbfile="" \
63        --enable-bind8-stats \
64        --enable-zone-stats \
65        --enable-checking \
66        --enable-mmap \
67        --enable-nsec3 \
68        --enable-ratelimit \
69        --enable-pie \
70        --enable-relro-now \
71        --enable-recvmmsg \
72        --enable-packed \
73        --enable-memclean \
74%if %{with systemd}
75        --enable-systemd \
76%endif
77        %{nil}
78
79%{__make} %{?_smp_mflags}
80#convert to utf8
81iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
82iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
83mv -f doc/RELNOTES.utf8 doc/RELNOTES
84mv -f doc/CREDITS.utf8 doc/CREDITS
85
86
87%install
88rm -rf %{buildroot}
89%{__make} DESTDIR=%{buildroot} install
90install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
91install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
92
93%if %{with systemd}
94mkdir -p %{buildroot}%{_unitdir}
95install -m 0644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_unitdir}
96mkdir -p %{buildroot}%{_tmpfilesdir}
97install -m 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/nsd.conf
98%else
99install -d -m 0755 %{buildroot}%{_initrddir}
100install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
101install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
102install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
103%endif
104
105# change .sample to normal config files
106mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
107sed -i \
108        -e 's/# database:.*$/database: ""/' \
109        -e 's/# round-robin:.*$/round-robin: yes/' \
110        -e 's/# minimal-responses:.*$/minimal-responses: yes/' \
111        -e 's/# refuse-any:.*$/refuse-any: yes/' \
112        -e 's/# control-enable:.*$/control-enable: yes/' \
113        -e 's|# control-interface: ::1|control-interface: %{piddir}/nsd.ctl|' \
114        %{buildroot}%{_sysconfdir}/nsd/nsd.conf
115
116
117%clean
118rm -rf ${RPM_BUILD_ROOT}
119
120
121%files
122%defattr(-,root,root,-)
123%doc doc/*
124%doc contrib/nsd.zones2nsd.conf
125%dir %{_sysconfdir}/nsd/
126%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
127#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
128%if %{with systemd}
129%attr(0644,root,root) %{_unitdir}/nsd.service
130%attr(0644,root,root) %{_unitdir}/nsd-keygen.service
131%attr(0644,root,root) %{_tmpfilesdir}/nsd.conf
132%else
133%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
134%attr(0755,root,root) %{_initrddir}/%{name}
135%endif
136%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
137%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
138%{_sbindir}/*
139%{_mandir}/*/*
140
141
142%pre
143getent group nsd >/dev/null || groupadd -r nsd
144getent passwd nsd >/dev/null || \
145useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
146-c "nsd daemon account" nsd
147exit 0
148
149%post
150chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
151chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
152%if %{with systemd}
153%systemd_post nsd.service
154%systemd_post nsd-keygen.service
155%else
156/sbin/chkconfig --add %{name}
157if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
158  /usr/sbin/nsd-control-setup
159fi
160%endif
161
162%preun
163%if %{with systemd}
164%systemd_preun nsd.service
165%systemd_preun nsd-keygen.service
166%else
167if [ $1 -eq 0 -o -x /bin/systemctl ]; then
168        /sbin/service %{name} stop
169        /sbin/chkconfig --del %{name}
170fi
171%endif
172
173%postun
174%if %{with systemd}
175%systemd_postun_with_restart nsd.service
176%systemd_postun nsd-keygen.service
177%else
178if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
179  /sbin/service %{name} condrestart
180fi
181%endif
182
183%changelog
184* Wed Jul 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.2-1
185- new upstream release.
186
187* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.1-1
188- new upstream release.
189
190* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-3
191- rebuilt with libevent-2.1.11.
192
193* Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-2
194- fixed nsd-keygen.service.
195- updated nsd.conf.
196
197* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
198- new upstream release.
199- dropped Patch0.
200- added systemd support (disabled as default).
201
202* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
203- new upstream release.
204
205* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
206- new upstream release.
207
208* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
209- new upstream release.
210- rebuilt with openssl-1.1.1 and libevent-2.1.8.
211
212* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
213- new upstream release.
214
215* Wed Mar  8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
216- new upstream release.
217
218* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
219- new upstream release.
220
221* Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
222- new upstream release.
223
224* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
225- rebuilt with openssl-1.0.2g.
226
227* Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
228- new upstream release.
229
230* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
231- new upstream release.
232
233* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
234- new upstream release.
235
236* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
237- new upstream release.
238- dropped Source2 (no longer needed).
239
240* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
241- new upstream release
242
243* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
244- new upstream release
245
246* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
247- new upstream release
248
249* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
250- new upstream release
251
252* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
253- initial build for Vine Linux
254
255* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
256- Updated to nsd 3.2.4
257
258* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
259- Incorporated Ville Mattila's fixes  to nsd.cron
260- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
261
262* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
263- rebuilt with new openssl
264
265* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
266- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
267
268* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
269-Updated to version 3.2.3
270
271* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
273
274* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
275- Fixed /dev/nul which cause a file \%%1 to be written by cron
276- Bump for EVR.
277
278* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
279- Upgraded to 3.2.2 security release
280  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
281
282* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
283- Make various file paths used by the nsd.init script configurable
284  from /etc/sysconfig/nsd.
285- Add template /etc/sysconfig/nsd.
286
287* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
288- nsd used the 'named' subsystem in one call in the init script
289
290* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
291- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
292
293* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
294- Fix init script 'unary operator' error.
295
296* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
297- Updated to new version 3.2.1
298
299* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
300- rebuild with new openssl
301
302* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
303- Updates summary as per Richard Hughes guidelines
304
305* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
306- Bump version after pre-release version correction.
307
308* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
309- 3.2.0-1
310
311* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
312- updated to 3.1.1
313
314* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
315- fix license tag
316- fix static user creation
317
318* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
319- Updated to 3.1.0
320
321* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
322- Fix /dev/null redirection [Venkatesh Krishnamurthi]
323
324* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
325- Updated to 3.0.8
326
327* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
328- Autorebuild for GCC 4.3
329
330* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
331- Rebuild for new libcrypto
332
333* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
334- Updated to new version
335- fix RELNOTES/README to be utf8
336- Fix path to nsd.db in cron job.
337
338* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
339- Modified cron to only rebuild/reload when zone updates
340  have been received
341
342* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
343- Added hourly cron job to do various maintenance tasks
344- Added nsd rebuild to create the proper nsd.db file on startup
345- Added nsd patch on shutdown to ensure zonefiles are up to date
346
347* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
348- nsdc update and nsdc notify are no longer needed in initscript.
349
350* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
351- Bump release for upgrade path.
352
353* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
354- Do not include examples from nsd.conf.sample that causes
355  bogus network traffic.
356
357* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
358- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
359- Enable NSEC3
360- Delay running nsdc update until after nsd has started
361- Delete xfrd.state on nsd stop
362- Run nsdc notify in the background, since it can take
363  a very long time when remote servers are unavailable.
364
365* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
366- Upgraded to 3.0.6
367- Do not include bind2nsd, since it didn't compile for me
368
369* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
370- Fix init script, bug #245546
371
372* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
373- Upgraded to 3.0.5
374
375* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
376- Upgraded to 3.0.3
377
378* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
379- Upgraded to 3.0.2.
380- Use new configuration file nsd.conf. Still needs migration script.
381  patch from Farkas Levente <lfarkas@bppiac.hu>
382
383* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
384- Bump version for upgrade path
385
386* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
387- Upgraded to 2.3.6
388- Removed obsolete workaround in nsd.init
389- Fixed spec file so daemon gets properly restarted on upgrade
390
391* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
392- Rebuild requested for PT_GNU_HASH support from gcc
393- Removed dbaccess.c from doc section
394
395* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
396- Bump version for FC-x upgrade path
397
398* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
399- Upgraded to nsd-2.3.5
400
401* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
402- Upgraded to nsd-2.3.4.
403- Removed manual install targets because DESTDIR is now supported
404- Re-enabled --checking, checking patch no longer needed and removed.
405- Work around in nsd.init for nsd failing to start when there is no ipv6
406
407* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
408- chkconfig and attribute  changes as proposed by Dmitry Butskoy
409
410* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
411- Moved pid file to /var/run/nsd/nsd.pid.
412- Use _localstatedir instead of "/var"
413
414* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
415- Added BuildRequires for openssl-devel, removed Requires for openssl.
416
417* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
418- upgraded to nsd-2.3.3
419
420* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
421- minor cleanups
422
423* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
424- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
425  Extras policies (eg do not start daemon on fresh install)
426
427* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
428- Initial version
Note: See TracBrowser for help on using the repository browser.