source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 12503

Revision 12503, 13.6 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

mariadb-10.5.6-1

nsd-4.3.3-1

pcre2-10.35-1

rspamd-2.6-2

unbound-1.12.0-1

Line 
1%bcond_with systemd
2
3Summary: Fast and lean authoritative DNS Name Server
4Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
5Name: nsd
6Version: 4.3.3
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: servers
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: BSD
13Url: http://www.nlnetlabs.nl/%{name}/
14Source: https://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
15Source1: nsd.init
16Source3: nsd.sysconfig
17Source10: nsd.service
18Source11: nsd-keygen.service
19Source12: tmpfiles-nsd.conf
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: flex, libevent-devel, openssl-devel
23Requires(pre): shadow-utils
24%if %{with systemd}
25%global piddir /run/%{name}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29%global piddir %{_localstatedir}/run/%{name}
30Requires(post): /sbin/chkconfig
31Requires(preun): /sbin/chkconfig
32Requires(preun): /sbin/service
33Requires(postun): /sbin/service
34%endif
35
36%description
37NSD is a complete implementation of an authoritative DNS name server.
38For further information about what NSD is and what NSD is not please
39consult the REQUIREMENTS document which is a part of this distribution
40
41%description -l ja
42NSD は Authoritative DNSネームサーバの完全な実装です。
43NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
44
45
46%debug_package
47
48
49%prep
50%setup -q
51autoreconf
52
53
54%build
55%configure \
56        --with-configdir=%{_sysconfdir}/nsd \
57        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
58        --with-zonesdir=%{_sysconfdir}/nsd \
59        --with-pidfile=%{piddir}/%{name}/%{name}.pid \
60    --with-zonelistfile=%{_sharedstatedir}/nsd/zone.list \
61        --with-ssl \
62        --with-user=nsd \
63        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
64        --with-max-ips=1024 \
65        --with-dbfile="" \
66        --enable-bind8-stats \
67        --enable-zone-stats \
68        --enable-checking \
69        --enable-mmap \
70        --enable-nsec3 \
71        --enable-ratelimit \
72        --enable-pie \
73        --enable-relro-now \
74        --enable-recvmmsg \
75        --enable-packed \
76        --enable-memclean \
77%if %{with systemd}
78        --enable-systemd \
79%endif
80        %{nil}
81
82%{__make} %{?_smp_mflags}
83#convert to utf8
84iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
85iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
86mv -f doc/RELNOTES.utf8 doc/RELNOTES
87mv -f doc/CREDITS.utf8 doc/CREDITS
88
89
90%install
91rm -rf %{buildroot}
92%{__make} DESTDIR=%{buildroot} install
93install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
94install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
95
96%if %{with systemd}
97mkdir -p %{buildroot}%{_unitdir}
98install -m 0644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_unitdir}
99mkdir -p %{buildroot}%{_tmpfilesdir}
100install -m 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/nsd.conf
101%else
102install -d -m 0755 %{buildroot}%{_initrddir}
103install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
104install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
105install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
106%endif
107
108# change .sample to normal config files
109mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
110sed -i \
111        -e 's/# database:.*$/database: ""/' \
112        -e 's/# round-robin:.*$/round-robin: yes/' \
113        -e 's/# minimal-responses:.*$/minimal-responses: yes/' \
114        -e 's/# refuse-any:.*$/refuse-any: yes/' \
115        -e 's/# control-enable:.*$/control-enable: yes/' \
116        -e 's|# control-interface: ::1|control-interface: %{piddir}/nsd.ctl|' \
117        %{buildroot}%{_sysconfdir}/nsd/nsd.conf
118
119
120%clean
121rm -rf ${RPM_BUILD_ROOT}
122
123
124%files
125%defattr(-,root,root,-)
126%doc doc/*
127%doc contrib/nsd.zones2nsd.conf
128%dir %{_sysconfdir}/nsd/
129%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
130#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
131%if %{with systemd}
132%attr(0644,root,root) %{_unitdir}/nsd.service
133%attr(0644,root,root) %{_unitdir}/nsd-keygen.service
134%attr(0644,root,root) %{_tmpfilesdir}/nsd.conf
135%else
136%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
137%attr(0755,root,root) %{_initrddir}/%{name}
138%endif
139%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
140%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
141%{_sbindir}/*
142%{_mandir}/*/*
143
144
145%pre
146getent group nsd >/dev/null || groupadd -r nsd
147getent passwd nsd >/dev/null || \
148useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
149-c "nsd daemon account" nsd
150exit 0
151
152%post
153chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
154chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
155%if %{with systemd}
156%systemd_post nsd.service
157%systemd_post nsd-keygen.service
158%else
159/sbin/chkconfig --add %{name}
160if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
161  /usr/sbin/nsd-control-setup
162fi
163%endif
164
165%preun
166%if %{with systemd}
167%systemd_preun nsd.service
168%systemd_preun nsd-keygen.service
169%else
170if [ $1 -eq 0 -o -x /bin/systemctl ]; then
171        /sbin/service %{name} stop
172        /sbin/chkconfig --del %{name}
173fi
174%endif
175
176%postun
177%if %{with systemd}
178%systemd_postun_with_restart nsd.service
179%systemd_postun nsd-keygen.service
180%else
181if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
182  /sbin/service %{name} condrestart
183fi
184%endif
185
186%changelog
187* Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.3-1
188- new upstream release.
189
190* Wed Jul 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.2-1
191- new upstream release.
192
193* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.1-1
194- new upstream release.
195
196* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-3
197- rebuilt with libevent-2.1.11.
198
199* Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-2
200- fixed nsd-keygen.service.
201- updated nsd.conf.
202
203* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
204- new upstream release.
205- dropped Patch0.
206- added systemd support (disabled as default).
207
208* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
209- new upstream release.
210
211* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
212- new upstream release.
213
214* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
215- new upstream release.
216- rebuilt with openssl-1.1.1 and libevent-2.1.8.
217
218* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
219- new upstream release.
220
221* Wed Mar  8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
222- new upstream release.
223
224* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
225- new upstream release.
226
227* Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
228- new upstream release.
229
230* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
231- rebuilt with openssl-1.0.2g.
232
233* Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
234- new upstream release.
235
236* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
237- new upstream release.
238
239* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
240- new upstream release.
241
242* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
243- new upstream release.
244- dropped Source2 (no longer needed).
245
246* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
247- new upstream release
248
249* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
250- new upstream release
251
252* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
253- new upstream release
254
255* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
256- new upstream release
257
258* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
259- initial build for Vine Linux
260
261* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
262- Updated to nsd 3.2.4
263
264* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
265- Incorporated Ville Mattila's fixes  to nsd.cron
266- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
267
268* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
269- rebuilt with new openssl
270
271* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
272- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
273
274* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
275-Updated to version 3.2.3
276
277* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
279
280* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
281- Fixed /dev/nul which cause a file \%%1 to be written by cron
282- Bump for EVR.
283
284* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
285- Upgraded to 3.2.2 security release
286  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
287
288* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
289- Make various file paths used by the nsd.init script configurable
290  from /etc/sysconfig/nsd.
291- Add template /etc/sysconfig/nsd.
292
293* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
294- nsd used the 'named' subsystem in one call in the init script
295
296* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
298
299* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
300- Fix init script 'unary operator' error.
301
302* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
303- Updated to new version 3.2.1
304
305* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
306- rebuild with new openssl
307
308* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
309- Updates summary as per Richard Hughes guidelines
310
311* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
312- Bump version after pre-release version correction.
313
314* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
315- 3.2.0-1
316
317* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
318- updated to 3.1.1
319
320* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
321- fix license tag
322- fix static user creation
323
324* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
325- Updated to 3.1.0
326
327* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
328- Fix /dev/null redirection [Venkatesh Krishnamurthi]
329
330* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
331- Updated to 3.0.8
332
333* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
334- Autorebuild for GCC 4.3
335
336* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
337- Rebuild for new libcrypto
338
339* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
340- Updated to new version
341- fix RELNOTES/README to be utf8
342- Fix path to nsd.db in cron job.
343
344* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
345- Modified cron to only rebuild/reload when zone updates
346  have been received
347
348* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
349- Added hourly cron job to do various maintenance tasks
350- Added nsd rebuild to create the proper nsd.db file on startup
351- Added nsd patch on shutdown to ensure zonefiles are up to date
352
353* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
354- nsdc update and nsdc notify are no longer needed in initscript.
355
356* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
357- Bump release for upgrade path.
358
359* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
360- Do not include examples from nsd.conf.sample that causes
361  bogus network traffic.
362
363* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
364- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
365- Enable NSEC3
366- Delay running nsdc update until after nsd has started
367- Delete xfrd.state on nsd stop
368- Run nsdc notify in the background, since it can take
369  a very long time when remote servers are unavailable.
370
371* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
372- Upgraded to 3.0.6
373- Do not include bind2nsd, since it didn't compile for me
374
375* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
376- Fix init script, bug #245546
377
378* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
379- Upgraded to 3.0.5
380
381* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
382- Upgraded to 3.0.3
383
384* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
385- Upgraded to 3.0.2.
386- Use new configuration file nsd.conf. Still needs migration script.
387  patch from Farkas Levente <lfarkas@bppiac.hu>
388
389* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
390- Bump version for upgrade path
391
392* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
393- Upgraded to 2.3.6
394- Removed obsolete workaround in nsd.init
395- Fixed spec file so daemon gets properly restarted on upgrade
396
397* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
398- Rebuild requested for PT_GNU_HASH support from gcc
399- Removed dbaccess.c from doc section
400
401* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
402- Bump version for FC-x upgrade path
403
404* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
405- Upgraded to nsd-2.3.5
406
407* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
408- Upgraded to nsd-2.3.4.
409- Removed manual install targets because DESTDIR is now supported
410- Re-enabled --checking, checking patch no longer needed and removed.
411- Work around in nsd.init for nsd failing to start when there is no ipv6
412
413* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
414- chkconfig and attribute  changes as proposed by Dmitry Butskoy
415
416* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
417- Moved pid file to /var/run/nsd/nsd.pid.
418- Use _localstatedir instead of "/var"
419
420* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
421- Added BuildRequires for openssl-devel, removed Requires for openssl.
422
423* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
424- upgraded to nsd-2.3.3
425
426* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
427- minor cleanups
428
429* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
430- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
431  Extras policies (eg do not start daemon on fresh install)
432
433* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
434- Initial version
Note: See TracBrowser for help on using the repository browser.