source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 12521

Revision 12521, 13.8 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

dnsmasq-2.84-1

firefox-78.7.0-1

kernel-5.4.93-1

libmaxminddb-1.5.0-1

nsd-4.3.5-1

openldap-2.4.57-1

python-pillow-8.1.0-1

rust-1.49.0-1

samba-4.13.4-1

sudo-1.9.5p2-1

thunderbird-78.7.0-1

Line 
1%bcond_with systemd
2
3Summary: Fast and lean authoritative DNS Name Server
4Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
5Name: nsd
6Version: 4.3.5
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: servers
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: BSD
13Url: http://www.nlnetlabs.nl/%{name}/
14Source: https://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
15Source1: nsd.init
16Source3: nsd.sysconfig
17Source10: nsd.service
18Source11: nsd-keygen.service
19Source12: tmpfiles-nsd.conf
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: flex, libevent-devel, openssl-devel
23Requires(pre): shadow-utils
24%if %{with systemd}
25%global piddir /run/%{name}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29%global piddir %{_localstatedir}/run/%{name}
30Requires(post): /sbin/chkconfig
31Requires(preun): /sbin/chkconfig
32Requires(preun): /sbin/service
33Requires(postun): /sbin/service
34%endif
35
36%description
37NSD is a complete implementation of an authoritative DNS name server.
38For further information about what NSD is and what NSD is not please
39consult the REQUIREMENTS document which is a part of this distribution
40
41%description -l ja
42NSD は Authoritative DNSネームサーバの完全な実装です。
43NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
44
45
46%debug_package
47
48
49%prep
50%setup -q
51autoreconf
52
53
54%build
55%configure \
56        --with-configdir=%{_sysconfdir}/nsd \
57        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
58        --with-zonesdir=%{_sysconfdir}/nsd \
59        --with-pidfile=%{piddir}/%{name}/%{name}.pid \
60    --with-zonelistfile=%{_sharedstatedir}/nsd/zone.list \
61        --with-ssl \
62        --with-user=nsd \
63        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
64        --with-max-ips=1024 \
65        --with-dbfile="" \
66        --enable-bind8-stats \
67        --enable-zone-stats \
68        --enable-checking \
69        --enable-mmap \
70        --enable-nsec3 \
71        --enable-ratelimit \
72        --enable-pie \
73        --enable-relro-now \
74        --enable-recvmmsg \
75        --enable-packed \
76        --enable-memclean \
77%if %{with systemd}
78        --enable-systemd \
79%endif
80        %{nil}
81
82%{__make} %{?_smp_mflags}
83#convert to utf8
84iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
85iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
86mv -f doc/RELNOTES.utf8 doc/RELNOTES
87mv -f doc/CREDITS.utf8 doc/CREDITS
88
89
90%install
91rm -rf %{buildroot}
92%{__make} DESTDIR=%{buildroot} install
93install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
94install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
95
96%if %{with systemd}
97mkdir -p %{buildroot}%{_unitdir}
98install -m 0644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_unitdir}
99mkdir -p %{buildroot}%{_tmpfilesdir}
100install -m 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/nsd.conf
101%else
102install -d -m 0755 %{buildroot}%{_initrddir}
103install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
104install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
105install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
106%endif
107
108# change .sample to normal config files
109mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
110sed -i \
111        -e 's/# database:.*$/database: ""/' \
112        -e 's/# round-robin:.*$/round-robin: yes/' \
113        -e 's/# minimal-responses:.*$/minimal-responses: yes/' \
114        -e 's/# refuse-any:.*$/refuse-any: yes/' \
115        -e 's/# control-enable:.*$/control-enable: yes/' \
116        -e 's|# control-interface: ::1|control-interface: %{piddir}/nsd.ctl|' \
117        %{buildroot}%{_sysconfdir}/nsd/nsd.conf
118
119
120%clean
121rm -rf ${RPM_BUILD_ROOT}
122
123
124%files
125%defattr(-,root,root,-)
126%doc doc/*
127%doc contrib/nsd.zones2nsd.conf
128%dir %{_sysconfdir}/nsd/
129%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
130#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
131%if %{with systemd}
132%attr(0644,root,root) %{_unitdir}/nsd.service
133%attr(0644,root,root) %{_unitdir}/nsd-keygen.service
134%attr(0644,root,root) %{_tmpfilesdir}/nsd.conf
135%else
136%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
137%attr(0755,root,root) %{_initrddir}/%{name}
138%endif
139%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
140%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
141%{_sbindir}/*
142%{_mandir}/*/*
143
144
145%pre
146getent group nsd >/dev/null || groupadd -r nsd
147getent passwd nsd >/dev/null || \
148useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
149-c "nsd daemon account" nsd
150exit 0
151
152%post
153chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
154chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
155%if %{with systemd}
156%systemd_post nsd.service
157%systemd_post nsd-keygen.service
158%else
159/sbin/chkconfig --add %{name}
160if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
161  /usr/sbin/nsd-control-setup
162fi
163%endif
164
165%preun
166%if %{with systemd}
167%systemd_preun nsd.service
168%systemd_preun nsd-keygen.service
169%else
170if [ $1 -eq 0 -o -x /bin/systemctl ]; then
171        /sbin/service %{name} stop
172        /sbin/chkconfig --del %{name}
173fi
174%endif
175
176%postun
177%if %{with systemd}
178%systemd_postun_with_restart nsd.service
179%systemd_postun nsd-keygen.service
180%else
181if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
182  /sbin/service %{name} condrestart
183fi
184%endif
185
186%changelog
187* Tue Jan 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.5-1
188- new upstream release.
189
190* Wed Dec 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.4-1
191- new upstream release.
192
193* Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.3-1
194- new upstream release.
195
196* Wed Jul 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.2-1
197- new upstream release.
198
199* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.1-1
200- new upstream release.
201
202* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-3
203- rebuilt with libevent-2.1.11.
204
205* Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-2
206- fixed nsd-keygen.service.
207- updated nsd.conf.
208
209* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
210- new upstream release.
211- dropped Patch0.
212- added systemd support (disabled as default).
213
214* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
215- new upstream release.
216
217* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
218- new upstream release.
219
220* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
221- new upstream release.
222- rebuilt with openssl-1.1.1 and libevent-2.1.8.
223
224* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
225- new upstream release.
226
227* Wed Mar  8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
228- new upstream release.
229
230* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
231- new upstream release.
232
233* Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
234- new upstream release.
235
236* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
237- rebuilt with openssl-1.0.2g.
238
239* Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
240- new upstream release.
241
242* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
243- new upstream release.
244
245* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
246- new upstream release.
247
248* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
249- new upstream release.
250- dropped Source2 (no longer needed).
251
252* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
253- new upstream release
254
255* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
256- new upstream release
257
258* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
259- new upstream release
260
261* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
262- new upstream release
263
264* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
265- initial build for Vine Linux
266
267* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
268- Updated to nsd 3.2.4
269
270* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
271- Incorporated Ville Mattila's fixes  to nsd.cron
272- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
273
274* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
275- rebuilt with new openssl
276
277* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
278- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
279
280* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
281-Updated to version 3.2.3
282
283* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
285
286* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
287- Fixed /dev/nul which cause a file \%%1 to be written by cron
288- Bump for EVR.
289
290* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
291- Upgraded to 3.2.2 security release
292  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
293
294* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
295- Make various file paths used by the nsd.init script configurable
296  from /etc/sysconfig/nsd.
297- Add template /etc/sysconfig/nsd.
298
299* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
300- nsd used the 'named' subsystem in one call in the init script
301
302* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
303- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
304
305* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
306- Fix init script 'unary operator' error.
307
308* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
309- Updated to new version 3.2.1
310
311* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
312- rebuild with new openssl
313
314* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
315- Updates summary as per Richard Hughes guidelines
316
317* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
318- Bump version after pre-release version correction.
319
320* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
321- 3.2.0-1
322
323* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
324- updated to 3.1.1
325
326* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
327- fix license tag
328- fix static user creation
329
330* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
331- Updated to 3.1.0
332
333* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
334- Fix /dev/null redirection [Venkatesh Krishnamurthi]
335
336* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
337- Updated to 3.0.8
338
339* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
340- Autorebuild for GCC 4.3
341
342* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
343- Rebuild for new libcrypto
344
345* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
346- Updated to new version
347- fix RELNOTES/README to be utf8
348- Fix path to nsd.db in cron job.
349
350* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
351- Modified cron to only rebuild/reload when zone updates
352  have been received
353
354* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
355- Added hourly cron job to do various maintenance tasks
356- Added nsd rebuild to create the proper nsd.db file on startup
357- Added nsd patch on shutdown to ensure zonefiles are up to date
358
359* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
360- nsdc update and nsdc notify are no longer needed in initscript.
361
362* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
363- Bump release for upgrade path.
364
365* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
366- Do not include examples from nsd.conf.sample that causes
367  bogus network traffic.
368
369* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
370- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
371- Enable NSEC3
372- Delay running nsdc update until after nsd has started
373- Delete xfrd.state on nsd stop
374- Run nsdc notify in the background, since it can take
375  a very long time when remote servers are unavailable.
376
377* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
378- Upgraded to 3.0.6
379- Do not include bind2nsd, since it didn't compile for me
380
381* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
382- Fix init script, bug #245546
383
384* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
385- Upgraded to 3.0.5
386
387* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
388- Upgraded to 3.0.3
389
390* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
391- Upgraded to 3.0.2.
392- Use new configuration file nsd.conf. Still needs migration script.
393  patch from Farkas Levente <lfarkas@bppiac.hu>
394
395* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
396- Bump version for upgrade path
397
398* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
399- Upgraded to 2.3.6
400- Removed obsolete workaround in nsd.init
401- Fixed spec file so daemon gets properly restarted on upgrade
402
403* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
404- Rebuild requested for PT_GNU_HASH support from gcc
405- Removed dbaccess.c from doc section
406
407* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
408- Bump version for FC-x upgrade path
409
410* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
411- Upgraded to nsd-2.3.5
412
413* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
414- Upgraded to nsd-2.3.4.
415- Removed manual install targets because DESTDIR is now supported
416- Re-enabled --checking, checking patch no longer needed and removed.
417- Work around in nsd.init for nsd failing to start when there is no ipv6
418
419* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
420- chkconfig and attribute  changes as proposed by Dmitry Butskoy
421
422* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
423- Moved pid file to /var/run/nsd/nsd.pid.
424- Use _localstatedir instead of "/var"
425
426* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
427- Added BuildRequires for openssl-devel, removed Requires for openssl.
428
429* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
430- upgraded to nsd-2.3.3
431
432* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
433- minor cleanups
434
435* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
436- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
437  Extras policies (eg do not start daemon on fresh install)
438
439* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
440- Initial version
Note: See TracBrowser for help on using the repository browser.