source: projects/specs/trunk/n/notification-daemon/notification-daemon-vl.spec @ 3585

Revision 3585, 8.5 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define gtk2_version            2.10.0
2%define glib2_version           2.8.0
3%define dbus_version            0.60
4%define libnotify_version       0.4.0
5
6Summary: Notification Daemon
7Name: notification-daemon
8Version: 0.4.0
9Release: 9%{?_dist_release}
10URL: http://www.galago-project.org/specs/notification/
11License: GPL
12Group: System Environment/Libraries
13
14Source0: %{name}-%{version}.tar.bz2
15Source1: notification-daemon-0.4.0-ja.po
16Patch1:  notification-daemon-0.4.0-ja.patch
17
18# patches from ubuntu
19Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
20Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
21Patch105: notification-daemon-0.4.0-spacing.patch
22Patch107: notification-daemon-0.4.0-memleak-daemon.patch
23Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
24
25# vine theme (based on coco) and vine5 theme (old theme)
26# http://github.com/tatofoo/notification-daemon-engine-coco
27Source200: notification-daemon-engine-vine.tar.bz2
28
29# Vine patch
30# use gvfs-open instead of gnome-open
31Patch300: notification-daemon-0.4.0-browser.patch
32# dirty hack to change notification bubble position.
33Patch310: notification-daemon-0.4.0-position.patch
34# add vine and vine5 theme
35Patch320: notification-daemon-0.4.0-vine-theme.patch
36# change default to slider
37Patch330: notification-daemon-0.4.0-default-theme.patch
38# change default notify location to TOP_RIGHT
39Patch340: notification-daemon-0.4.0-location.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42Requires: dbus >= %{dbus_version}
43Requires: dbus-glib >= %{dbus_version}
44Requires(post): GConf2
45BuildRequires: glib2-devel >= %{glib2_version}
46BuildRequires: dbus-devel >= %{dbus_version}
47BuildRequires: dbus-glib-devel >= %{dbus_version}
48BuildRequires: libnotify-devel >= %{libnotify_version}
49BuildRequires: libsexy-devel
50BuildRequires: libwnck-devel
51BuildRequires: GConf2-devel
52BuildRequires: libglade2-devel
53BuildRequires: gstreamer-devel
54BuildRequires: desktop-file-utils
55
56%description
57notification-daemon is the server implementation of the freedesktop.org
58desktop notification specification. 
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: daisuke
63
64%prep
65%setup -q -a 200
66
67%patch1 -p1 -b .ja
68
69%patch103 -p1
70%patch104 -p1
71%patch105 -p0
72%patch107 -p1
73%patch109 -p1
74
75%patch300 -p1
76%patch310 -p1
77%patch320 -p1
78%patch330 -p1
79%patch340 -p1
80
81
82# install japanese message catalog
83%{__cp} %{SOURCE1} po/ja.po
84
85%build
86autoreconf -f -i
87%configure --disable-schemas-install
88make %{?_smp_mflags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92%{__make} install DESTDIR=$RPM_BUILD_ROOT
93
94%find_lang %name
95
96# remove unpackaged files
97rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
98
99# install desktop file
100desktop-file-install --delete-original  \
101        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
102        --add-category DesktopSettings \
103        ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
104
105
106%pre
107if [ "$1" -gt 1 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
111fi
112
113%post
114export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
115gconftool-2 --makefile-install-rule \
116  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
117
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
120    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
121fi
122
123%preun
124if [ "$1" -eq 0 ]; then
125    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
126    gconftool-2 --makefile-uninstall-rule \
127      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
128fi
129
130%postun
131touch --no-create %{_datadir}/icons/hicolor
132if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
133    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
134fi
135
136
137%clean
138rm -rf %{buildroot}
139
140
141%files -f %{name}.lang
142%defattr(-,root,root)
143%doc COPYING ChangeLog NEWS
144%{_bindir}/notification-properties
145%{_sysconfdir}/gconf/schemas/%{name}.schemas
146%dir %{_libdir}/notification-daemon-1.0
147%dir %{_libdir}/notification-daemon-1.0/engines
148%{_libdir}/notification-daemon-1.0/engines/*.so
149%{_libexecdir}/notification-daemon
150%{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
151%{_datadir}/applications/notification-properties.desktop
152%{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
153%{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
154%{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
155%{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
156%{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
157%{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
158%{_datadir}/notification-daemon/notification-properties.glade
159
160%changelog
161* Wed Apr 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-9
162- add BuildRequires: gstreamer-devel, desktop-file-utils
163
164* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-8
165- add missing BuildRequires: GConf2-devel, libglade2-devel
166
167* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
168- rebuilt with rpm-4.8.1-3
169
170* Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
171- update Source201
172
173* Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
174- rebuild with new toolchain
175- update Source201 (add modified coco theme as new default)
176- add patch300 to use gvfs-open instead of gnome-open
177- add patch310 to change notification bubble position
178- add patch320 to add new vine theme
179- add patch340 to change default notification localtion to top_right.
180- add BR: libwnck-devel
181
182* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
183- add Categories=DesktopSettings for notification-properties.desktop
184
185* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
186- add Source200, Patch200,201
187  - add vine theme engine based on ubuntu engine.
188
189- add patch101-109 from ubuntu
190  - Patch103: fix xinerama stack
191  - Patch104: dont crash on critical warnings
192  - Patch105: fix notification spacing
193  - Patch107: fix memleak
194  - Patch109: fix crash on theme changing
195
196* Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
197- add japanese translation (Source1 and Patch1)
198- prperly install/uninstall gconf schemas
199- update gtk icon cache with %%post, %%postun
200
201* Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
202- new upstream release
203- change required gtk2 version to 2.10.0
204
205* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
206- applied new versioning policy
207
208* Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
209- rebuilt with libwnck 2.20.2
210
211* Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
212- new upstream release
213- rebuilt with libsexy 0.1.10
214- added BuildRequores: libsexy-devel
215
216* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
217- new upstream release
218
219* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
220- initial build for Vine Linux partialy based on FC package.
221
222* Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
223- Add patch to fix struct handling in the dbus glib binding for dbus 0.61
224  so image data works again
225
226* Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
227- BuildRequires love, for all you lovers out there.
228
229* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
230- bump again for double-long bug on ppc(64)
231
232* Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
233- remove empty scripts from .spec file
234
235* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
236- rebuilt for new gcc4.1 snapshot and glibc changes
237
238* Fri Feb  3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
239- Add patch to determine whether a compositing manager is running
240  when drawing a new notification bubble, as long as the CM grabs
241  the appropriate XSelection.
242
243* Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
244- Make it so that marked-up messages appear with markup
245
246* Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
247- Provide desktop-notification-daemon, since libnotify requires a
248  notification deamon, but not this specific one.  Other notification
249  daemons can exist on the system so long as they meet the provides
250  (and the API of course).
251
252* Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
253- Fix positioning of the notification bubble to not draw off-screen
254
255* Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
256- Actuall release of 0.3.1
257
258* Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
259- Upgrade to upstream 0.3.1
260
261* Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
262- inital build
Note: See TracBrowser for help on using the repository browser.