source: projects/specs/trunk/n/notification-daemon/notification-daemon-vl.spec @ 3572

Revision 3572, 8.3 KB checked in by shaolin, 13 years ago (diff)
  • notification-daemon: add missing BuildRequires?: GConf2-devel, libglade2-devel
Line 
1%define gtk2_version            2.10.0
2%define glib2_version           2.8.0
3%define dbus_version            0.60
4%define libnotify_version       0.4.0
5
6Summary: Notification Daemon
7Name: notification-daemon
8Version: 0.4.0
9Release: 8%{?_dist_release}
10URL: http://www.galago-project.org/specs/notification/
11License: GPL
12Group: System Environment/Libraries
13
14Source0: %{name}-%{version}.tar.bz2
15Source1: notification-daemon-0.4.0-ja.po
16Patch1:  notification-daemon-0.4.0-ja.patch
17
18# patches from ubuntu
19Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
20Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
21Patch105: notification-daemon-0.4.0-spacing.patch
22Patch107: notification-daemon-0.4.0-memleak-daemon.patch
23Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
24
25# vine theme (based on coco) and vine5 theme (old theme)
26# http://github.com/tatofoo/notification-daemon-engine-coco
27Source200: notification-daemon-engine-vine.tar.bz2
28
29# Vine patch
30# use gvfs-open instead of gnome-open
31Patch300: notification-daemon-0.4.0-browser.patch
32# dirty hack to change notification bubble position.
33Patch310: notification-daemon-0.4.0-position.patch
34# add vine and vine5 theme
35Patch320: notification-daemon-0.4.0-vine-theme.patch
36# change default to slider
37Patch330: notification-daemon-0.4.0-default-theme.patch
38# change default notify location to TOP_RIGHT
39Patch340: notification-daemon-0.4.0-location.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42Requires: dbus >= %{dbus_version}
43Requires: dbus-glib >= %{dbus_version}
44Requires(post): GConf2
45BuildRequires: glib2-devel >= %{glib2_version}
46BuildRequires: dbus-devel >= %{dbus_version}
47BuildRequires: dbus-glib-devel >= %{dbus_version}
48BuildRequires: libnotify-devel >= %{libnotify_version}
49BuildRequires: libsexy-devel
50BuildRequires: libwnck-devel
51BuildRequires: GConf2-devel
52BuildRequires: libglade2-devel
53
54%description
55notification-daemon is the server implementation of the freedesktop.org
56desktop notification specification. 
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%prep
63%setup -q -a 200
64
65%patch1 -p1 -b .ja
66
67%patch103 -p1
68%patch104 -p1
69%patch105 -p0
70%patch107 -p1
71%patch109 -p1
72
73%patch300 -p1
74%patch310 -p1
75%patch320 -p1
76%patch330 -p1
77%patch340 -p1
78
79
80# install japanese message catalog
81%{__cp} %{SOURCE1} po/ja.po
82
83%build
84autoreconf -f -i
85%configure --disable-schemas-install
86make %{?_smp_mflags}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%{__make} install DESTDIR=$RPM_BUILD_ROOT
91
92%find_lang %name
93
94# remove unpackaged files
95rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
96
97# install desktop file
98desktop-file-install --delete-original  \
99        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
100        --add-category DesktopSettings \
101        ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
102
103
104%pre
105if [ "$1" -gt 1 ]; then
106    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107    gconftool-2 --makefile-uninstall-rule \
108      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
109fi
110
111%post
112export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113gconftool-2 --makefile-install-rule \
114  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
115
116touch --no-create %{_datadir}/icons/hicolor
117if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
118    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
119fi
120
121%preun
122if [ "$1" -eq 0 ]; then
123    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
124    gconftool-2 --makefile-uninstall-rule \
125      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
126fi
127
128%postun
129touch --no-create %{_datadir}/icons/hicolor
130if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
131    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
132fi
133
134
135%clean
136rm -rf %{buildroot}
137
138
139%files -f %{name}.lang
140%defattr(-,root,root)
141%doc COPYING ChangeLog NEWS
142%{_bindir}/notification-properties
143%{_sysconfdir}/gconf/schemas/%{name}.schemas
144%dir %{_libdir}/notification-daemon-1.0
145%dir %{_libdir}/notification-daemon-1.0/engines
146%{_libdir}/notification-daemon-1.0/engines/*.so
147%{_libexecdir}/notification-daemon
148%{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
149%{_datadir}/applications/notification-properties.desktop
150%{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
151%{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
152%{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
153%{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
154%{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
155%{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
156%{_datadir}/notification-daemon/notification-properties.glade
157
158%changelog
159* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-8
160- add missing BuildRequires: GConf2-devel, libglade2-devel
161
162* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
163- rebuilt with rpm-4.8.1-3
164
165* Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
166- update Source201
167
168* Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
169- rebuild with new toolchain
170- update Source201 (add modified coco theme as new default)
171- add patch300 to use gvfs-open instead of gnome-open
172- add patch310 to change notification bubble position
173- add patch320 to add new vine theme
174- add patch340 to change default notification localtion to top_right.
175- add BR: libwnck-devel
176
177* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
178- add Categories=DesktopSettings for notification-properties.desktop
179
180* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
181- add Source200, Patch200,201
182  - add vine theme engine based on ubuntu engine.
183
184- add patch101-109 from ubuntu
185  - Patch103: fix xinerama stack
186  - Patch104: dont crash on critical warnings
187  - Patch105: fix notification spacing
188  - Patch107: fix memleak
189  - Patch109: fix crash on theme changing
190
191* Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
192- add japanese translation (Source1 and Patch1)
193- prperly install/uninstall gconf schemas
194- update gtk icon cache with %%post, %%postun
195
196* Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
197- new upstream release
198- change required gtk2 version to 2.10.0
199
200* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
201- applied new versioning policy
202
203* Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
204- rebuilt with libwnck 2.20.2
205
206* Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
207- new upstream release
208- rebuilt with libsexy 0.1.10
209- added BuildRequores: libsexy-devel
210
211* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
212- new upstream release
213
214* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
215- initial build for Vine Linux partialy based on FC package.
216
217* Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
218- Add patch to fix struct handling in the dbus glib binding for dbus 0.61
219  so image data works again
220
221* Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
222- BuildRequires love, for all you lovers out there.
223
224* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
225- bump again for double-long bug on ppc(64)
226
227* Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
228- remove empty scripts from .spec file
229
230* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
231- rebuilt for new gcc4.1 snapshot and glibc changes
232
233* Fri Feb  3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
234- Add patch to determine whether a compositing manager is running
235  when drawing a new notification bubble, as long as the CM grabs
236  the appropriate XSelection.
237
238* Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
239- Make it so that marked-up messages appear with markup
240
241* Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
242- Provide desktop-notification-daemon, since libnotify requires a
243  notification deamon, but not this specific one.  Other notification
244  daemons can exist on the system so long as they meet the provides
245  (and the API of course).
246
247* Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
248- Fix positioning of the notification bubble to not draw off-screen
249
250* Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
251- Actuall release of 0.3.1
252
253* Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
254- Upgrade to upstream 0.3.1
255
256* Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
257- inital build
Note: See TracBrowser for help on using the repository browser.