source: projects/specs/trunk/n/notification-daemon/notification-daemon-vl.spec @ 3534

Revision 3534, 8.1 KB checked in by owa, 13 years ago (diff)

rebuit

Line 
1%define gtk2_version            2.10.0
2%define glib2_version           2.8.0
3%define dbus_version            0.60
4%define libnotify_version       0.4.0
5
6Summary: Notification Daemon
7Name: notification-daemon
8Version: 0.4.0
9Release: 7%{?_dist_release}
10URL: http://www.galago-project.org/specs/notification/
11License: GPL
12Group: System Environment/Libraries
13
14Source0: %{name}-%{version}.tar.bz2
15Source1: notification-daemon-0.4.0-ja.po
16Patch1:  notification-daemon-0.4.0-ja.patch
17
18# patches from ubuntu
19Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
20Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
21Patch105: notification-daemon-0.4.0-spacing.patch
22Patch107: notification-daemon-0.4.0-memleak-daemon.patch
23Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
24
25# vine theme (based on coco) and vine5 theme (old theme)
26# http://github.com/tatofoo/notification-daemon-engine-coco
27Source200: notification-daemon-engine-vine.tar.bz2
28
29# Vine patch
30# use gvfs-open instead of gnome-open
31Patch300: notification-daemon-0.4.0-browser.patch
32# dirty hack to change notification bubble position.
33Patch310: notification-daemon-0.4.0-position.patch
34# add vine and vine5 theme
35Patch320: notification-daemon-0.4.0-vine-theme.patch
36# change default to slider
37Patch330: notification-daemon-0.4.0-default-theme.patch
38# change default notify location to TOP_RIGHT
39Patch340: notification-daemon-0.4.0-location.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42Requires: dbus >= %{dbus_version}
43Requires: dbus-glib >= %{dbus_version}
44Requires(post): GConf2
45BuildRequires: glib2-devel >= %{glib2_version}
46BuildRequires: dbus-devel >= %{dbus_version}
47BuildRequires: dbus-glib-devel >= %{dbus_version}
48BuildRequires: libnotify-devel >= %{libnotify_version}
49BuildRequires: libsexy-devel
50BuildRequires: libwnck-devel
51
52%description
53notification-daemon is the server implementation of the freedesktop.org
54desktop notification specification. 
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%prep
61%setup -q -a 200
62
63%patch1 -p1 -b .ja
64
65%patch103 -p1
66%patch104 -p1
67%patch105 -p0
68%patch107 -p1
69%patch109 -p1
70
71%patch300 -p1
72%patch310 -p1
73%patch320 -p1
74%patch330 -p1
75%patch340 -p1
76
77
78# install japanese message catalog
79%{__cp} %{SOURCE1} po/ja.po
80
81%build
82autoreconf -f -i
83%configure --disable-schemas-install
84make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88%{__make} install DESTDIR=$RPM_BUILD_ROOT
89
90%find_lang %name
91
92# remove unpackaged files
93rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
94
95# install desktop file
96desktop-file-install --delete-original  \
97        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
98        --add-category DesktopSettings \
99        ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
100
101
102%pre
103if [ "$1" -gt 1 ]; then
104    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105    gconftool-2 --makefile-uninstall-rule \
106      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
107fi
108
109%post
110export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111gconftool-2 --makefile-install-rule \
112  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
113
114touch --no-create %{_datadir}/icons/hicolor
115if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
116    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
117fi
118
119%preun
120if [ "$1" -eq 0 ]; then
121    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
122    gconftool-2 --makefile-uninstall-rule \
123      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
124fi
125
126%postun
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
129    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132
133%clean
134rm -rf %{buildroot}
135
136
137%files -f %{name}.lang
138%defattr(-,root,root)
139%doc COPYING ChangeLog NEWS
140%{_bindir}/notification-properties
141%{_sysconfdir}/gconf/schemas/%{name}.schemas
142%dir %{_libdir}/notification-daemon-1.0
143%dir %{_libdir}/notification-daemon-1.0/engines
144%{_libdir}/notification-daemon-1.0/engines/*.so
145%{_libexecdir}/notification-daemon
146%{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
147%{_datadir}/applications/notification-properties.desktop
148%{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
149%{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
150%{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
151%{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
152%{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
153%{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
154%{_datadir}/notification-daemon/notification-properties.glade
155
156%changelog
157* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
158- rebuilt with rpm-4.8.1-3
159
160* Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
161- update Source201
162
163* Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
164- rebuild with new toolchain
165- update Source201 (add modified coco theme as new default)
166- add patch300 to use gvfs-open instead of gnome-open
167- add patch310 to change notification bubble position
168- add patch320 to add new vine theme
169- add patch340 to change default notification localtion to top_right.
170- add BR: libwnck-devel
171
172* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
173- add Categories=DesktopSettings for notification-properties.desktop
174
175* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
176- add Source200, Patch200,201
177  - add vine theme engine based on ubuntu engine.
178
179- add patch101-109 from ubuntu
180  - Patch103: fix xinerama stack
181  - Patch104: dont crash on critical warnings
182  - Patch105: fix notification spacing
183  - Patch107: fix memleak
184  - Patch109: fix crash on theme changing
185
186* Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
187- add japanese translation (Source1 and Patch1)
188- prperly install/uninstall gconf schemas
189- update gtk icon cache with %%post, %%postun
190
191* Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
192- new upstream release
193- change required gtk2 version to 2.10.0
194
195* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
196- applied new versioning policy
197
198* Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
199- rebuilt with libwnck 2.20.2
200
201* Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
202- new upstream release
203- rebuilt with libsexy 0.1.10
204- added BuildRequores: libsexy-devel
205
206* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
207- new upstream release
208
209* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
210- initial build for Vine Linux partialy based on FC package.
211
212* Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
213- Add patch to fix struct handling in the dbus glib binding for dbus 0.61
214  so image data works again
215
216* Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
217- BuildRequires love, for all you lovers out there.
218
219* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
220- bump again for double-long bug on ppc(64)
221
222* Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
223- remove empty scripts from .spec file
224
225* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
226- rebuilt for new gcc4.1 snapshot and glibc changes
227
228* Fri Feb  3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
229- Add patch to determine whether a compositing manager is running
230  when drawing a new notification bubble, as long as the CM grabs
231  the appropriate XSelection.
232
233* Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
234- Make it so that marked-up messages appear with markup
235
236* Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
237- Provide desktop-notification-daemon, since libnotify requires a
238  notification deamon, but not this specific one.  Other notification
239  daemons can exist on the system so long as they meet the provides
240  (and the API of course).
241
242* Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
243- Fix positioning of the notification bubble to not draw off-screen
244
245* Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
246- Actuall release of 0.3.1
247
248* Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
249- Upgrade to upstream 0.3.1
250
251* Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
252- inital build
Note: See TracBrowser for help on using the repository browser.