source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 8914

Revision 8914, 8.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 6.47
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
71gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
72pushd $RPM_BUILD_ROOT%{_mandir}/man1
73ln -s zenmap.1.gz nmapfe.1.gz
74ln -s zenmap.1.gz xnmap.1.gz
75popd
76
77#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
78#mkdir zenmap
79#mv *.svg zenmap
80#mv *.png zenmap
81#popd
82
83#desktop-file-install --vendor= \
84#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
85#       %{SOURCE1};
86rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
87
88%find_lang %{name} --with-man
89
90%clean
91rm -rf %{buildroot}
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc COPYING CHANGELOG
96%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
97%{_bindir}/nmap
98%{_bindir}/ncat
99%{_bindir}/ndiff
100%{_bindir}/nping
101%{_datadir}/nmap
102%{_datadir}/ncat
103#%{_libexecdir}/nmap
104%{_mandir}/man1/nmap.1*
105%{_mandir}/man1/ncat.1*
106%{_mandir}/man1/ndiff.1*
107%{_mandir}/man1/nping.1*
108
109%files frontend
110%defattr(-,root,root)
111%{_bindir}/nmapfe
112%{_bindir}/xnmap
113%{_bindir}/zenmap
114%{python_sitelib}/*
115%{_datadir}/applications/*.desktop
116#%{_datadir}/icons/*
117#%{_datadir}/pixmaps/zenmap
118%{_datadir}/zenmap
119%{_mandir}/man1/zenmap.1*
120%{_mandir}/man1/nmapfe.1*
121%{_mandir}/man1/xnmap.1*
122
123%changelog
124* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
125- new upstream release
126
127* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
128- new upstream release
129
130* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
131- rebuild with pcre-8.31
132
133* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
134- new upstream release
135
136* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
137- new upstream release
138
139* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
140- new upstream release
141
142* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
143- new upstream release
144- fix %files to add nping
145
146* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
147- new upstream release
148- add BuildRequires: openssl-devel, lua-devel
149- fix %files to add ncat and ndiff
150
151* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
152- new upstream release
153- spec in UTF-8
154- added BuildRequires: libpcap-devel instead of libpcap
155- removed BuildRequires: desktop-file-utils
156
157* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
158- rebuilt with libpcap 1.0.0
159
160* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
161- rebuilt with python-2.5.2
162
163* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
164- updated python sitelib files path
165
166* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
167- new upstream release
168
169* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
170- new upstream release
171- rebuild with new environment/toolchain
172
173* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
174- new upstream release
175- added BuildRequires: desktop-file-utils
176
177* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
178- new upstream release
179
180* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
181- rebuild for VineSeed Plus
182
183* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
184- new upstream release
185
186* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
187- new upstream release
188
189* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
190- new upstream release
191- added Japanese summary to nmap-frontend
192
193* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
194- new upstream release
195
196* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
197- rebuild with new openssl
198
199* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
200- new upstream release
201
202* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
203- new upstream release
204
205* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
206- new upstream release
207
208* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
209- new upstream release
210
211* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
212- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
213
214* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
215- new upstream release
216- rebuild with new toolchains
217
218* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
219- new upstream release
220- delete Version Tag from nmap-frontend package
221- fix BuildRoot
222
223* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
224- new upstream release
225- 2.54BETA is developpment release, but it is more stable than 2.53.
226
227* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
228- unfortunately increase release: 1vl2 from 0vl2
229  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
230- patch to build on current glibc22 system
231
232* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
233- 2.53-0vl2: use better macros
234
235* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
236- rebuild for VineSeed based on the original site's srpm
237- add Japanese summary and description
238
239* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
240- Updated description
241- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
242- Fixed nmap distribution URL (source0)
243- Added this .rpm to base Nmap distribution
244
245* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
246- based on origional spec file from
247        http://www.insecure.org/nmap/index.html#download
248- general cleanups, removed lots of commenrts since it made the spec hard to
249        read
250- changed group to Applications/System
251- quiet setup
252- no need to create dirs in the install section, "make
253        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
254- using defined %{prefix}, %{version} etc. for easier/quicker maint.
255- added docs
256- gzip man pages
257- strip after files have been installed into buildroot
258- created separate package for the frontend so that Gtk+ isn't needed for the
259        CLI nmap
260- not using -f in files section anymore, no need for it since there aren't that
261        many files/dirs
262- added desktop entry for gnome
263
264* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
265- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
266
267* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
268- Made some changes, and merged in another .spec file sent in
269  by Oren Tirosh <oren@hishome.net>
270
271* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
272- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.