source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 9876

Revision 9876, 8.7 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 7.01
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
71cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
72gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
73pushd $RPM_BUILD_ROOT%{_mandir}/man1
74ln -s zenmap.1.gz nmapfe.1.gz
75ln -s zenmap.1.gz xnmap.1.gz
76popd
77
78#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
79#mkdir zenmap
80#mv *.svg zenmap
81#mv *.png zenmap
82#popd
83
84#desktop-file-install --vendor= \
85#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
86#       %{SOURCE1};
87rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
88
89%find_lang %{name} --with-man
90
91%clean
92rm -rf %{buildroot}
93
94%files -f %{name}.lang
95%defattr(-,root,root)
96%doc COPYING CHANGELOG
97%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
98%{_bindir}/nmap
99%{_bindir}/ncat
100%{_bindir}/ndiff
101%{_bindir}/nping
102%{_datadir}/nmap
103%{_datadir}/ncat
104#%{_libexecdir}/nmap
105%{_mandir}/man1/nmap.1*
106%{_mandir}/man1/ncat.1*
107%{_mandir}/man1/ndiff.1*
108%{_mandir}/man1/nping.1*
109
110%files frontend
111%defattr(-,root,root)
112%{_bindir}/nmapfe
113%{_bindir}/xnmap
114%{_bindir}/zenmap
115%{python_sitelib}/*
116%{_datadir}/applications/*.desktop
117#%{_datadir}/icons/*
118#%{_datadir}/pixmaps/zenmap
119%{_datadir}/zenmap
120%{_mandir}/man1/zenmap.1*
121%{_mandir}/man1/nmapfe.1*
122%{_mandir}/man1/xnmap.1*
123
124%changelog
125* Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
126- new upstream release
127
128* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
129- new upstream release
130
131* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
132- new upstream release
133
134* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
135- rebuild with pcre-8.31
136
137* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
138- new upstream release
139
140* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
141- new upstream release
142
143* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
144- new upstream release
145
146* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
147- new upstream release
148- fix %files to add nping
149
150* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
151- new upstream release
152- add BuildRequires: openssl-devel, lua-devel
153- fix %files to add ncat and ndiff
154
155* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
156- new upstream release
157- spec in UTF-8
158- added BuildRequires: libpcap-devel instead of libpcap
159- removed BuildRequires: desktop-file-utils
160
161* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
162- rebuilt with libpcap 1.0.0
163
164* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
165- rebuilt with python-2.5.2
166
167* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
168- updated python sitelib files path
169
170* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
171- new upstream release
172
173* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
174- new upstream release
175- rebuild with new environment/toolchain
176
177* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
178- new upstream release
179- added BuildRequires: desktop-file-utils
180
181* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
182- new upstream release
183
184* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
185- rebuild for VineSeed Plus
186
187* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
188- new upstream release
189
190* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
191- new upstream release
192
193* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
194- new upstream release
195- added Japanese summary to nmap-frontend
196
197* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
198- new upstream release
199
200* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
201- rebuild with new openssl
202
203* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
204- new upstream release
205
206* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
207- new upstream release
208
209* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
210- new upstream release
211
212* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
213- new upstream release
214
215* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
216- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
217
218* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
219- new upstream release
220- rebuild with new toolchains
221
222* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
223- new upstream release
224- delete Version Tag from nmap-frontend package
225- fix BuildRoot
226
227* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
228- new upstream release
229- 2.54BETA is developpment release, but it is more stable than 2.53.
230
231* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
232- unfortunately increase release: 1vl2 from 0vl2
233  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
234- patch to build on current glibc22 system
235
236* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
237- 2.53-0vl2: use better macros
238
239* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
240- rebuild for VineSeed based on the original site's srpm
241- add Japanese summary and description
242
243* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
244- Updated description
245- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
246- Fixed nmap distribution URL (source0)
247- Added this .rpm to base Nmap distribution
248
249* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
250- based on origional spec file from
251        http://www.insecure.org/nmap/index.html#download
252- general cleanups, removed lots of commenrts since it made the spec hard to
253        read
254- changed group to Applications/System
255- quiet setup
256- no need to create dirs in the install section, "make
257        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
258- using defined %{prefix}, %{version} etc. for easier/quicker maint.
259- added docs
260- gzip man pages
261- strip after files have been installed into buildroot
262- created separate package for the frontend so that Gtk+ isn't needed for the
263        CLI nmap
264- not using -f in files section anymore, no need for it since there aren't that
265        many files/dirs
266- added desktop entry for gnome
267
268* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
269- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
270
271* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
272- Made some changes, and merged in another .spec file sent in
273  by Oren Tirosh <oren@hishome.net>
274
275* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
276- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.