source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 5701

Revision 5701, 8.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 5.51
7Release: 2%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
71gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
72pushd $RPM_BUILD_ROOT%{_mandir}/man1
73ln -s zenmap.1.gz nmapfe.1.gz
74ln -s zenmap.1.gz xnmap.1.gz
75popd
76
77#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
78#mkdir zenmap
79#mv *.svg zenmap
80#mv *.png zenmap
81#popd
82
83#desktop-file-install --vendor= \
84#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
85#       %{SOURCE1};
86rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
87
88%find_lang %{name} --with-man
89
90%clean
91rm -rf %{buildroot}
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc COPYING COPYING.OpenSSL CHANGELOG
96%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
97%{_bindir}/nmap
98%{_bindir}/ncat
99%{_bindir}/ndiff
100%{_bindir}/nping
101%{_datadir}/nmap
102%{_datadir}/ncat
103#%{_libexecdir}/nmap
104%{_mandir}/man1/nmap.1*
105%{_mandir}/man1/ncat.1*
106%{_mandir}/man1/ndiff.1*
107%{_mandir}/man1/nping.1*
108
109%files frontend
110%defattr(-,root,root)
111%{_bindir}/nmapfe
112%{_bindir}/xnmap
113%{_bindir}/zenmap
114%{python_sitelib}/*
115%{_datadir}/applications/*.desktop
116#%{_datadir}/icons/*
117#%{_datadir}/pixmaps/zenmap
118%{_datadir}/zenmap
119%{_mandir}/man1/zenmap.1*
120%{_mandir}/man1/nmapfe.1*
121%{_mandir}/man1/xnmap.1*
122
123%changelog
124* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
125- new upstream release
126
127* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
128- new upstream release
129
130* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
131- new upstream release
132- fix %files to add nping
133
134* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
135- new upstream release
136- add BuildRequires: openssl-devel, lua-devel
137- fix %files to add ncat and ndiff
138
139* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
140- new upstream release
141- spec in UTF-8
142- added BuildRequires: libpcap-devel instead of libpcap
143- removed BuildRequires: desktop-file-utils
144
145* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
146- rebuilt with libpcap 1.0.0
147
148* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
149- rebuilt with python-2.5.2
150
151* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
152- updated python sitelib files path
153
154* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
155- new upstream release
156
157* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
158- new upstream release
159- rebuild with new environment/toolchain
160
161* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
162- new upstream release
163- added BuildRequires: desktop-file-utils
164
165* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
166- new upstream release
167
168* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
169- rebuild for VineSeed Plus
170
171* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
172- new upstream release
173
174* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
175- new upstream release
176
177* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
178- new upstream release
179- added Japanese summary to nmap-frontend
180
181* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
182- new upstream release
183
184* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
185- rebuild with new openssl
186
187* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
188- new upstream release
189
190* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
191- new upstream release
192
193* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
194- new upstream release
195
196* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
197- new upstream release
198
199* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
200- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
201
202* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
203- new upstream release
204- rebuild with new toolchains
205
206* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
207- new upstream release
208- delete Version Tag from nmap-frontend package
209- fix BuildRoot
210
211* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
212- new upstream release
213- 2.54BETA is developpment release, but it is more stable than 2.53.
214
215* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
216- unfortunately increase release: 1vl2 from 0vl2
217  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
218- patch to build on current glibc22 system
219
220* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
221- 2.53-0vl2: use better macros
222
223* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
224- rebuild for VineSeed based on the original site's srpm
225- add Japanese summary and description
226
227* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
228- Updated description
229- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
230- Fixed nmap distribution URL (source0)
231- Added this .rpm to base Nmap distribution
232
233* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
234- based on origional spec file from
235        http://www.insecure.org/nmap/index.html#download
236- general cleanups, removed lots of commenrts since it made the spec hard to
237        read
238- changed group to Applications/System
239- quiet setup
240- no need to create dirs in the install section, "make
241        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
242- using defined %{prefix}, %{version} etc. for easier/quicker maint.
243- added docs
244- gzip man pages
245- strip after files have been installed into buildroot
246- created separate package for the frontend so that Gtk+ isn't needed for the
247        CLI nmap
248- not using -f in files section anymore, no need for it since there aren't that
249        many files/dirs
250- added desktop entry for gnome
251
252* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
253- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
254
255* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
256- Made some changes, and merged in another .spec file sent in
257  by Oren Tirosh <oren@hishome.net>
258
259* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
260- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.