source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 6936

Revision 6936, 8.3 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-commander,gambas2: rebuild
others: new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 6.01
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
71gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
72pushd $RPM_BUILD_ROOT%{_mandir}/man1
73ln -s zenmap.1.gz nmapfe.1.gz
74ln -s zenmap.1.gz xnmap.1.gz
75popd
76
77#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
78#mkdir zenmap
79#mv *.svg zenmap
80#mv *.png zenmap
81#popd
82
83#desktop-file-install --vendor= \
84#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
85#       %{SOURCE1};
86rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
87
88%find_lang %{name} --with-man
89
90%clean
91rm -rf %{buildroot}
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc COPYING CHANGELOG
96%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
97%{_bindir}/nmap
98%{_bindir}/ncat
99%{_bindir}/ndiff
100%{_bindir}/nping
101%{_datadir}/nmap
102%{_datadir}/ncat
103#%{_libexecdir}/nmap
104%{_mandir}/man1/nmap.1*
105%{_mandir}/man1/ncat.1*
106%{_mandir}/man1/ndiff.1*
107%{_mandir}/man1/nping.1*
108
109%files frontend
110%defattr(-,root,root)
111%{_bindir}/nmapfe
112%{_bindir}/xnmap
113%{_bindir}/zenmap
114%{python_sitelib}/*
115%{_datadir}/applications/*.desktop
116#%{_datadir}/icons/*
117#%{_datadir}/pixmaps/zenmap
118%{_datadir}/zenmap
119%{_mandir}/man1/zenmap.1*
120%{_mandir}/man1/nmapfe.1*
121%{_mandir}/man1/xnmap.1*
122
123%changelog
124* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
125- new upstream release
126
127* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
128- new upstream release
129
130* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
131- new upstream release
132
133* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
134- new upstream release
135- fix %files to add nping
136
137* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
138- new upstream release
139- add BuildRequires: openssl-devel, lua-devel
140- fix %files to add ncat and ndiff
141
142* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
143- new upstream release
144- spec in UTF-8
145- added BuildRequires: libpcap-devel instead of libpcap
146- removed BuildRequires: desktop-file-utils
147
148* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
149- rebuilt with libpcap 1.0.0
150
151* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
152- rebuilt with python-2.5.2
153
154* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
155- updated python sitelib files path
156
157* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
158- new upstream release
159
160* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
161- new upstream release
162- rebuild with new environment/toolchain
163
164* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
165- new upstream release
166- added BuildRequires: desktop-file-utils
167
168* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
169- new upstream release
170
171* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
172- rebuild for VineSeed Plus
173
174* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
175- new upstream release
176
177* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
178- new upstream release
179
180* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
181- new upstream release
182- added Japanese summary to nmap-frontend
183
184* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
185- new upstream release
186
187* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
188- rebuild with new openssl
189
190* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
191- new upstream release
192
193* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
194- new upstream release
195
196* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
197- new upstream release
198
199* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
200- new upstream release
201
202* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
203- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
204
205* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
206- new upstream release
207- rebuild with new toolchains
208
209* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
210- new upstream release
211- delete Version Tag from nmap-frontend package
212- fix BuildRoot
213
214* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
215- new upstream release
216- 2.54BETA is developpment release, but it is more stable than 2.53.
217
218* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
219- unfortunately increase release: 1vl2 from 0vl2
220  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
221- patch to build on current glibc22 system
222
223* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
224- 2.53-0vl2: use better macros
225
226* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
227- rebuild for VineSeed based on the original site's srpm
228- add Japanese summary and description
229
230* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
231- Updated description
232- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
233- Fixed nmap distribution URL (source0)
234- Added this .rpm to base Nmap distribution
235
236* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
237- based on origional spec file from
238        http://www.insecure.org/nmap/index.html#download
239- general cleanups, removed lots of commenrts since it made the spec hard to
240        read
241- changed group to Applications/System
242- quiet setup
243- no need to create dirs in the install section, "make
244        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
245- using defined %{prefix}, %{version} etc. for easier/quicker maint.
246- added docs
247- gzip man pages
248- strip after files have been installed into buildroot
249- created separate package for the frontend so that Gtk+ isn't needed for the
250        CLI nmap
251- not using -f in files section anymore, no need for it since there aren't that
252        many files/dirs
253- added desktop entry for gnome
254
255* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
256- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
257
258* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
259- Made some changes, and merged in another .spec file sent in
260  by Oren Tirosh <oren@hishome.net>
261
262* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
263- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.