source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 12379

Revision 12379, 9.6 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

authconfig-7.0.1-2

nmap-7.80-1

php74-7.4.5-1

procps-3.3.16-1

rubygem-json-2.3.0-2

wget-1.20.3-1

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 7.80
7Release: 1%{?_dist_release}
8Group: Applications/System
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: GPL
13URL: https://nmap.org/
14Source0: https://nmap.org/dist/%{name}-%{version}.tar.bz2
15#Source1: zenmap.desktop
16
17# Patches from Fedora rawhide
18#prevent possible race condition for shtool, rhbz#158996
19Patch1: nmap-4.03-mktemp.patch
20
21#don't suggest to scan microsoft
22Patch2: nmap-4.52-noms.patch
23
24# upstream provided patch for rhbz#845005, not yet in upstream repository
25Patch5: ncat_reg_stdin.diff
26Patch6: nmap-6.25-displayerror.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: libpcap-devel
30BuildRequires: pcre-devel
31BuildRequires: python-devel
32BuildRequires: pygtk2-devel
33BuildRequires: openssl-devel
34BuildRequires: lua-devel
35
36%description
37Nmap is a utility for network exploration or security auditing. It
38supports ping scanning (determine which hosts are up), many port
39scanning techniques (determine what services the hosts are offering),
40and TCP/IP fingerprinting (remote host operating system
41identification). Nmap also offers flexible target and port
42specification, decoy scanning, determination of TCP sequence
43predictability characteristics, sunRPC scanning, reverse-identd
44scanning, and more.
45
46%description -l ja
47Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
48ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
49技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
50の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
51ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
52予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
53機能も提供します。
54
55%package frontend
56Summary: Gtk+ frontend for nmap
57Summary(ja): Nmap の GTK+ フロントエンド
58Group: Applications/System
59Requires: nmap = %{version}-%{release}
60Requires: python pygtk2 pysqlite
61Provides: zenmap = %{version}-%{release}
62
63%description frontend
64This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
65be installed before installing nmap-frontend.
66
67%description frontend -l ja
68Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
69する前に、nmap パッケージをインストールする必要があります。
70
71%prep
72%setup -q
73
74%patch1 -p1 -b .mktemp
75%patch2 -p1 -b .noms
76%patch5 -p1 -b .ncat_reg_stdin
77%patch6 -p1 -b .displayerror
78
79%build
80export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
81%configure
82make
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87
88rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
89rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
90cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
91gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
92pushd $RPM_BUILD_ROOT%{_mandir}/man1
93ln -s zenmap.1.gz nmapfe.1.gz
94ln -s zenmap.1.gz xnmap.1.gz
95popd
96
97#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
98#mkdir zenmap
99#mv *.svg zenmap
100#mv *.png zenmap
101#popd
102
103#desktop-file-install --vendor= \
104#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
105#       %{SOURCE1};
106rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
107
108%find_lang %{name} --with-man
109
110%clean
111rm -rf %{buildroot}
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%license COPYING
116%doc CHANGELOG README*
117%doc docs/nmap.usage.txt docs/nmap.dtd
118%{_bindir}/nmap
119%{_bindir}/ncat
120%{_bindir}/ndiff
121%{_bindir}/nping
122%{_datadir}/nmap
123%{_datadir}/ncat
124#%{_libexecdir}/nmap
125%{_mandir}/man1/nmap.1*
126%{_mandir}/man1/ncat.1*
127%{_mandir}/man1/ndiff.1*
128%{_mandir}/man1/nping.1*
129
130%files frontend
131%defattr(-,root,root)
132%{_bindir}/nmapfe
133%{_bindir}/xnmap
134%{_bindir}/zenmap
135%{python_sitelib}/*
136%{_datadir}/applications/*.desktop
137#%{_datadir}/icons/*
138#%{_datadir}/pixmaps/zenmap
139%{_datadir}/zenmap
140%{_mandir}/man1/zenmap.1*
141%{_mandir}/man1/nmapfe.1*
142%{_mandir}/man1/xnmap.1*
143
144%changelog
145* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.80-1
146- new upstream release.
147
148* Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 7.70-1
149- update to 7.70
150- add Patches from Fedora rawhide
151
152* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-2
153- rebuild with gcc-5.4.0
154
155* Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
156- new upstream release
157
158* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
159- new upstream release
160
161* Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
162- new upstream release
163
164* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
165- new upstream release
166
167* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
168- new upstream release
169
170* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
171- rebuild with pcre-8.31
172
173* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
174- new upstream release
175
176* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
177- new upstream release
178
179* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
180- new upstream release
181
182* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
183- new upstream release
184- fix %files to add nping
185
186* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
187- new upstream release
188- add BuildRequires: openssl-devel, lua-devel
189- fix %files to add ncat and ndiff
190
191* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
192- new upstream release
193- spec in UTF-8
194- added BuildRequires: libpcap-devel instead of libpcap
195- removed BuildRequires: desktop-file-utils
196
197* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
198- rebuilt with libpcap 1.0.0
199
200* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
201- rebuilt with python-2.5.2
202
203* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
204- updated python sitelib files path
205
206* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
207- new upstream release
208
209* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
210- new upstream release
211- rebuild with new environment/toolchain
212
213* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
214- new upstream release
215- added BuildRequires: desktop-file-utils
216
217* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
218- new upstream release
219
220* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
221- rebuild for VineSeed Plus
222
223* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
224- new upstream release
225
226* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
227- new upstream release
228
229* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
230- new upstream release
231- added Japanese summary to nmap-frontend
232
233* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
234- new upstream release
235
236* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
237- rebuild with new openssl
238
239* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
240- new upstream release
241
242* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
243- new upstream release
244
245* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
246- new upstream release
247
248* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
249- new upstream release
250
251* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
252- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
253
254* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
255- new upstream release
256- rebuild with new toolchains
257
258* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
259- new upstream release
260- delete Version Tag from nmap-frontend package
261- fix BuildRoot
262
263* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
264- new upstream release
265- 2.54BETA is developpment release, but it is more stable than 2.53.
266
267* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
268- unfortunately increase release: 1vl2 from 0vl2
269  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
270- patch to build on current glibc22 system
271
272* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
273- 2.53-0vl2: use better macros
274
275* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
276- rebuild for VineSeed based on the original site's srpm
277- add Japanese summary and description
278
279* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
280- Updated description
281- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
282- Fixed nmap distribution URL (source0)
283- Added this .rpm to base Nmap distribution
284
285* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
286- based on origional spec file from
287        http://www.insecure.org/nmap/index.html#download
288- general cleanups, removed lots of commenrts since it made the spec hard to
289        read
290- changed group to Applications/System
291- quiet setup
292- no need to create dirs in the install section, "make
293        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
294- using defined %{prefix}, %{version} etc. for easier/quicker maint.
295- added docs
296- gzip man pages
297- strip after files have been installed into buildroot
298- created separate package for the frontend so that Gtk+ isn't needed for the
299        CLI nmap
300- not using -f in files section anymore, no need for it since there aren't that
301        many files/dirs
302- added desktop entry for gnome
303
304* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
305- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
306
307* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
308- Made some changes, and merged in another .spec file sent in
309  by Oren Tirosh <oren@hishome.net>
310
311* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
312- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.