source: projects/specs/trunk/n/ninja/ninja-vl.spec @ 8558

Revision 8558, 4.1 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW PACKAGE

Line 
1#global githash 5dc55a3
2
3Name:           ninja
4Version:        1.4.0
5Release:        1%{?_dist_release}
6Group:          Development/Tools
7Summary:        A small build system with a focus on speed
8
9License:        ASL 2.0
10URL:            http://martine.github.com/ninja/
11#VCS:            git://github.com/martine/ninja.git
12# Snapshot from github
13# Downloaded from https://github.com/martine/ninja/tarball/%{githash}
14#Source0:        martine-ninja-%{githash}.tar.gz
15Source0:        https://github.com/martine/ninja/archive/v%{version}.tar.gz
16Source1:        ninja.vim
17
18BuildRequires:  asciidoc
19BuildRequires:  gtest-devel
20BuildRequires:  re2c
21Requires:       emacsen
22Requires:       vim
23
24%description
25Ninja is a small build system with a focus on speed. It differs from other
26build systems in two major respects: it is designed to have its input files
27generated by a higher-level build system, and it is designed to run builds as
28fast as possible.
29
30
31%prep
32%setup -q -n ninja-%{version}
33
34
35%build
36CFLAGS="%{optflags}"
37export CFLAGS
38./bootstrap.py --verbose -- --debug
39./ninja -v manual
40./ninja -v ninja_test
41
42
43%check
44# workaround possible too low default limits
45ulimit -n 2048
46ulimit -u 2048
47
48./ninja_test
49
50
51%install
52# TODO: Install ninja_syntax.py?
53install -p -m 755 -d %{buildroot}%{_bindir}
54install -p -m 755 ninja %{buildroot}%{_bindir}/ninja
55
56install -p -m 755 -d %{buildroot}%{_sysconfdir}/bash_completion.d
57install -p -m 644 misc/bash-completion %{buildroot}%{_sysconfdir}/bash_completion.d/ninja-bash-completion
58
59install -p -m 755 -d %{buildroot}%{_datadir}/emacs/site-lisp
60install -p -m 644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
61
62install -p -m 755 -d %{buildroot}%{_datadir}/vim/vimfiles/syntax
63install -p -m 644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
64install -p -m 755 -d %{buildroot}%{_datadir}/vim/vimfiles/ftdetect
65install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
66
67install -p -m 755 -d %{buildroot}%{_datadir}/zsh/site-functions
68install -p -m 644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
69
70
71%files
72%doc COPYING README doc/manual.html
73%{_bindir}/ninja
74# bash-completion does not own this
75%{_sysconfdir}/bash_completion.d/
76%{_datadir}/emacs/site-lisp/ninja-mode.el
77%{_datadir}/vim/vimfiles/syntax/ninja.vim
78%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
79# zsh does not have a -filesystem package
80%{_datadir}/zsh/
81
82
83%changelog
84* Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
85- initial build for Vine Linux
86
87
88* Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
89- Update to 1.4.0
90
91* Sun Nov  3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
92- Use special %%doc to install all docs (#994005).
93
94* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
96
97* Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
98- workaround possible too low limits for number of processes and open files,
99  fixes build on ppc/ppc64 and s390(x)
100
101* Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
102- Update to 1.3.4
103- Run test suite
104
105* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
107
108* Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
109- Update to 1.0.0
110
111* Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
112- Update to new snapshot
113
114* Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
115- Preserve timestamps on install
116- Install as ninja-build to avoid conflicts with the ninja IRC package
117- Update snapshot
118
119* Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
120- Add an ftdetect file for ninja
121- Fix zsh-stuff directory ownership
122
123* Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
124- Add a Group tag
125
126* Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
127- Update to new snapshot
128
129* Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
130- Initial package
Note: See TracBrowser for help on using the repository browser.