source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 6601

Revision 6601, 20.6 KB checked in by daisuke, 12 years ago (diff)

update to 1.2.2

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4%if "%{_dist_release}" > "vl6"
5%define nginx_user      www-data
6%else
7%define nginx_user      nginx
8%endif
9%define nginx_group     %{nginx_user}
10%define nginx_home      %{_localstatedir}/lib/nginx
11%define nginx_home_tmp  %{nginx_home}/tmp
12%define nginx_home_cache %{nginx_home}/cache
13%define nginx_logdir    %{_localstatedir}/log/nginx
14%define nginx_confdir   %{_sysconfdir}/nginx
15%define nginx_datadir   %{_datadir}/nginx
16%define nginx_webroot   %{nginx_datadir}/html
17
18Summary:        Robust, small and high performance http and reverse proxy server
19Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
20Name:           nginx
21Version:        1.2.2
22Release:        1%{?_dist_release}
23
24Group:          System Environment/Daemons   
25# BSD License (two clause)
26# http://www.freebsd.org/copyright/freebsd-license.html
27License:        BSD
28URL:            http://nginx.net/
29
30Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
31Source1:    %{name}.init
32Source2:    %{name}.logrotate
33Source3:    nginx-virtual.conf.template
34Source4:    nginx-ssl.conf
35Source5:    %{name}.sysconfig
36Source10:   nginx-vine.conf
37Source11:   nginx-default-vine
38Source20:   proxy_cache.conf
39Source100:  nginx-index.html
40Source101:  poweredby-vine.png
41Source102:  nginx-logo.png
42Source103:  nginx-50x.html
43Source104:  nginx-404.html
44%define ngx_fancyindex_version 0.3
45Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
46%define nginx_accept_language_module_version 02262ce
47Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
48%define passenger_version 3.0.12
49Source1020: passenger-%{passenger_version}.tar.gz
50%define upstream_fair_version 2131c73
51Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
52
53%define mod_wsgi_version 6975f0ec7eeb
54Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
55
56# removes -Werror in upstream build scripts.  -Werror conflicts with
57# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
58Patch0:     nginx-auto-cc-gcc.patch
59# configuration patch to match all the Vine Linux paths for logs, pid files
60# etc.
61Patch1:     nginx-conf.patch
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
64
65BuildRequires:      pcre-devel
66BuildRequires:      zlib-devel
67BuildRequires:      openssl-devel
68BuildRequires:      gd-devel
69BuildRequires:      perl
70BuildRequires:      perl(ExtUtils::Embed)
71BuildRequires:      libxml2-devel
72BuildRequires:      libxslt-devel
73BuildRequires:      curl-devel
74
75%if "%{?_dist_release}" == "vl4"
76Requires:           perl >= 5.8.6
77%else
78Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
79%endif
80# for /usr/sbin/useradd
81Requires(pre):      shadow-utils
82Requires(post):     chkconfig
83# for /sbin/service
84Requires(preun):    chkconfig, initscripts
85Requires(postun):   initscripts
86%if "%{_dist_release}" > "vl6"
87Requires(pre):      www-common
88%endif
89
90Provides: webserver
91
92Vendor: Project Vine
93Distribution: Vine Linux
94Packager: daisuke
95
96%description
97Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
98proxy server written by Igor Sysoev.
99
100%description -l ja
101Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
102堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
103 - HTTP(S) サーバ
104 - HTTP(S) リバースプロキシサーバ
105 - IMAP/POP3 プロキシサーバ
106
107%package passenger
108Summary: Nginx with mod_passenger support
109Summary(ja): Passenger サポート入りの Nginx
110Group: System Environment/Daemons   
111BuildRequires: ruby, rubygems, rubygem-rake
112Requires: nginx
113
114%description passenger
115Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
116This package contains nginx server with passenger support.
117
118%description -l ja passenger
119Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
120堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
121 - HTTP(S) サーバ
122 - HTTP(S) リバースプロキシサーバ
123 - IMAP/POP3 プロキシサーバ
124このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
125
126%prep
127%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
128
129%patch0 -p0
130%patch1 -p1
131
132%build
133# nginx does not utilize a standard configure script.  It has its own
134# and the standard configure options cause the nginx configure script
135# to error out.  This is is also the reason for the DESTDIR environment
136# variable.  The configure script(s) have been patched (Patch1 and
137# Patch2) in order to support installing into a build environment.
138
139export DESTDIR=%{buildroot}
140
141## build with passenger
142./configure \
143    --user=%{nginx_user} \
144    --group=%{nginx_group} \
145    --prefix=%{nginx_datadir} \
146    --sbin-path=%{_sbindir}/%{name} \
147    --conf-path=%{nginx_confdir}/%{name}.conf \
148    --error-log-path=%{nginx_logdir}/error.log \
149    --http-log-path=%{nginx_logdir}/access.log \
150    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
151    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
152    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
153    --pid-path=%{_localstatedir}/run/%{name}.pid \
154    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
155    --with-file-aio \
156    --with-ipv6 \
157    --with-http_ssl_module \
158    --with-http_realip_module \
159    --with-http_addition_module \
160    --with-http_xslt_module \
161    --with-http_image_filter_module \
162    --with-http_sub_module \
163    --with-http_dav_module \
164    --with-http_flv_module \
165    --with-http_gzip_static_module \
166    --with-http_random_index_module \
167    --with-http_secure_link_module \
168    --with-http_stub_status_module \
169    --with-http_perl_module \
170    --with-mail \
171    --with-mail_ssl_module \
172    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
173    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
174    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
175%if %{with wsgi}
176    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
177%endif
178    --add-module=passenger-%{passenger_version}/ext/nginx \
179%ifarch i686
180    --with-cpu-opt=pentiumpro \
181    --with-zlib-asm=pentiumpro \
182    --with-md5-asm \
183    --with-sha1-asm \
184%endif
185    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
186make %{?_smp_mflags}
187mv objs/nginx objs/nginx.passenger
188
189## build without passenger
190./configure \
191    --user=%{nginx_user} \
192    --group=%{nginx_group} \
193    --prefix=%{nginx_datadir} \
194    --sbin-path=%{_sbindir}/%{name} \
195    --conf-path=%{nginx_confdir}/%{name}.conf \
196    --error-log-path=%{nginx_logdir}/error.log \
197    --http-log-path=%{nginx_logdir}/access.log \
198    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
199    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
200    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
201    --pid-path=%{_localstatedir}/run/%{name}.pid \
202    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
203    --with-file-aio \
204    --with-ipv6 \
205    --with-http_ssl_module \
206    --with-http_realip_module \
207    --with-http_addition_module \
208    --with-http_xslt_module \
209    --with-http_image_filter_module \
210    --with-http_sub_module \
211    --with-http_dav_module \
212    --with-http_flv_module \
213    --with-http_gzip_static_module \
214    --with-http_random_index_module \
215    --with-http_secure_link_module \
216    --with-http_stub_status_module \
217    --with-http_perl_module \
218    --with-mail \
219    --with-mail_ssl_module \
220    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
221    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
222    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
223%if %{with wsgi}
224    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
225%endif
226%ifarch i686
227    --with-cpu-opt=pentiumpro \
228    --with-zlib-asm=pentiumpro \
229    --with-md5-asm \
230    --with-sha1-asm \
231%endif
232    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
233make %{?_smp_mflags}
234
235%install
236rm -rf %{buildroot}
237make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
238find %{buildroot} -type f -name .packlist -exec rm -f {} \;
239find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
240find %{buildroot} -type f -empty -exec rm -f {} \;
241find %{buildroot} -type f -exec chmod 0644 {} \;
242find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
243mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
244%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
245chmod 0755 %{buildroot}%{_sbindir}/nginx.*
246%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
247%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
248%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
249%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
250%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
251%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
252%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
253%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
254%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
255%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
256%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
257%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
258%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
259%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
260%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
261%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
262%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
263%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
264%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
265%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
266
267%if %{with wsgi}
268%{__install} -p -m 0644 \
269    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
270    %{buildroot}%{nginx_confdir}
271cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
272%endif
273
274# upstream fair module document
275cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
276
277touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
278
279# convert to UTF-8 all files that give warnings.
280for textfile in CHANGES
281do
282    mv $textfile $textfile.old
283    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
284    rm -f $textfile.old
285done
286
287%clean
288rm -rf %{buildroot}
289
290%post
291if [ $1 == 1 ]; then
292    /sbin/chkconfig --add %{name}
293fi
294update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
295
296%post passenger
297update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
298
299%preun
300if [ $1 = 0 ]; then
301    /sbin/service %{name} stop >/dev/null 2>&1
302    /sbin/chkconfig --del %{name}
303    update-alternatives --remove nginx %{_sbindir}/nginx.normal
304fi
305
306%preun passenger
307if [ $1 = 0 ]; then
308    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
309fi
310
311
312%postun
313if [ $1 == 2 ]; then
314    /sbin/service %{name} upgrade || :
315fi
316
317%files
318%defattr(-,root,root,-)
319%doc LICENSE CHANGES README
320%doc README.upstream_fair
321%doc %{?with_wsgi:README.mod_wsgi}
322%{nginx_datadir}/
323%{_sbindir}/%{name}.normal
324%{_mandir}/man3/%{name}.3pm.gz
325%{_initrddir}/%{name}
326%dir %{nginx_confdir}
327%dir %{nginx_confdir}/conf.d
328%config(noreplace) %{nginx_confdir}/conf.d/*.conf
329%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
330%config(noreplace) %{nginx_confdir}/sites.d/*
331%config(noreplace) %{nginx_confdir}/win-utf
332%config(noreplace) %{nginx_confdir}/%{name}.conf.default
333%config(noreplace) %{nginx_confdir}/mime.types.default
334%config(noreplace) %{nginx_confdir}/fastcgi_params
335%config(noreplace) %{nginx_confdir}/fastcgi_params.default
336%config(noreplace) %{nginx_confdir}/koi-win
337%config(noreplace) %{nginx_confdir}/koi-utf
338%config(noreplace) %{nginx_confdir}/%{name}.conf
339%config(noreplace) %{nginx_confdir}/mime.types
340%config(noreplace) %{nginx_confdir}/fastcgi.conf
341%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
342%config(noreplace) %{nginx_confdir}/scgi_params
343%config(noreplace) %{nginx_confdir}/scgi_params.default
344%config(noreplace) %{nginx_confdir}/uwsgi_params
345%config(noreplace) %{nginx_confdir}/uwsgi_params.default
346%if %{with wsgi}
347%config(noreplace) %{nginx_confdir}/wsgi_vars
348%endif
349%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
350%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
351%dir %{perl_vendorarch}/auto/%{name}
352%{perl_vendorarch}/%{name}.pm
353%{perl_vendorarch}/auto/%{name}/%{name}.so
354%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
355%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
356%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
357%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
358
359%files passenger
360%defattr(-,root,root,-)
361%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
362%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
363%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
364%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
365%doc passenger-%{passenger_version}/doc/template
366%doc passenger-%{passenger_version}/doc/users_guide_snippets
367%doc passenger-%{passenger_version}/doc/images
368%{_sbindir}/%{name}.passenger
369
370
371%changelog
372* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
373- update to 1.2.2
374
375* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
376- update to 1.2.1
377- change nginx user from nginx to www-data
378- R(pre): www-common
379
380* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
381- update to 1.2.0
382- update passenger to 3.0.12
383- drop http_upstream_keepalive
384
385* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
386- new upstream release
387
388* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
389- update to 1.0.12
390
391* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
392- update to 1.0.11
393- update passenger to 3.0.11
394
395* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
396- update to 1.0.10
397
398* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
399- update passenger to 3.0.9
400
401* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
402- update to 1.0.6
403
404* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
405- update to 1.0.4
406
407* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
408- add gnosek-nginx-upstream-fair module
409- add ngx_http_upstream_keepalive module
410
411* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
412- add nginx-passenger sub pakckage
413  - use alternatives to choose nginx with or without passenger
414  - add BR: ruby, rubygems, rubygem-rake
415
416* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
417- update to 1.0.2
418
419* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
420- update to 1.0.1
421
422* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
423- add bcond_with wsgi for mod_wsgi
424- add bcond_with passenger
425  - you need to install rake.gem to build with this option.
426- add Provides: webserver
427
428* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
429- new upstream release 1.0.0!
430
431* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
432- rebuild with perl-5.12.3
433
434* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
435- update to 0.8.54
436
437* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
438- update to 0.8.53
439- add nginx_accept_language_module
440
441* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
442- update to 0.8.50
443- update ngx-fancyindex to 0.3
444- add BR: libxml2-devel, libxslt-devel
445- add scgi_params* and uwsgi_params* to %%files
446
447* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
448- update to 0.8.35 (development version)
449- add sites.d/ to store vitualhost settings
450- split out default server settings to sites.d/default
451- add fancyindex module
452
453* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
454- new upstream release
455
456* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
457- update to 0.7.62 (included security fix: VU#180065)
458
459* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
460- fix typo
461
462* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
463- add translated descriptions
464
465* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
466- update 404.html/50x.html to use powered by vine logo.
467
468* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
469- initial build for Vine Linux
470- update to 0.7.61
471
472* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
473- init script updates from Gena Makhomed
474- remove nginx-upstream-fair
475
476* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
477-  update to 0.6.36
478
479* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
480- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
481
482* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
483- rebuild
484
485* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
486- update to 0.6.35
487
488* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
489- rebuild with new openssl
490
491* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
492- update to 0.6.34
493
494* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
495- Fix inclusion of /usr/share/nginx tree => no unowned directories.
496
497* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
498- update to 0.6.33
499
500* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
501- update to 0.6.32
502- nginx now supports DESTDIR so removed the patches that enabled it
503
504* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
505- init script fixes
506- resolve 'listen 80 default' [#447873]
507
508* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
509- update to 0.6.31
510
511* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
512- upate to new upstream stable branch 0.6
513- added 3rd party module nginx-upstream-fair
514- added default webpages
515
516* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
517- update init script to match recommended guidelines
518- add /etc/nginx/conf.d support [#443280]
519- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
520
521* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
522- add Requires for versioned perl (libperl.so)
523- drop silly file Requires
524
525* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
526- Autorebuild for GCC 4.3
527
528* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
529- update to 0.5.35
530
531* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
532- update to 0.5.34
533
534* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
535 - Rebuild for deps
536
537* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
538- update to 0.5.33
539
540* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
541- updated to 0.5.32
542- fixed rpmlint UTF-8 complaints.
543
544* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
545- added --with-http_stub_status_module build option.
546- added --with-http_sub_module build option.
547- added use of pcre-config --cflags
548
549* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
550- Update to 0.5.31
551- specify license is BSD
552
553* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
554- Add BuildRequires: perl-devel - fixing rawhide build
555
556* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
557- Update to 0.5.30
558
559* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
560- Update to 0.5.29
561
562* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
563- Update to 0.5.28
564
565* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
566- Update to 0.5.27
567
568* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
569- Update to 0.5.26
570
571* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
572- Update to 0.5.19
573
574* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
575- Update to 0.5.17
576
577* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
578- Update to 0.5.16
579- add ownership of /usr/share/nginx/html (#233950)
580
581* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
582- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
583
584* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
585- fixed package review bugs (#233522) given by kevin@tummy.com
586
587* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
588- create patches to assist with building for Fedora
589- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.