source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 6028

Revision 6028, 20.4 KB checked in by daisuke, 12 years ago (diff)

update to 1.2.0

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4%define nginx_user      nginx
5%define nginx_group     %{nginx_user}
6%define nginx_home      %{_localstatedir}/lib/nginx
7%define nginx_home_tmp  %{nginx_home}/tmp
8%define nginx_home_cache %{nginx_home}/cache
9%define nginx_logdir    %{_localstatedir}/log/nginx
10%define nginx_confdir   %{_sysconfdir}/nginx
11%define nginx_datadir   %{_datadir}/nginx
12%define nginx_webroot   %{nginx_datadir}/html
13
14Summary:        Robust, small and high performance http and reverse proxy server
15Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
16Name:           nginx
17Version:        1.2.0
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Daemons   
21# BSD License (two clause)
22# http://www.freebsd.org/copyright/freebsd-license.html
23License:        BSD
24URL:            http://nginx.net/
25
26Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
27Source1:    %{name}.init
28Source2:    %{name}.logrotate
29Source3:    nginx-virtual.conf.template
30Source4:    nginx-ssl.conf
31Source5:    %{name}.sysconfig
32Source10:   nginx-vine.conf
33Source11:   nginx-default-vine
34Source20:   proxy_cache.conf
35Source100:  nginx-index.html
36Source101:  poweredby-vine.png
37Source102:  nginx-logo.png
38Source103:  nginx-50x.html
39Source104:  nginx-404.html
40%define ngx_fancyindex_version 0.3
41Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
42%define nginx_accept_language_module_version 02262ce
43Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
44%define passenger_version 3.0.12
45Source1020: passenger-%{passenger_version}.tar.gz
46%define upstream_fair_version 2131c73
47Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
48
49%define mod_wsgi_version 6975f0ec7eeb
50Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
51
52# removes -Werror in upstream build scripts.  -Werror conflicts with
53# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
54Patch0:     nginx-auto-cc-gcc.patch
55# configuration patch to match all the Vine Linux paths for logs, pid files
56# etc.
57Patch1:     nginx-conf.patch
58
59BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
60
61BuildRequires:      pcre-devel
62BuildRequires:      zlib-devel
63BuildRequires:      openssl-devel
64BuildRequires:      gd-devel
65BuildRequires:      perl
66BuildRequires:      perl(ExtUtils::Embed)
67BuildRequires:      libxml2-devel
68BuildRequires:      libxslt-devel
69BuildRequires:      curl-devel
70
71%if "%{?_dist_release}" == "vl4"
72Requires:           perl >= 5.8.6
73%else
74Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
75%endif
76# for /usr/sbin/useradd
77Requires(pre):      shadow-utils
78Requires(post):     chkconfig
79# for /sbin/service
80Requires(preun):    chkconfig, initscripts
81Requires(postun):   initscripts
82
83Provides: webserver
84
85Vendor: Project Vine
86Distribution: Vine Linux
87Packager: daisuke
88
89%description
90Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
91proxy server written by Igor Sysoev.
92
93%description -l ja
94Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
95堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
96 - HTTP(S) サーバ
97 - HTTP(S) リバースプロキシサーバ
98 - IMAP/POP3 プロキシサーバ
99
100%package passenger
101Summary: Nginx with mod_passenger support
102Summary(ja): Passenger サポート入りの Nginx
103Group: System Environment/Daemons   
104BuildRequires: ruby, rubygems, rubygem-rake
105Requires: nginx
106
107%description passenger
108Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
109This package contains nginx server with passenger support.
110
111%description -l ja passenger
112Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
113堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
114 - HTTP(S) サーバ
115 - HTTP(S) リバースプロキシサーバ
116 - IMAP/POP3 プロキシサーバ
117このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
118
119%prep
120%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
121
122%patch0 -p0
123%patch1 -p1
124
125%build
126# nginx does not utilize a standard configure script.  It has its own
127# and the standard configure options cause the nginx configure script
128# to error out.  This is is also the reason for the DESTDIR environment
129# variable.  The configure script(s) have been patched (Patch1 and
130# Patch2) in order to support installing into a build environment.
131
132export DESTDIR=%{buildroot}
133
134## build with passenger
135./configure \
136    --user=%{nginx_user} \
137    --group=%{nginx_group} \
138    --prefix=%{nginx_datadir} \
139    --sbin-path=%{_sbindir}/%{name} \
140    --conf-path=%{nginx_confdir}/%{name}.conf \
141    --error-log-path=%{nginx_logdir}/error.log \
142    --http-log-path=%{nginx_logdir}/access.log \
143    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
144    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
145    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
146    --pid-path=%{_localstatedir}/run/%{name}.pid \
147    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
148    --with-file-aio \
149    --with-ipv6 \
150    --with-http_ssl_module \
151    --with-http_realip_module \
152    --with-http_addition_module \
153    --with-http_xslt_module \
154    --with-http_image_filter_module \
155    --with-http_sub_module \
156    --with-http_dav_module \
157    --with-http_flv_module \
158    --with-http_gzip_static_module \
159    --with-http_random_index_module \
160    --with-http_secure_link_module \
161    --with-http_stub_status_module \
162    --with-http_perl_module \
163    --with-mail \
164    --with-mail_ssl_module \
165    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
166    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
167    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
168%if %{with wsgi}
169    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
170%endif
171    --add-module=passenger-%{passenger_version}/ext/nginx \
172%ifarch i686
173    --with-cpu-opt=pentiumpro \
174    --with-zlib-asm=pentiumpro \
175    --with-md5-asm \
176    --with-sha1-asm \
177%endif
178    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
179make %{?_smp_mflags}
180mv objs/nginx objs/nginx.passenger
181
182## build without passenger
183./configure \
184    --user=%{nginx_user} \
185    --group=%{nginx_group} \
186    --prefix=%{nginx_datadir} \
187    --sbin-path=%{_sbindir}/%{name} \
188    --conf-path=%{nginx_confdir}/%{name}.conf \
189    --error-log-path=%{nginx_logdir}/error.log \
190    --http-log-path=%{nginx_logdir}/access.log \
191    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
192    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
193    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
194    --pid-path=%{_localstatedir}/run/%{name}.pid \
195    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
196    --with-file-aio \
197    --with-ipv6 \
198    --with-http_ssl_module \
199    --with-http_realip_module \
200    --with-http_addition_module \
201    --with-http_xslt_module \
202    --with-http_image_filter_module \
203    --with-http_sub_module \
204    --with-http_dav_module \
205    --with-http_flv_module \
206    --with-http_gzip_static_module \
207    --with-http_random_index_module \
208    --with-http_secure_link_module \
209    --with-http_stub_status_module \
210    --with-http_perl_module \
211    --with-mail \
212    --with-mail_ssl_module \
213    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
214    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
215    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
216%if %{with wsgi}
217    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
218%endif
219%ifarch i686
220    --with-cpu-opt=pentiumpro \
221    --with-zlib-asm=pentiumpro \
222    --with-md5-asm \
223    --with-sha1-asm \
224%endif
225    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
226make %{?_smp_mflags}
227
228%install
229rm -rf %{buildroot}
230make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
231find %{buildroot} -type f -name .packlist -exec rm -f {} \;
232find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
233find %{buildroot} -type f -empty -exec rm -f {} \;
234find %{buildroot} -type f -exec chmod 0644 {} \;
235find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
236mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
237%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
238chmod 0755 %{buildroot}%{_sbindir}/nginx.*
239%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
240%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
241%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
242%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
243%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
244%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
245%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
246%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
247%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
248%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
249%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
250%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
251%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
252%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
253%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
254%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
255%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
256%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
257%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
258%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
259
260%if %{with wsgi}
261%{__install} -p -m 0644 \
262    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
263    %{buildroot}%{nginx_confdir}
264cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
265%endif
266
267# upstream fair module document
268cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
269
270touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
271
272# convert to UTF-8 all files that give warnings.
273for textfile in CHANGES
274do
275    mv $textfile $textfile.old
276    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
277    rm -f $textfile.old
278done
279
280%clean
281rm -rf %{buildroot}
282
283%pre
284if [ $1 == 1 ]; then
285    %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
286fi
287
288%post
289if [ $1 == 1 ]; then
290    /sbin/chkconfig --add %{name}
291fi
292update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
293
294%post passenger
295update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
296
297%preun
298if [ $1 = 0 ]; then
299    /sbin/service %{name} stop >/dev/null 2>&1
300    /sbin/chkconfig --del %{name}
301    update-alternatives --remove nginx %{_sbindir}/nginx.normal
302fi
303
304%preun passenger
305if [ $1 = 0 ]; then
306    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
307fi
308
309
310%postun
311if [ $1 == 2 ]; then
312    /sbin/service %{name} upgrade || :
313fi
314
315%files
316%defattr(-,root,root,-)
317%doc LICENSE CHANGES README
318%doc README.upstream_fair
319%doc %{?with_wsgi:README.mod_wsgi}
320%{nginx_datadir}/
321%{_sbindir}/%{name}.normal
322%{_mandir}/man3/%{name}.3pm.gz
323%{_initrddir}/%{name}
324%dir %{nginx_confdir}
325%dir %{nginx_confdir}/conf.d
326%config(noreplace) %{nginx_confdir}/conf.d/*.conf
327%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
328%config(noreplace) %{nginx_confdir}/sites.d/*
329%config(noreplace) %{nginx_confdir}/win-utf
330%config(noreplace) %{nginx_confdir}/%{name}.conf.default
331%config(noreplace) %{nginx_confdir}/mime.types.default
332%config(noreplace) %{nginx_confdir}/fastcgi_params
333%config(noreplace) %{nginx_confdir}/fastcgi_params.default
334%config(noreplace) %{nginx_confdir}/koi-win
335%config(noreplace) %{nginx_confdir}/koi-utf
336%config(noreplace) %{nginx_confdir}/%{name}.conf
337%config(noreplace) %{nginx_confdir}/mime.types
338%config(noreplace) %{nginx_confdir}/fastcgi.conf
339%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
340%config(noreplace) %{nginx_confdir}/scgi_params
341%config(noreplace) %{nginx_confdir}/scgi_params.default
342%config(noreplace) %{nginx_confdir}/uwsgi_params
343%config(noreplace) %{nginx_confdir}/uwsgi_params.default
344%if %{with wsgi}
345%config(noreplace) %{nginx_confdir}/wsgi_vars
346%endif
347%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
348%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
349%dir %{perl_vendorarch}/auto/%{name}
350%{perl_vendorarch}/%{name}.pm
351%{perl_vendorarch}/auto/%{name}/%{name}.so
352%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
353%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
354%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
355%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
356
357%files passenger
358%defattr(-,root,root,-)
359%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
360%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
361%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
362%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
363%doc passenger-%{passenger_version}/doc/template
364%doc passenger-%{passenger_version}/doc/users_guide_snippets
365%doc passenger-%{passenger_version}/doc/images
366%{_sbindir}/%{name}.passenger
367
368
369%changelog
370* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
371- update to 1.2.0
372- update passenger to 3.0.12
373- drop http_upstream_keepalive
374
375* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
376- new upstream release
377
378* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
379- update to 1.0.12
380
381* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
382- update to 1.0.11
383- update passenger to 3.0.11
384
385* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
386- update to 1.0.10
387
388* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
389- update passenger to 3.0.9
390
391* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
392- update to 1.0.6
393
394* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
395- update to 1.0.4
396
397* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
398- add gnosek-nginx-upstream-fair module
399- add ngx_http_upstream_keepalive module
400
401* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
402- add nginx-passenger sub pakckage
403  - use alternatives to choose nginx with or without passenger
404  - add BR: ruby, rubygems, rubygem-rake
405
406* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
407- update to 1.0.2
408
409* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
410- update to 1.0.1
411
412* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
413- add bcond_with wsgi for mod_wsgi
414- add bcond_with passenger
415  - you need to install rake.gem to build with this option.
416- add Provides: webserver
417
418* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
419- new upstream release 1.0.0!
420
421* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
422- rebuild with perl-5.12.3
423
424* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
425- update to 0.8.54
426
427* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
428- update to 0.8.53
429- add nginx_accept_language_module
430
431* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
432- update to 0.8.50
433- update ngx-fancyindex to 0.3
434- add BR: libxml2-devel, libxslt-devel
435- add scgi_params* and uwsgi_params* to %%files
436
437* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
438- update to 0.8.35 (development version)
439- add sites.d/ to store vitualhost settings
440- split out default server settings to sites.d/default
441- add fancyindex module
442
443* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
444- new upstream release
445
446* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
447- update to 0.7.62 (included security fix: VU#180065)
448
449* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
450- fix typo
451
452* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
453- add translated descriptions
454
455* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
456- update 404.html/50x.html to use powered by vine logo.
457
458* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
459- initial build for Vine Linux
460- update to 0.7.61
461
462* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
463- init script updates from Gena Makhomed
464- remove nginx-upstream-fair
465
466* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
467-  update to 0.6.36
468
469* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
470- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
471
472* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
473- rebuild
474
475* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
476- update to 0.6.35
477
478* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
479- rebuild with new openssl
480
481* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
482- update to 0.6.34
483
484* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
485- Fix inclusion of /usr/share/nginx tree => no unowned directories.
486
487* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
488- update to 0.6.33
489
490* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
491- update to 0.6.32
492- nginx now supports DESTDIR so removed the patches that enabled it
493
494* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
495- init script fixes
496- resolve 'listen 80 default' [#447873]
497
498* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
499- update to 0.6.31
500
501* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
502- upate to new upstream stable branch 0.6
503- added 3rd party module nginx-upstream-fair
504- added default webpages
505
506* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
507- update init script to match recommended guidelines
508- add /etc/nginx/conf.d support [#443280]
509- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
510
511* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
512- add Requires for versioned perl (libperl.so)
513- drop silly file Requires
514
515* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
516- Autorebuild for GCC 4.3
517
518* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
519- update to 0.5.35
520
521* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
522- update to 0.5.34
523
524* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
525 - Rebuild for deps
526
527* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
528- update to 0.5.33
529
530* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
531- updated to 0.5.32
532- fixed rpmlint UTF-8 complaints.
533
534* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
535- added --with-http_stub_status_module build option.
536- added --with-http_sub_module build option.
537- added use of pcre-config --cflags
538
539* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
540- Update to 0.5.31
541- specify license is BSD
542
543* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
544- Add BuildRequires: perl-devel - fixing rawhide build
545
546* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
547- Update to 0.5.30
548
549* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
550- Update to 0.5.29
551
552* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
553- Update to 0.5.28
554
555* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
556- Update to 0.5.27
557
558* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
559- Update to 0.5.26
560
561* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
562- Update to 0.5.19
563
564* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
565- Update to 0.5.17
566
567* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
568- Update to 0.5.16
569- add ownership of /usr/share/nginx/html (#233950)
570
571* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
572- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
573
574* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
575- fixed package review bugs (#233522) given by kevin@tummy.com
576
577* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
578- create patches to assist with building for Fedora
579- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.