source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 12062

Revision 12062, 26.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.16.0
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51
52%define ngx_fancyindex_version 0.4.3
53Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
54
55%define nginx_accept_language_module_version 2f69842
56Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
57
58## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
59%define passenger_version 6.0.2
60Source1020: passenger-%{passenger_version}.tar.gz
61
62%define upstream_fair_version a18b409
63Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
64
65%define mod_wsgi_version 6975f0ec7eeb
66Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
67
68%define nginx_dav_ext_module_version 3.0.0
69Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
70
71# removes -Werror in upstream build scripts.  -Werror conflicts with
72# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
73Patch0:     nginx-auto-cc-gcc.patch
74
75# to fix https://svn.boost.org/trac/boost/ticket/8731
76Patch100:   boost-changeset_84950.diff
77
78# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
79Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
80
81# to fix compile error with C++11.
82Patch1000: passenger-5.0.28-boost.patch
83
84BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
85
86%if "%{_dist_release}" > "vl6"
87BuildRequires:      libboost-devel
88%endif
89BuildRequires:      libxcrypt-devel
90BuildRequires:      libnsl2-devel
91BuildRequires:      pcre-devel
92BuildRequires:      zlib-devel
93BuildRequires:      openssl-devel
94BuildRequires:      gd-devel
95BuildRequires:      perl
96BuildRequires:      perl(ExtUtils::Embed)
97BuildRequires:      libxml2-devel
98BuildRequires:      libxslt-devel
99BuildRequires:      curl-devel
100%if %{with geoip}
101BuildRequires:      GeoIP-devel
102%endif
103
104Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
105# for /usr/sbin/useradd
106Requires(pre):      shadow-utils
107Requires(post):     chkconfig
108# for /sbin/service
109Requires(preun):    chkconfig, initscripts
110Requires(postun):   initscripts
111%if "%{_dist_release}" > "vl6"
112Requires(pre):      www-common
113%endif
114
115Provides: webserver
116
117Vendor: Project Vine
118Distribution: Vine Linux
119Packager: daisuke
120
121%description
122Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
123proxy server written by Igor Sysoev.
124
125%description -l ja
126Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
127堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
128 - HTTP(S) サーバ
129 - HTTP(S) リバースプロキシサーバ
130 - IMAP/POP3 プロキシサーバ
131
132%package passenger
133Summary: Nginx with mod_passenger support
134Summary(ja): Passenger サポート入りの Nginx
135Group: System Environment/Daemons
136BuildRequires: ruby, rubygem-rake
137Requires: ruby, rubygem-rake
138%if "%{_dist_release}" >= "vl7"
139BuildRequires: ruby-devel, ruby-rubygems
140Requires: ruby-rubygems
141%else
142BuildRequires: rubygems
143Requires: rubygems
144%endif
145Requires: nginx
146
147%description passenger
148Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
149This package contains nginx server with passenger support.
150
151%description -l ja passenger
152Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
153堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
154 - HTTP(S) サーバ
155 - HTTP(S) リバースプロキシサーバ
156 - IMAP/POP3 プロキシサーバ
157このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
158
159%prep
160%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
161
162%patch0 -p0
163
164# pushd passenger-%{passenger_version}/ext/
165# %patch100 -p2
166# popd
167
168pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
169%patch101 -p1
170popd
171
172%if %{?_dist_release} == "vl7"
173pushd passenger-%{passenger_version}
174#% patch1000 -p1
175popd
176%endif
177
178%build
179# nginx does not utilize a standard configure script.  It has its own
180# and the standard configure options cause the nginx configure script
181# to error out.  This is is also the reason for the DESTDIR environment
182# variable.  The configure script(s) have been patched (Patch1 and
183# Patch2) in order to support installing into a build environment.
184
185export DESTDIR=%{buildroot}
186
187
188CONFIGOPTS="\
189    --user=%{nginx_user} \
190    --group=%{nginx_group} \
191    --prefix=%{nginx_datadir} \
192    --sbin-path=%{_sbindir}/%{name} \
193    --conf-path=%{nginx_confdir}/%{name}.conf \
194    --error-log-path=%{nginx_logdir}/error.log \
195    --http-log-path=%{nginx_logdir}/access.log \
196    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
197    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
198    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
199    --pid-path=%{_localstatedir}/run/%{name}.pid \
200    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
201    --with-file-aio \
202    --with-ipv6 \
203    --with-http_ssl_module \
204    --with-http_v2_module \
205    --with-http_realip_module \
206    --with-http_addition_module \
207    --with-http_xslt_module \
208    --with-http_image_filter_module \
209%if %{with geoip}
210    --with-http_geoip_module \
211%endif
212    --with-http_sub_module \
213    --with-http_dav_module \
214    --with-http_flv_module \
215    --with-http_mp4_module \
216    --with-http_gunzip_module \
217    --with-http_gzip_static_module \
218    --with-http_auth_request_module \
219    --with-http_random_index_module \
220    --with-http_secure_link_module \
221    --with-http_degradation_module \
222    --with-http_stub_status_module \
223    --with-http_perl_module \
224    --with-mail \
225    --with-mail_ssl_module \
226    --with-stream \
227    --with-stream_ssl_preread_module \
228    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
229    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
230    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
231%if %{with wsgi}
232    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
233%endif
234    --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
235%ifarch i686
236    --with-cpu-opt=pentiumpro \
237    --with-zlib-asm=pentiumpro \
238    --with-md5-asm \
239    --with-sha1-asm \
240%endif
241"
242
243
244## build with passenger
245./configure \
246    $CONFIGOPTS \
247    --with-cc-opt="%{optflags}" \
248    --add-module=passenger-%{passenger_version}/src/nginx_module
249
250make %{?_smp_mflags}
251mv objs/nginx objs/nginx.passenger
252
253## build without passenger
254./configure \
255    $CONFIGOPTS \
256    --with-cc-opt="%{optflags}"
257
258make %{?_smp_mflags}
259
260%install
261rm -rf %{buildroot}
262make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
263find %{buildroot} -type f -name .packlist -exec rm -f {} \;
264find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
265find %{buildroot} -type f -empty -exec rm -f {} \;
266find %{buildroot} -type f -exec chmod 0644 {} \;
267find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
268mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
269%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
270chmod 0755 %{buildroot}%{_sbindir}/nginx.*
271%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
272%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
273%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
274%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
275%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
276%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
277%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
278%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
279%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
280%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
281%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
282%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
283%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
285%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
286%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
287%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
288%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
289%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
290%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
291
292%if %{with wsgi}
293%{__install} -p -m 0644 \
294    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
295    %{buildroot}%{nginx_confdir}
296cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
297%endif
298
299# upstream fair module document
300cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
301
302# document for nginx-dav-ext-module
303cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
304cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
305
306touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
307
308# convert to UTF-8 all files that give warnings.
309for textfile in CHANGES
310do
311    mv $textfile $textfile.old
312    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
313    rm -f $textfile.old
314done
315
316%clean
317rm -rf %{buildroot}
318
319%post
320if [ $1 == 1 ]; then
321    /sbin/chkconfig --add %{name}
322fi
323update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
324
325%post passenger
326update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
327
328%preun
329if [ $1 = 0 ]; then
330    /sbin/service %{name} stop >/dev/null 2>&1
331    /sbin/chkconfig --del %{name}
332    update-alternatives --remove nginx %{_sbindir}/nginx.normal
333fi
334
335%preun passenger
336if [ $1 = 0 ]; then
337    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
338fi
339
340
341%postun
342if [ $1 == 2 ]; then
343    /sbin/service %{name} upgrade || :
344fi
345
346%files
347%defattr(-,root,root,-)
348%doc LICENSE CHANGES README LICENSE.dav-ext-module
349%doc README.upstream_fair
350%doc README.dav-ext-module.rst
351%doc %{?with_wsgi:README.mod_wsgi}
352%{nginx_datadir}/
353%{_sbindir}/%{name}.normal
354%{_mandir}/man3/%{name}.3pm.gz
355%{_initrddir}/%{name}
356%dir %{nginx_confdir}
357%dir %{nginx_confdir}/conf.d
358%config(noreplace) %{nginx_confdir}/conf.d/*.conf
359%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
360%config(noreplace) %{nginx_confdir}/sites.d/*
361%config(noreplace) %{nginx_confdir}/win-utf
362%config(noreplace) %{nginx_confdir}/%{name}.conf.default
363%config(noreplace) %{nginx_confdir}/mime.types.default
364%config(noreplace) %{nginx_confdir}/fastcgi_params
365%config(noreplace) %{nginx_confdir}/fastcgi_params.default
366%config(noreplace) %{nginx_confdir}/koi-win
367%config(noreplace) %{nginx_confdir}/koi-utf
368%config(noreplace) %{nginx_confdir}/%{name}.conf
369%config(noreplace) %{nginx_confdir}/mime.types
370%config(noreplace) %{nginx_confdir}/fastcgi.conf
371%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
372%config(noreplace) %{nginx_confdir}/scgi_params
373%config(noreplace) %{nginx_confdir}/scgi_params.default
374%config(noreplace) %{nginx_confdir}/uwsgi_params
375%config(noreplace) %{nginx_confdir}/uwsgi_params.default
376%if %{with wsgi}
377%config(noreplace) %{nginx_confdir}/wsgi_vars
378%endif
379%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
380%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
381%dir %{perl_vendorarch}/auto/%{name}
382%{perl_vendorarch}/%{name}.pm
383%{perl_vendorarch}/auto/%{name}/%{name}.so
384%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
385%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
386%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
387%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
388
389%files passenger
390%defattr(-,root,root,-)
391%doc passenger-%{passenger_version}/doc/*.md
392%doc passenger-%{passenger_version}/doc/*.txt
393%doc passenger-%{passenger_version}/doc/*.html
394%doc passenger-%{passenger_version}/doc/templates
395%doc passenger-%{passenger_version}/doc/users_guide_snippets
396%doc passenger-%{passenger_version}/doc/images
397%{_sbindir}/%{name}.passenger
398
399
400%changelog
401* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
402- updated to 1.16.0.
403- updated passenger to 6.0.2.
404- updated nginx-dav-ext-module to 3.0.0.
405- dropped Patch1001: fixed in upstream.
406
407* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
408- updated to 1.15.5.
409- updated passenger to 5.3.6.
410- updated ngx_fancyindex_version to 0.4.3.
411
412* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
413- updated to 1.13.9.
414- updated ngx-fancyindex to 0.4.2.
415- updated nginx-accept_language_module to git HEAD.
416- updated nginx-upstream-fair to git HEAD.
417- updated passenger to 5.2.1.
418- added Source2010 (nginx-dav-ext-module).
419- enabled --with-stream and --with-stream_ssl_preread_module.
420
421* Fri Sep  8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
422- updated to 1.13.5
423- updated passenger to 5.1.8
424
425* Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
426- updated to 1.13.4
427- updated passenger to 5.1.7
428
429* Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
430- updated to 1.13.3
431
432* Sat Jul  1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
433- updated to 1.13.2
434
435* Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
436- updated to 1.13.1
437- updated passenger to 5.1.5
438
439* Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
440- updated to 1.13.0
441
442* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
443- updated to 1.11.13
444
445* Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
446- updated to 1.11.12
447
448* Tue Mar  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
449- updated to 1.11.10
450- updated passenger to 5.1.2
451
452* Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
453- updated to 1.11.9
454
455* Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
456- updated to 1.11.8
457
458* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
459- updated to 1.11.6
460- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
461
462* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
463- updated to 1.11.3
464- updated passenger to 5.0.30
465
466* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
467- rebuild with gcc-5.4.0
468
469* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
470- updated to 1.10.1.
471- updated passenger to 5.0.28.
472
473* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
474- updated to 1.9.15
475
476* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
477- updated to 1.9.14
478- updated passenger to 5.0.27
479
480* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
481- new upstream release
482
483* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
484- updated to 1.9.12.
485- updated passenger to 5.0.26.
486
487* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
488- new upstream release
489
490* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
491- update to 1.9.10
492- update passenger to 5.0.24
493
494* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
495- update passenger to 5.0.23
496
497* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
498- new upstream release
499
500* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
501- new upstream release
502
503* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
504- new upstream release
505
506* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
507- new upstream release
508
509* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
510- update to 1.9.3
511- update passenger to 5.0.11
512
513* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
514- updated Source4 (ssl.conf).
515
516* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
517- update to 1.9.2
518- update passenger to 5.0.10
519- update ngx-fancyindex to 0.3.5
520
521* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
522- update to 1.6.2
523- update passenger to 4.0.52
524
525* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
526- new upstream release
527
528* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
529- rebuild with new environment
530
531* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
532- update passenger to 4.0.45
533
534* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
535- update to 1.6.0 (stable)
536
537* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
538- update fancyindex to 0.3.3
539
540* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
541- update to 1.5.10
542- update passenger to 4.0.37
543
544* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
545- rebuilt with GeoIP-1.6.0.
546- added Patch100.
547
548* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
549- update to 1.5.6
550- update passenger to 4.0.21
551
552* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
553- rebuilt with gd-2.1.0.
554
555* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
556- update to 1.4.1
557
558* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
559- update to 1.4.0
560- enable SPDY module
561
562* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
563- new upstream release
564- update passenger to 3.0.19
565- update ngx-fancyindex to upstream git master
566
567* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
568- new upstream release
569- update passenger to 3.0.17
570
571* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
572- rebuild with pcre-8.31
573
574* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
575- added http_geoip_module.
576
577* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
578- update to 1.2.4
579
580* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
581- update to 1.2.2
582
583* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
584- update to 1.2.1
585- change nginx user from nginx to www-data
586- R(pre): www-common
587
588* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
589- update to 1.2.0
590- update passenger to 3.0.12
591- drop http_upstream_keepalive
592
593* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
594- new upstream release
595
596* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
597- update to 1.0.12
598
599* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
600- update to 1.0.11
601- update passenger to 3.0.11
602
603* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
604- update to 1.0.10
605
606* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
607- update passenger to 3.0.9
608
609* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
610- update to 1.0.6
611
612* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
613- update to 1.0.4
614
615* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
616- add gnosek-nginx-upstream-fair module
617- add ngx_http_upstream_keepalive module
618
619* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
620- add nginx-passenger sub pakckage
621  - use alternatives to choose nginx with or without passenger
622  - add BR: ruby, rubygems, rubygem-rake
623
624* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
625- update to 1.0.2
626
627* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
628- update to 1.0.1
629
630* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
631- add bcond_with wsgi for mod_wsgi
632- add bcond_with passenger
633  - you need to install rake.gem to build with this option.
634- add Provides: webserver
635
636* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
637- new upstream release 1.0.0!
638
639* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
640- rebuild with perl-5.12.3
641
642* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
643- update to 0.8.54
644
645* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
646- update to 0.8.53
647- add nginx_accept_language_module
648
649* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
650- update to 0.8.50
651- update ngx-fancyindex to 0.3
652- add BR: libxml2-devel, libxslt-devel
653- add scgi_params* and uwsgi_params* to %%files
654
655* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
656- update to 0.8.35 (development version)
657- add sites.d/ to store vitualhost settings
658- split out default server settings to sites.d/default
659- add fancyindex module
660
661* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
662- new upstream release
663
664* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
665- update to 0.7.62 (included security fix: VU#180065)
666
667* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
668- fix typo
669
670* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
671- add translated descriptions
672
673* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
674- update 404.html/50x.html to use powered by vine logo.
675
676* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
677- initial build for Vine Linux
678- update to 0.7.61
679
680* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
681- init script updates from Gena Makhomed
682- remove nginx-upstream-fair
683
684* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
685-  update to 0.6.36
686
687* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
688- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
689
690* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
691- rebuild
692
693* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
694- update to 0.6.35
695
696* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
697- rebuild with new openssl
698
699* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
700- update to 0.6.34
701
702* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
703- Fix inclusion of /usr/share/nginx tree => no unowned directories.
704
705* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
706- update to 0.6.33
707
708* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
709- update to 0.6.32
710- nginx now supports DESTDIR so removed the patches that enabled it
711
712* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
713- init script fixes
714- resolve 'listen 80 default' [#447873]
715
716* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
717- update to 0.6.31
718
719* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
720- upate to new upstream stable branch 0.6
721- added 3rd party module nginx-upstream-fair
722- added default webpages
723
724* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
725- update init script to match recommended guidelines
726- add /etc/nginx/conf.d support [#443280]
727- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
728
729* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
730- add Requires for versioned perl (libperl.so)
731- drop silly file Requires
732
733* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
734- Autorebuild for GCC 4.3
735
736* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
737- update to 0.5.35
738
739* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
740- update to 0.5.34
741
742* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
743 - Rebuild for deps
744
745* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
746- update to 0.5.33
747
748* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
749- updated to 0.5.32
750- fixed rpmlint UTF-8 complaints.
751
752* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
753- added --with-http_stub_status_module build option.
754- added --with-http_sub_module build option.
755- added use of pcre-config --cflags
756
757* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
758- Update to 0.5.31
759- specify license is BSD
760
761* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
762- Add BuildRequires: perl-devel - fixing rawhide build
763
764* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
765- Update to 0.5.30
766
767* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
768- Update to 0.5.29
769
770* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
771- Update to 0.5.28
772
773* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
774- Update to 0.5.27
775
776* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
777- Update to 0.5.26
778
779* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
780- Update to 0.5.19
781
782* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
783- Update to 0.5.17
784
785* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
786- Update to 0.5.16
787- add ownership of /usr/share/nginx/html (#233950)
788
789* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
790- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
791
792* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
793- fixed package review bugs (#233522) given by kevin@tummy.com
794
795* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
796- create patches to assist with building for Fedora
797- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.