source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 12120

Revision 12120, 26.2 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.16.0
29Release:        2%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51
52%define ngx_fancyindex_version 0.4.3
53Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
54
55%define nginx_accept_language_module_version 2f69842
56Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
57
58## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
59%define passenger_version 6.0.2
60Source1020: passenger-%{passenger_version}.tar.gz
61
62%define upstream_fair_version a18b409
63Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
64
65%define mod_wsgi_version 6975f0ec7eeb
66Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
67
68%define nginx_dav_ext_module_version 3.0.0
69Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
70
71# removes -Werror in upstream build scripts.  -Werror conflicts with
72# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
73Patch0:     nginx-auto-cc-gcc.patch
74
75# to fix https://svn.boost.org/trac/boost/ticket/8731
76Patch100:   boost-changeset_84950.diff
77
78# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
79Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
80
81# to fix compile error with C++11.
82Patch1000: passenger-5.0.28-boost.patch
83
84BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
85
86%if "%{_dist_release}" > "vl6"
87BuildRequires:      libboost-devel
88%endif
89BuildRequires:      libxcrypt-devel
90BuildRequires:      libnsl2-devel
91BuildRequires:      pcre-devel
92BuildRequires:      zlib-devel
93BuildRequires:      openssl-devel
94BuildRequires:      gd-devel
95BuildRequires:      perl
96BuildRequires:      perl(ExtUtils::Embed)
97BuildRequires:      libxml2-devel
98BuildRequires:      libxslt-devel
99BuildRequires:      curl-devel
100%if %{with geoip}
101BuildRequires:      GeoIP-devel
102%endif
103
104Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
105# for /usr/sbin/useradd
106Requires(pre):      shadow-utils
107Requires(post):     chkconfig
108# for /sbin/service
109Requires(preun):    chkconfig, initscripts
110Requires(postun):   initscripts
111%if "%{_dist_release}" > "vl6"
112Requires(pre):      www-common
113%endif
114
115Provides: webserver
116
117Vendor: Project Vine
118Distribution: Vine Linux
119Packager: daisuke
120
121%description
122Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
123proxy server written by Igor Sysoev.
124
125%description -l ja
126Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
127堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
128 - HTTP(S) サーバ
129 - HTTP(S) リバースプロキシサーバ
130 - IMAP/POP3 プロキシサーバ
131
132%package passenger
133Summary: Nginx with mod_passenger support
134Summary(ja): Passenger サポート入りの Nginx
135Group: System Environment/Daemons
136BuildRequires: ruby, rubygem-rake
137Requires: ruby, rubygem-rake
138%if "%{_dist_release}" >= "vl7"
139BuildRequires: ruby-devel, ruby-rubygems
140Requires: ruby-rubygems
141%else
142BuildRequires: rubygems
143Requires: rubygems
144%endif
145Requires: nginx
146
147%description passenger
148Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
149This package contains nginx server with passenger support.
150
151%description -l ja passenger
152Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
153堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
154 - HTTP(S) サーバ
155 - HTTP(S) リバースプロキシサーバ
156 - IMAP/POP3 プロキシサーバ
157このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
158
159%prep
160%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
161
162%patch0 -p0
163
164# pushd passenger-%{passenger_version}/ext/
165# %patch100 -p2
166# popd
167
168pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
169%patch101 -p1
170popd
171
172%if %{?_dist_release} == "vl7"
173pushd passenger-%{passenger_version}
174#% patch1000 -p1
175popd
176%endif
177
178%build
179# nginx does not utilize a standard configure script.  It has its own
180# and the standard configure options cause the nginx configure script
181# to error out.  This is is also the reason for the DESTDIR environment
182# variable.  The configure script(s) have been patched (Patch1 and
183# Patch2) in order to support installing into a build environment.
184
185export DESTDIR=%{buildroot}
186
187
188CONFIGOPTS="\
189    --user=%{nginx_user} \
190    --group=%{nginx_group} \
191    --prefix=%{nginx_datadir} \
192    --sbin-path=%{_sbindir}/%{name} \
193    --conf-path=%{nginx_confdir}/%{name}.conf \
194    --error-log-path=%{nginx_logdir}/error.log \
195    --http-log-path=%{nginx_logdir}/access.log \
196    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
197    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
198    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
199    --pid-path=%{_localstatedir}/run/%{name}.pid \
200    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
201    --with-file-aio \
202    --with-ipv6 \
203    --with-http_ssl_module \
204    --with-http_v2_module \
205    --with-http_realip_module \
206    --with-http_addition_module \
207    --with-http_xslt_module \
208    --with-http_image_filter_module \
209%if %{with geoip}
210    --with-http_geoip_module \
211%endif
212    --with-http_sub_module \
213    --with-http_dav_module \
214    --with-http_flv_module \
215    --with-http_mp4_module \
216    --with-http_gunzip_module \
217    --with-http_gzip_static_module \
218    --with-http_auth_request_module \
219    --with-http_random_index_module \
220    --with-http_secure_link_module \
221    --with-http_degradation_module \
222    --with-http_stub_status_module \
223    --with-http_perl_module \
224    --with-mail \
225    --with-mail_ssl_module \
226    --with-stream \
227    --with-stream_ssl_preread_module \
228    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
229    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
230    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
231%if %{with wsgi}
232    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
233%endif
234    --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
235%ifarch i686
236    --with-cpu-opt=pentiumpro \
237    --with-zlib-asm=pentiumpro \
238    --with-md5-asm \
239    --with-sha1-asm \
240%endif
241"
242
243
244## build with passenger
245./configure \
246    $CONFIGOPTS \
247    --with-cc-opt="%{optflags}" \
248    --add-module=passenger-%{passenger_version}/src/nginx_module
249
250make %{?_smp_mflags}
251mv objs/nginx objs/nginx.passenger
252
253## build without passenger
254./configure \
255    $CONFIGOPTS \
256    --with-cc-opt="%{optflags}"
257
258make %{?_smp_mflags}
259
260%install
261rm -rf %{buildroot}
262make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
263find %{buildroot} -type f -name .packlist -exec rm -f {} \;
264find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
265find %{buildroot} -type f -empty -exec rm -f {} \;
266find %{buildroot} -type f -exec chmod 0644 {} \;
267find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
268mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
269%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
270chmod 0755 %{buildroot}%{_sbindir}/nginx.*
271%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
272%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
273%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
274%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
275%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
276%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
277%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
278%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
279%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
280%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
281%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
282%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
283%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
285%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
286%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
287%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
288%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
289%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
290%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
291
292%if %{with wsgi}
293%{__install} -p -m 0644 \
294    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
295    %{buildroot}%{nginx_confdir}
296cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
297%endif
298
299# upstream fair module document
300cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
301
302# document for nginx-dav-ext-module
303cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
304cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
305
306touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
307
308# convert to UTF-8 all files that give warnings.
309for textfile in CHANGES
310do
311    mv $textfile $textfile.old
312    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
313    rm -f $textfile.old
314done
315
316%clean
317rm -rf %{buildroot}
318
319%post
320if [ $1 == 1 ]; then
321    /sbin/chkconfig --add %{name}
322fi
323update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
324
325%post passenger
326update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
327
328%preun
329if [ $1 = 0 ]; then
330    /sbin/service %{name} stop >/dev/null 2>&1
331    /sbin/chkconfig --del %{name}
332    update-alternatives --remove nginx %{_sbindir}/nginx.normal
333fi
334
335%preun passenger
336if [ $1 = 0 ]; then
337    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
338fi
339
340
341%postun
342if [ $1 == 2 ]; then
343    /sbin/service %{name} upgrade || :
344fi
345
346%files
347%defattr(-,root,root,-)
348%doc LICENSE CHANGES README LICENSE.dav-ext-module
349%doc README.upstream_fair
350%doc README.dav-ext-module.rst
351%doc %{?with_wsgi:README.mod_wsgi}
352%{nginx_datadir}/
353%{_sbindir}/%{name}.normal
354%{_mandir}/man3/%{name}.3pm.gz
355%{_initrddir}/%{name}
356%dir %{nginx_confdir}
357%dir %{nginx_confdir}/conf.d
358%config(noreplace) %{nginx_confdir}/conf.d/*.conf
359%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
360%config(noreplace) %{nginx_confdir}/sites.d/*
361%config(noreplace) %{nginx_confdir}/win-utf
362%config(noreplace) %{nginx_confdir}/%{name}.conf.default
363%config(noreplace) %{nginx_confdir}/mime.types.default
364%config(noreplace) %{nginx_confdir}/fastcgi_params
365%config(noreplace) %{nginx_confdir}/fastcgi_params.default
366%config(noreplace) %{nginx_confdir}/koi-win
367%config(noreplace) %{nginx_confdir}/koi-utf
368%config(noreplace) %{nginx_confdir}/%{name}.conf
369%config(noreplace) %{nginx_confdir}/mime.types
370%config(noreplace) %{nginx_confdir}/fastcgi.conf
371%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
372%config(noreplace) %{nginx_confdir}/scgi_params
373%config(noreplace) %{nginx_confdir}/scgi_params.default
374%config(noreplace) %{nginx_confdir}/uwsgi_params
375%config(noreplace) %{nginx_confdir}/uwsgi_params.default
376%if %{with wsgi}
377%config(noreplace) %{nginx_confdir}/wsgi_vars
378%endif
379%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
380%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
381%dir %{perl_vendorarch}/auto/%{name}
382%{perl_vendorarch}/%{name}.pm
383%{perl_vendorarch}/auto/%{name}/%{name}.so
384%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
385%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
386%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
387%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
388
389%files passenger
390%defattr(-,root,root,-)
391%doc passenger-%{passenger_version}/doc/*.md
392%doc passenger-%{passenger_version}/doc/*.txt
393%doc passenger-%{passenger_version}/doc/*.html
394%doc passenger-%{passenger_version}/doc/templates
395%doc passenger-%{passenger_version}/doc/users_guide_snippets
396%doc passenger-%{passenger_version}/doc/images
397%{_sbindir}/%{name}.passenger
398
399
400%changelog
401* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-2
402- rebuilt with perl-5.26.
403
404* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
405- updated to 1.16.0.
406- updated passenger to 6.0.2.
407- updated nginx-dav-ext-module to 3.0.0.
408- dropped Patch1001: fixed in upstream.
409
410* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
411- updated to 1.15.5.
412- updated passenger to 5.3.6.
413- updated ngx_fancyindex_version to 0.4.3.
414
415* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
416- updated to 1.13.9.
417- updated ngx-fancyindex to 0.4.2.
418- updated nginx-accept_language_module to git HEAD.
419- updated nginx-upstream-fair to git HEAD.
420- updated passenger to 5.2.1.
421- added Source2010 (nginx-dav-ext-module).
422- enabled --with-stream and --with-stream_ssl_preread_module.
423
424* Fri Sep  8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
425- updated to 1.13.5
426- updated passenger to 5.1.8
427
428* Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
429- updated to 1.13.4
430- updated passenger to 5.1.7
431
432* Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
433- updated to 1.13.3
434
435* Sat Jul  1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
436- updated to 1.13.2
437
438* Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
439- updated to 1.13.1
440- updated passenger to 5.1.5
441
442* Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
443- updated to 1.13.0
444
445* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
446- updated to 1.11.13
447
448* Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
449- updated to 1.11.12
450
451* Tue Mar  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
452- updated to 1.11.10
453- updated passenger to 5.1.2
454
455* Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
456- updated to 1.11.9
457
458* Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
459- updated to 1.11.8
460
461* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
462- updated to 1.11.6
463- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
464
465* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
466- updated to 1.11.3
467- updated passenger to 5.0.30
468
469* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
470- rebuild with gcc-5.4.0
471
472* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
473- updated to 1.10.1.
474- updated passenger to 5.0.28.
475
476* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
477- updated to 1.9.15
478
479* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
480- updated to 1.9.14
481- updated passenger to 5.0.27
482
483* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
484- new upstream release
485
486* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
487- updated to 1.9.12.
488- updated passenger to 5.0.26.
489
490* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
491- new upstream release
492
493* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
494- update to 1.9.10
495- update passenger to 5.0.24
496
497* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
498- update passenger to 5.0.23
499
500* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
501- new upstream release
502
503* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
504- new upstream release
505
506* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
507- new upstream release
508
509* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
510- new upstream release
511
512* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
513- update to 1.9.3
514- update passenger to 5.0.11
515
516* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
517- updated Source4 (ssl.conf).
518
519* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
520- update to 1.9.2
521- update passenger to 5.0.10
522- update ngx-fancyindex to 0.3.5
523
524* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
525- update to 1.6.2
526- update passenger to 4.0.52
527
528* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
529- new upstream release
530
531* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
532- rebuild with new environment
533
534* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
535- update passenger to 4.0.45
536
537* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
538- update to 1.6.0 (stable)
539
540* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
541- update fancyindex to 0.3.3
542
543* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
544- update to 1.5.10
545- update passenger to 4.0.37
546
547* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
548- rebuilt with GeoIP-1.6.0.
549- added Patch100.
550
551* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
552- update to 1.5.6
553- update passenger to 4.0.21
554
555* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
556- rebuilt with gd-2.1.0.
557
558* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
559- update to 1.4.1
560
561* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
562- update to 1.4.0
563- enable SPDY module
564
565* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
566- new upstream release
567- update passenger to 3.0.19
568- update ngx-fancyindex to upstream git master
569
570* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
571- new upstream release
572- update passenger to 3.0.17
573
574* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
575- rebuild with pcre-8.31
576
577* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
578- added http_geoip_module.
579
580* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
581- update to 1.2.4
582
583* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
584- update to 1.2.2
585
586* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
587- update to 1.2.1
588- change nginx user from nginx to www-data
589- R(pre): www-common
590
591* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
592- update to 1.2.0
593- update passenger to 3.0.12
594- drop http_upstream_keepalive
595
596* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
597- new upstream release
598
599* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
600- update to 1.0.12
601
602* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
603- update to 1.0.11
604- update passenger to 3.0.11
605
606* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
607- update to 1.0.10
608
609* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
610- update passenger to 3.0.9
611
612* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
613- update to 1.0.6
614
615* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
616- update to 1.0.4
617
618* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
619- add gnosek-nginx-upstream-fair module
620- add ngx_http_upstream_keepalive module
621
622* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
623- add nginx-passenger sub pakckage
624  - use alternatives to choose nginx with or without passenger
625  - add BR: ruby, rubygems, rubygem-rake
626
627* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
628- update to 1.0.2
629
630* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
631- update to 1.0.1
632
633* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
634- add bcond_with wsgi for mod_wsgi
635- add bcond_with passenger
636  - you need to install rake.gem to build with this option.
637- add Provides: webserver
638
639* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
640- new upstream release 1.0.0!
641
642* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
643- rebuild with perl-5.12.3
644
645* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
646- update to 0.8.54
647
648* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
649- update to 0.8.53
650- add nginx_accept_language_module
651
652* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
653- update to 0.8.50
654- update ngx-fancyindex to 0.3
655- add BR: libxml2-devel, libxslt-devel
656- add scgi_params* and uwsgi_params* to %%files
657
658* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
659- update to 0.8.35 (development version)
660- add sites.d/ to store vitualhost settings
661- split out default server settings to sites.d/default
662- add fancyindex module
663
664* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
665- new upstream release
666
667* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
668- update to 0.7.62 (included security fix: VU#180065)
669
670* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
671- fix typo
672
673* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
674- add translated descriptions
675
676* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
677- update 404.html/50x.html to use powered by vine logo.
678
679* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
680- initial build for Vine Linux
681- update to 0.7.61
682
683* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
684- init script updates from Gena Makhomed
685- remove nginx-upstream-fair
686
687* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
688-  update to 0.6.36
689
690* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
691- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
692
693* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
694- rebuild
695
696* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
697- update to 0.6.35
698
699* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
700- rebuild with new openssl
701
702* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
703- update to 0.6.34
704
705* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
706- Fix inclusion of /usr/share/nginx tree => no unowned directories.
707
708* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
709- update to 0.6.33
710
711* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
712- update to 0.6.32
713- nginx now supports DESTDIR so removed the patches that enabled it
714
715* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
716- init script fixes
717- resolve 'listen 80 default' [#447873]
718
719* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
720- update to 0.6.31
721
722* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
723- upate to new upstream stable branch 0.6
724- added 3rd party module nginx-upstream-fair
725- added default webpages
726
727* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
728- update init script to match recommended guidelines
729- add /etc/nginx/conf.d support [#443280]
730- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
731
732* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
733- add Requires for versioned perl (libperl.so)
734- drop silly file Requires
735
736* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
737- Autorebuild for GCC 4.3
738
739* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
740- update to 0.5.35
741
742* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
743- update to 0.5.34
744
745* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
746 - Rebuild for deps
747
748* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
749- update to 0.5.33
750
751* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
752- updated to 0.5.32
753- fixed rpmlint UTF-8 complaints.
754
755* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
756- added --with-http_stub_status_module build option.
757- added --with-http_sub_module build option.
758- added use of pcre-config --cflags
759
760* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
761- Update to 0.5.31
762- specify license is BSD
763
764* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
765- Add BuildRequires: perl-devel - fixing rawhide build
766
767* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
768- Update to 0.5.30
769
770* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
771- Update to 0.5.29
772
773* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
774- Update to 0.5.28
775
776* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
777- Update to 0.5.27
778
779* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
780- Update to 0.5.26
781
782* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
783- Update to 0.5.19
784
785* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
786- Update to 0.5.17
787
788* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
789- Update to 0.5.16
790- add ownership of /usr/share/nginx/html (#233950)
791
792* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
793- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
794
795* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
796- fixed package review bugs (#233522) given by kevin@tummy.com
797
798* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
799- create patches to assist with building for Fedora
800- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.